Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Ford Edge Heads Up!!

buffalo78buffalo78 Posts: 36
A friend from work just picked up her EDGE SEL. Two days later she took it back to the dealer to have the remote start installed. On the way home her brakes locked up and the stabillity control indicator went nuts (flashing like a strobe light). Well after finally getting back to the dealership on the back of a tow truck, the dealer told her it wa the BOS (brake on/off switch) that as he claims they have had a problem with on the early production EDGE. The new ones have the problem already corrected. BUT.... of course no-one in the country has the part so she has been without her EDGE for almost a week! Might want to do some preventative maintenance and ask your dealer if your EDGE falls into the "early production" class and get the switch replaced.

Me, I haven't had any problems with my EDGE after 5K (knock on wood!!!). Only complaint is a rattle in the rear passenger side that I can't pin-point. Any body else have that issue?
Tagged:

Comments

  • steverstever Viva Las CrucesPosts: 41,957
    Makes you wonder if it was really related to the install of the remote start - maybe the dealer screwed up and is just blaming the BOS?

    Sounds like one to watch - if you hear a follow-up from her, please let us know.

    Moderator
    Minivan fan. Feel free to message or email me - stever@edmunds.com.

  • akirbyakirby Posts: 7,747
    That's what I was thinking. The dealer's explanation doesn't really make sense.
  • buffalo78buffalo78 Posts: 36
    Yeah, that is the first thing I thought of when she told me. Seems like an odd coincidence!!! I have to take mine in this week for an oil change and that darn rattle in the back, so I'll ask my dealer about it and let you guys know.
  • svofan2svofan2 Posts: 440
    Early production EDGE?....in July?....when the 08 are about to be released?....when you can not get an EDGE the way yu really wanted because there not so many available?....I smell a rat here...that is the reason why I believe those remote starters (as well as any other electronics)if they don't come from factory I don't want to know about...
  • staci01staci01 Posts: 2
    I'm having the same problem regarding the rattle in my 2007 ford edge. It is the clips in the sunroof. I have had my car in twice to the dealer (we bought the car 6 weeks ago) and I have another appointment today for the same problem. They have already replaced the clips twice (broken) but as soon as you open the roof and then close it, the clips break. Our service advisor said it is a design defect. The rattle drives me crazy and it just seems to get worse.
  • buffalo78buffalo78 Posts: 36
    Thanks for the reply. I haven't had it back in yet but I plan to in the spring when I can actually open it again :) Mine seems to be worse when the sun-shade is closed.
  • johnl80johnl80 Posts: 1
    I am having this weird delayed response when I step on the gas. Almost like a jerking or skipping of the engine. Does anyone else have this problem?
Sign In or Register to comment.