Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Chrysler 300 Outside temperature Sensor

warwar Posts: 1
edited March 9 in Chrysler
2005 300C has a problem keeping up to the outside temp. It sticks and is eratic. Any suggestions how to troubleshoot this problem?

Comments

  • lacadelacade Posts: 12
    All of them behave like that. Mine takes forever to update and is consistently 2C over. One would figure that at lest they would be somewhat accurate. Good thing is that this is the only issue I have with the car since I got it in Aug of 2004.
  • xtecxtec Posts: 354
    I've had alot of Chrysler products with the outside temp sensor,and found them to be accurate.My Charger works great and hasn't shown any problem as well as my priors cars I had.If your having problem you should have it checked out and if its under warranty it won't cost a thing.
  • smithedsmithed Posts: 444
    Mine always seems just a little high,too.
  • Enter the diagnostic menus (hold the Menu and Music buttons simultaneously for 7-10 sec) then page through the EVIC screens until you get to the raw temperature display. Press the > button and you can decrease the indicated reading by increments of 5 degrees.

    One day I found the indicated temperature reading way, way off. Up until that point I had thought it to be pretty accurate. I was planning to take the car to the dealer to find out what was wrong with the sensor. But then I found this little trick, and I got it back to reading normally all by myself. It took a couple more adjustments over the next couple of days (wife's car, which I don't drive that often), but now it's back to reading normally again.

    Try it... you might like it.
This discussion has been closed.