Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Hyundai Santa Fe TSBs

somedai1somedai1 Posts: 416
edited March 14 in Hyundai
Here's another - just to dedicate a section to TSB's - i had one fixed - TSB 06-20-003 for malfunctioning ambient (outside) temperature gauge
don't wait if you think your digital readout does not seem accurate - they have to fix under warranty... anyone else finding TSB's post here...

Comments

  • gizzer777gizzer777 Posts: 335
    On my Nov 06 build 2007 SF SE, the Temp sensor would sometimes show in the display and sometimes not...turns out it was wired incorrectly.
    The TSB was 07-90-001.

    It works now but is not accurate or close...usually misses by at least 10 degrees. Next oil change i shall check out the TSB above to see if that is the corrective measure or if there is one

    My driver's side window has begun to squeak a bit...I presume the regulator is going south (Mini Coopers are infamous As is BMW for that). TSB anyone, or just let them listen to it?

    There is no TSB for the map light issue (not illuminating when a door opens- design issue)...most dealers should know by now (early builds) but if not, set it up with Hyundai USA and they will get the dealer going with the kit to fix it. Must admit. Hyundaiusa listened on that one and reacted pretty quickly IMHO
  • roudy1roudy1 Posts: 36
    Gizzer,
    Concerning your window squeak...I took my SF in for service yesterday and mentioned a squeak in the driver's side window. They said it was a regulator and have ordered a new one...it will be installed under warranty.
  • gizzer777gizzer777 Posts: 335
    Thanks Roudy1...

    That's what I figured. My ex mini went thru 2 of them in 1 yr!!! Sorry this wound up in the TSB thread!
  • somedai1somedai1 Posts: 416
    http://www-odi.nhtsa.dot.gov/cars/problems/tsb/tsbsearch.cfm

    check this out - rather incomplete list found here - but may still be helpful....
  • somedai1somedai1 Posts: 416
    another helpful site

    www.hmaservice.com
  • somedai1somedai1 Posts: 416
    got a tsb fixed today - replace bank 2 oxygen sensor - didn't get the tsb # but it cites that the bank 2 sensor gives false readings to bank 1 so they replaced - we'll see if it corrects the problems and keeps the svc eng light off...
  • russo5russo5 Posts: 8
    CEL on waaaayyyy too much !!!!!!!! by russo5 Mar 31, 2008 (8:36 pm)
    I bought my SF in November and was pleased with it since I had heard so much about the reliability and great warranty.
    Now I'm not so sure.
    At about 6500 mls. the CEL came on but the motor was running fine. This happened late on a Sunday so I had to wait until Monday morning to take it in.
    I was told that it was just a code that needed to be cleared. Okaaay ???
    Then again at 7222 mls. I went to lunch with some family and when I got in and started it up it was fine but when I gave it gas the engine was misfiring and there was a bad hesitation when accelerating. At this point not only am I really embarrassed but I am really ticked off !
    I limped it to the dealer and after a while they came back and said that it was " all fixed and ready to go" . I asked the service manager why the engine was doing that and he just said " Oh, it was just needing to have the computer reset. There was a TSB on it and it should be fine now".
    Well once again the light went on at 7320 mls. on a Friday evening so I had to wait till Saturday to take it in. The service department closes at 6 p.m. so I had to leave work early to make it by then. When I get there at 5:20 p.m. I am told that the service techs had all gone home already. So I made an appointment for Monday.
    When I went out to the SF and got in I started it and the dang light turned off !!!!!!!
    I got out and talked with the service guy and he says " well it was probably just a ghost light or it just fixed itself" Are you kidding me? "GHOST LIGHT"
    At this point I am really unhappy with this SUV and I would be interested in getting out of it except its only worth about half of what I owe on it.
    I have an out of town trip planned in a month but now I have to be worried about ghost lights and TSB and whether my SF is going to decide not to fix itself while I am motoring down the interstate.
  • pelican19pelican19 Posts: 323
    i feel your pain but your frustration should be with your dealer not the Santa Fe. Its a machine and can break. Your issue sounds like a simple sensor problem and could be fixed quickly IF your dealer knew what they were doing. Codes should not be cleared until diagnosed. The computer should not be re-set. There is no such thing as a ghost light or the vehicle fixing itself. However, under certain conditions if the fault does not return the code is stored for reference and will clear the light. Short answer: Go to another dealer.
  • Hey guys,

    I've been browsing this message forum for a few days, and I was noticing that a lot of people are having window regulator problems. Is this a common issue with the 07' Santa Fe's? Does anyone have a 07/08 Santa Fe with like 50k on it? If so, what kind of issues have you had?

    I opted to go with the 3.3L V6 engine (Limited Model). I've heard that the 3.3L is a better engine than the 2.7, and I wanted the extra horsepower. Anyway's, I was wondering what kind of issues, if any at all, people on this forum are experiencing with this motor?

    Lastly, I decided at my last oil change (6k) to opt for the full synthentic oil. The car has a remote starter, so it tends to idle for an extended period of times. It's also run pretty hard on the highway, and it does see a lot of stop and go traffic. Anyway's, I decided that I am going to change the oil ever 5-6 k. What are your thoughts on that?

    Thanks much!

    Jeff
This discussion has been closed.