Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Mitsubishi Montero Maintenance and Repair

1101112131416»

Comments

  • My Sunroof just stopped working. I have a 2002 Montero. I had it opened today , but when I came home and tried to close it it wouldn't move. By looking at the responses from everyone here it seems to be the motor maybe???? But the only thing is I can hear my motor running and it sounds as if it's trying to catch and move. In the mean time I closed it by hand b/c of the possibility of rain. Can anyone tell me how much the part was and where is the cheapest place to get it opposed to getting it from the dealer???
  • jazoreojazoreo Posts: 5
    2000 Mitsubishi Montero AC compressor turns off when fan is set to 4.
    I have a 2000 Mitsubishi Montero with a strange problem. The AC compressor works when the cabin fan is set to 1,2 or 3 but the fan won't work. I can tell the compressor is on because cold air seeps out. When I turn the fan to setting 4 it starts blowing but the compressor turns off. Click the fan back to setting 1,2, or 3 and the fan turns off but the compressor turns back on. Any clue what could be happening?
  • jazoreojazoreo Posts: 5
    I have a 2000 Mitsubishi Montero. The back cargo door won't open. I can't find any access to the latching mechanism while the door is closed. I'm pretty sure the thing just needs lubed but I can't access it to lube it. Would any one know how I can get in and lube that latch so it will open while the door is stuck shut?
  • The fan quit working on my 2003 Montero Sport ES so I checked the fuses under the hood. The one for the fan had melted so I went to the dealership looking for a new one. He said I had to replace the entire fuse box - really when only one fuse burned out? They want $115 not to mention labor. Any idea where I could get one for less than that? I'm a single parent on a tight budget.
    Thanks!
  • perry1205perry1205 Posts: 1
    Mike, Sorry, I saw one of your old posts from 2009 regarding the installation of a new Instrument Panel Printed Circuit Board (part #MR532787) in your 2001 Montero. Did doing so "jack" with your odometer at all?
  • I had this happen to my 2001 Mitsubishi Montero Limited. Both Front Wheel Bearings went out within months of each other. Then not even a year later my rear end differentials went out. Now I am having overheating problems. I have over 259,000 miles on the car.
  • ranil1ranil1 Posts: 1
    Hi Dear,

    Did you find any solution for this problem...? I have the same issue with my 1998 Mitsubishi Montero. Please let me know.

    Thank you
  • I'm having the same issue..noticed when I placed a new battery it worked fine for a week. The car always acts up when it rain and of course when I take it to a mechanic it works just fine... I braking my head over this. Car has new spark plug, battery, spark plug wires, filter, gas cap, and sensors. If anyone has a suggestion it would be greatly appreciated! Oooo...mechanicS say the alternator is fine.
  • Hi everybody, I have 2001 Mitsubishi Montero LTD., I would like to change the fuel filter, which is located inside gas tank with fuel pump. Unfortunally I do not know original part number at Mitsubishi, that I can order. Can anyone help to me. Thank you very much.
  • I went online and googled mitsubishi parts and many sites came up where you can purchase the part locally. in one of those sites, I typed the vehicle info and chose fuel system and they show a diagram with the corresponding numbers. find the number and name of the part (in this case, "fuel filter") then you can order the part online at a discount. hope this suggestion helps !
  • musi_ocimusi_oci Posts: 8
    edited February 2013
    Hello,
    I have 2001 Mitsubishi Montero LTD, few month ago appeared problem with engine. I have to start engine for 2 or 3 times. When is running on position „P“ and you push gas pedal the engine is speeds up easily. But when you change the gear to the „D“ the engine starts shake up and runs sometimes not on all 6 cylinders. Then you drive and even if you floor it the engine will not rev up over 2500 rpm. At „P“ can rev up to red pole without any problems.
    I checked the fuel pump and cleaned it, I cleaned the injectors too. I tested the injectors, and they are working not equally but working. And after clean up it is still doing. Can anybody have similar experiences? Can anybody help, Thank you very much.
  • Had similar issue about 3 years back. Had to floor accelerator at times to keep car running. Try some cataclean & have accelerator plates adjusted. Car has now run well for a few years. Still need to press accelerator when starting on cold mornings. TK
  • cochcoch Posts: 1
    I have the same problem, you fixed it?
  • lheathcolheathco Posts: 1
    Going on fwy at 65 / 70 mpg. Timing Belt went out. It was replaced at 60,000. Thought I got a great deal, 4000 cash in November and this happened in Jan at 103,000 miles. In all probability it seems that being it is an interferance engine, that my valves are probably ruined. Got an estimate for 1800 to do the entire job. if so, ... should it just cut my losses and try to get another vehicle. This has insurance paid up for six months. Tags til next year, One owner, very nice looking with extras ? If I buy another used card, that could go too. Just at an impasse.
    Any suggestions? I guess to find out if valves are ruiner or not, still have to do the change for about 650.00 before a compression check can be performed.

    On top of that, I have two other FORDs that went out. different probs. Time to go for Honda or Toyota but they are so expensive. then again ...hmmm?
  • What was the outcome of your problem? I have just had the EXACT same sequence of events on my 2000 Mitsubishi Sport LS. As the mechanic drove it out of the bay, the power steering failed and no one could explain why. He said he went nowhere near it, and another garage, where I did my oil change the next day, backed up that the two are not related. Too much of a coincidence, though, as you say. We have replaced the pump two weeks ago, but p/s is still out and car is very, very hard to drive. Tomorrow, we will do a steering wheel fluid flush, as the mechanic says there must be air and dirt in the lines. This "air" in the lines seems to be the standard reply from everyone. Hoping to fix this. Car was great before, no problems for 8 years, even as a secondhand car.
  • IM LOOKING FOR THE CIRCUIT BOARD FOR THIS CAR, IF YOU HAVE THIS PART IN STOCK PLEASE LET ME KNOW, OR IF YOU HAVE ANY IDEA HOW TO FIX THE CIRCUIT? THANK YOU
Sign In or Register to comment.