Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Dodge Durango Transmission Problems

13»

Comments

  • throtel valve cable dealer part 80$ or just adust the cable at the throtel body works great for me
  • Our transmission started slipping/jerking as I was towing a 2300lb trailer with about 500 lbs of livestock in it. I was traveling up long grades when I felt it begin to slip. The engine is a V8, but not the Hemi. We have towed 10 times previously with this car and in mountainous areas with no trouble. I had the guy at Advance Auto check it out and everything on his instrument came up transmission. One the the items that showed up was Torque Converter. My husband was not with me so I parked the vehicle, rented a Ford F-150 and continued my trip. We are taking it in today to be checked out. What can we expect? I can't understand why this vehicle can't tow 3,000 lbs when on paper it's supposed to tow more. Prior to our owning it for the past 10 months, it only had one owner who never towed with it and used for local driving.
  • i was going to work the other day stoped picked up a friend went backed up whent put it in drive spit like it was going to stall the check engine lite came on pulled the code it was a p-0700 witch is a computer control module when i leave from a stop sign i have first gear up intill 2500 to 3000 rpm no matter how i drive it once i hit them rpms it shifts passed 2nd and goes in to drive wont shift in to second automaticaly have to do it manualy wont kick down in to second wont kick down in to first just stays in drive wont shift in to over drive changed fluids and filters no metal in the pan stumped been working on it all day anone got any answers other that to shot it
  • I have a 2000 Dodge Durango it has a 5.2. It only has 2nd and 3rd gear doen't go in overdrive. The engine light comes on and the code reads P0749. When you reset it by unplugging the battery it shifts 1st thru 3rd everytime then when it gets to overdrive light comes on and has no o/d. Then when you stop it starts out in 2nd shifts to 3rd only. Limp mode. Replaced tranny twice same problem. :cry:
  • Sounds almost the same problem I am having. My husband is going to try changing the computer tomorrow. Have you fixed yours yet?
13»
Sign In or Register to comment.