Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Cougar Support Group - Chats On...

19192949697

Comments

  • sduff68sduff68 Posts: 51
    Just checking in after a long while,

    I am the owner of a 1999 Mecury Cougar (V6, 5 speed MTX, sport package) that presently has over 100,000 miles. I was one of the original posters in this group under a different name (dgemini).

    Other than a broken throttle (which may have been my fault), the remote opening trunk (which sticks), a remote control that died (didn't realize how easy it was to re-program yourself). and the window weather stripping (still works but is no longer black...actually looks "moldy") it has been a fine vehicle.

    Unfortunately it was out-classed not long after it came out by the competition, and Ford decided they did not want to invest any money in it to make it better. It is still a great looking vehicle, people still sometimes don't know what it is.

    I hate that the re-sale is so poor on the vehicle. I am in the market for a new vehicle now, and I don't think it is worth it to even trade it in.

    However, keeping the vehicle isn't such a bad idea since it still runs well and gets pretty good gas mileage (can get 18-20 mpg city if I baby it). When I finally move up to a four door pick-up I will probably just keep the Cougar until the Lord tells me to give it away to someone.

    Take care all and God bless! What's up Badulah and all you other old timers!!!
  • sduff68sduff68 Posts: 51
    Just read in an old message where someone paid 3,000 dollars for a cat in showroom condition with only 57,000 miles!

    My car really isn't worth trading in....

    I will really make sure I check out the re-sale values on future vehicles (one of the reasons why my last purchase was a Honday Odyssey!)

    I also don't plan on buying any more brand new vehicles, let someone else pay the depreciation.
  • gustafscgustafsc Posts: 361
    Good to hear from another 'experienced' forum member. Seems as though there's not a lot of us left. I've got 67K mi. on my '99, and it's still running OK. I get 22-23 mpg in mostly commuting traffic, so can't complain even with today's prices. The $3000 deal you read about sounds lke a panic sale to me. Either that, or one of the early 4cy models that NO ONE wants ;) As for me, when the time comes, I'll buy new as holding a car for 7-8 years amortizes the early depreciation vs. a used price with the associated risks. At least I know that my oil's been changed every 3k mi.

    SkipG
  • lmigliorelmigliore Posts: 148
    After my Cougar's sway bar bushing fix, I was driving to work and the shift linkage broke at a stop light, leaving me there with no way to get the car moving. I had it towed to the dealer. The problem was a $30 pin in the linkage. Unfortunately, the transmission had to be pulled to access the pin. $700 labor. Then the engine light went on; some module in the gas tank died. $60 module, $700 to put it in. Ecch.

    I bought a Lexus I300. The handling is unbelievably good and I hear they don't break much.

    So long and thanks for all the fish.
  • fish8fish8 Posts: 2,282
    I hadn't come here in awhile, so I decided to stop by. I got rid of my 1999 Cougar about 3 yrs ago, but some of these screen names sound familiar. Hope everyone is doing good and enjoying what they drive.
  • Sorry I have not checked in for a while. My 99 has just made 31,000K and we are ready to put ir up for the winter. Have not had any problems with it, am getting 27 MPG back and forth to work. Still runs good, wish they (Mercury) had stayed with it. Oh-Well. Any one heard from Badula or Lefty at all. I guess nobody much keeps a car as long as I do any more. The Cougar replaced a 1984 Turbo Daytona. We hope to keep the Cougar for at least another 5 years. It has been a great car so far.
    =^..^=
  • gustafscgustafsc Posts: 361
    I don't drop by as often as I used to, but I'm still here. My cat went over 70,000mi this morning on my way to work. Averaging just a touch over 10,000/yr, so I guess you'd say I'm a fairly low mileage driver for everyday useage. It'll be 7 years this coming Pearl Harbor day but seems like yesterday. Where does the time go? I did hear from Badulah about a month ago. He's been moving around and ended a long term relationship (girl, not car). Still driving his modified black Cougar and enjoying it. See you all later, Skip G.
  • duvelduvel Posts: 1
    Hello All - I have had a 99 Cougar since new (birthday present to myself!!) and recently have been experiencing the car locking itself without any use of the door locks or remote. The engine is running, I am outside scraping the ice off the outside and it locks itself!!
    This happens repeatedly (I can be outside or inside and the car is in Park)and makes it mandatory to always carry a spare set of keys!! Any ideas as to what may be causing the problem?
    Thanks.
  • I just traded in my 2000 Cougar last night :( . My Cougar was only 5 years old with 40,000 miles and had $1200 worth of labor it needed to replace a cracked oil pan... My mechanic, who is a very good friend, told me that this car was not going to be worth fixing if this was a sign of things to come. Soo, I bought an SUV and sad a teary eyed :cry: good bye to my Bella Mia last evening. I used to post here ages ago, I have no clue what my old name was..
  • lmigliorelmigliore Posts: 148
    My '99 never did this but I rented a Ford once that did; it locked itself with the engine running when I returned it.

    So that seems to be one failure mode of Ford door locks.

    Sorry but I don't know how to fix it.
  • bobw3bobw3 Posts: 2,997
    I have a '99 Cougar I bought in Nov'98, so one of the first of the new models. I now have 120K miles. I had to replace two alternators (at 68K & 110K miles), and then at about 115K miles the A/C compressor. All total, I've paid about $3,000 in repair costs in the past 7 years.

    Is this about average?
  • You're doing swell. I paid $3000 in repair costs for my '99 Cougar last August for sway bar bushings, a fuel pressure sensor and transmission linkage repair. Then I got rid of it.
  • gustafscgustafsc Posts: 361
    You know the claim aoubt 100,000 mi before a tuneup? BULL! At 72k mi, mine just died in front of the house. According to the CarX shop, it needed full plugs, ignition harness (arcing all over the place) and a new battery (not unexpected). But, to get to the plugs, you have to take the intake manifold off, so you can add in the cost of the gaskets. All in all, $575.00. I'm also loking at a complete brake replacement in the near future as the rotors are about shot. I figure that's about another $6-700. I am actively exploring the market during my lunch time, and have found a new '05 Saturn Ion Red Line for about $19.500. Weighs about the same as the Cougar, slightly roomier, and has a supercharged 200HP (0-60, 6.2sec) engine along with a lot of handling improvements. Maybe I'll take a test drive in the near future. ;) I did try the Scion Tc, but was disappointed in the feel of the car, and the trunk space under the hatch is a joke. :( I'll let the group know how thing turn out. Skip G.
  • Hi. We just bought a 99 Cougar, 2.5l V6 with 4 speed auto trans. The auto trans upshift from 1st to 2nd is noticeably firm or abrupt. Is this normal in this car? I did not notice it on the test drive. :mad:

    Thanks,

    Don M
  • gustafscgustafsc Posts: 361
    Well, I took that Saturn test drive, and was hooked :D With 200+HP(supercharged), roomier interior, slightly less weight, and more than adequate trunk space, the decision was made. As it was the last 2005 on the lot, it was marked down from ~$23K to $19750. Got the dealer to shave a few more bucks off, got the BB trade-in of $4K on the Cougar, and, after a ton of paperwork, took delivery last Monday. I was sorry to see my golden cat sitting off to the side, awaiting a cleanup to be set out for adoption, but life goes on, and I'm sure some kid will wind up driving off to the local passion pit with it as it's still a great looking ride. :shades: I'll miss the camaraderie and good times we've shared here, and will hold good memories of all. Skip G
  • I have a 2000 cougar that quit running when I was driving it. I replaced the fuel pump and it don't pump fuel. There is a buzzing noise like if a little electric motor is running under the hood. I don't know where it is coming from either. I don't know what to do. The pump doesnt pump fuel either. The fuze is good. The diode is good. The relay is good. Does anyone know what might be wrong or have a wiring diagram for the fuel pump? :confuse:
  • markphmarkph Posts: 1
    My Fan for the heater and a/c quit running. I can still feel heat coming up from the vent in the window. why did this happen
  • rgb2rgb2 Posts: 30
    I sold my Cougar a while back, but while still under warranty I had this happen. The dealer replaced some resistor to fix it. If I remember correctly, there was a TSB on this.
  • Hey all we just joined this forum. Heres my issue. About 3 Weeks ago my GF bought a 93 Mercury Cougar with 108,000 Miles on it. The issues that came up right away she was told by a passing motorist that her headlights blink. Also the radio started to not work right. The 1 thing I thought of was a short or bad ground in the system, but get this the car was low on power steering fluid so I filled it up then the radio started to work fine. Im totally lost on why that is as one should have nothing to do with the other. Last week my gf was accelerating over a hill and started losing power and droped in acceleration, the engine light came on then the car died. I had it taken in to a shop and they replaced the distributor. The car starts and everything now BUT now the battery light is on and the car ran like [non-permissible content removed]. Took it back and they adjusted the distributer off specs(from what there computer says.) until the car ran better they said they checked the battery and alternator and both were fine. The battery light is still on. I also noticed that at a red light when i turn the wheel the volts drop to like 11-12V and the rpms drop some then return to normal. I also have noise coming from the powersteering pump (been like that tho since we had the car). My gf explained to me at one point when driving that the car stop accelerating at 10mph and 40mph and when she pushed the gas a lil more there was no acceration for about 10-15 secs then slowly kick in. Apparently it only happened twice to her, as I have driven the car and not experienced this prob yet. I have no idea if this is an electrical or mechanical issue. Any help would be appreciated.
  • Same problem for me. If you have any of this answered I would greatly appreciate it. I am getting ready to replace the alternator AGAIN.

    Thanks
Sign In or Register to comment.