Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Isuzu Trooper Warning Lights and Gauges

13

Comments

  • will try this saturday.thanks alot for the reply.a concern of mine is that the 4 low always worked since i had it(4 months)then all the sudden the 4 low wont work.any ideas on why or what may have went bad?what should i check for the 4 low?thanks for any info.i need to get it fixed asap.
  • :cry: I have a 1989 Trooper, I was replacing the lights in the dash panel for the gauges and now the fuel, oil, temp gauges and RPM as well as the warning lights are not working.
    Is all those tied into the warning light relay?
  • Stever@EdmundsStever@Edmunds YooperlandPosts: 38,921
    That's good to hear - thanks for reporting back!
  • jbcol1jbcol1 Posts: 2
    Just recently on my 2002 Trooper the TOD display flashes the red CHECK light. In my problem, as soon as the engine starts the light starts flashing. Just the red CHECK light.
    My "Auto 4WD" does not seem to work. The 4WD low does work properly.
    I checked the vacuum solenoids and they seem to be functioning properly when I test them off the vehicle.
    Any ideas on where to go from here?

    John
  • brentb1brentb1 Posts: 18
    same problem i got here.pull your tod codes yourself manually.this will lead you to whats wrong
  • jbcol1jbcol1 Posts: 2
    I finally got them, 13, 14, 24..... haven't gotten any further yet. What did you find?
  • I recently had the intake manifold values replaced on my 1999 Trooper 3.2 and now I have a problem with my display of the TOD the rear wheel display green flashes and the check light flashes red. My 4 wd drive will engage and 4L has no problems. Sometimes the transmission will slip. Help any answers?
  • It is a 1999 trooper with TOD System with 132,400 miles and i have had all the pcv, sparks plugs, intake casket value,value cover set. fuel links & in 2007 timing belt redone and head casket on the left side. Now the right side head casket redone and i smell no oil burning. In the display i have the front wheels and rear wheels in the display and the rear wheels keep flashing green on and off and they the light that reads check comes in red in the display area and flashes on and off. No problems putting the vehicle in 4 wheel drive. It is the 3.5 liter engine I got when had around 78,560 miles and I am the 2nd owner of the vehicle and has all the goodies like the moonroof and captain seats and etc.
  • rrukrruk Posts: 2
    the car is a trooper 1999 vreg 3.0ltr td

    starts real nice, sounds like there is not anything wrong with the engine when its cold but when warm it makes a grateing noise comeing from with in the engine ..oil light only comes on at tick over and when warm ..im thinking oil pump or the balancer shaft is worn and this affects the oil pump when the engine is warm so im told ??? but sounds sweet again when cold ??

    any thoughts ..thanks rob
  • I found the problem to my TOD system. The flashing display light in the TOD area was losing the signal to the traction system in the rear end that was assoicated with the sensors in the rear wheels. Remember to reset the computer once you have fixed the sensors problem by disconnecting the battery to have the computer reset itself. I hope this helps anyone else out there.
  • i have a1999 trooper 3.5 can anyone tell me whats goin on my brake and battery warning light flickers on and off what do i need to do.
  • farmgoodefarmgoode Posts: 7
    check the fuild in the brake resivor./ bat lit could be bat. or the alt..
  • rfleminrflemin Posts: 5
    A while back I changed the front brake pads on my '98 Trooper. Following the advice on the 'net, I compressed the piston with a pair of Channelock pliers. Worked great, much easier than dragging out the big C-clamp. It did make the brake fluid reservoir overflow and the ABS light came on in the dash. Later I read that I should have opened the bleeder valves before compressing the piston. I tried bleed the brakes later, but the ABS light stays on. This happened once before, when I did some hard braking, and then eventually went away. I figure I have too much pressure in the ABS controller, but I can't see any way to bleed it. I had to have the back brake pads and calipers replaced in a shop and they could neither diagnose the ABS light problem or fix it. Anybody got any suggestions? Thanks.
  • rfleminrflemin Posts: 5
    Check and see if you have a loose or corroded connection between the battery and the fuse box. I had a similar problem (only worse) and that is what it was. At the end, I couldn't even shift gears until I got the fuse box rewired.
  • lorinprlorinpr Posts: 1
    I am lost when it comes to electical, throw a rod out the side of the block and no prob but all those wires get confusing! I have a 99 trooper and at first the brake light and battery light were on for awhile, I did a brake job and took care of that light. My blower wasn't working either and I found that the lead from alternator to relay wasn't hot (problem tracked down thanks to this forum) and got power back, don't know if the terminals were just corroded or lose, or maybe its one of those problems that just fixed itself, but that was only after I put in a special order for a new alternator thinking that it was going out. Everything seems to be fine, charging well and can run accesories and lights with no problem. Now that everything is working my battery and brake dummy lights are always on but are very dim, you can only see them in the dark. But when I set the parking brake it partially lights up the battery dummy light also????? I have heard that I may have lost a ground and that somthing is backfeeding through but what would it be?
  • Hey all,
    Just put a fresh 2.6 engine in a '91 trooper. It runs great but O2 and Check Engine lights on. Tried resetting but they come back. All I can think of is I hooked something up wrong but no clue where that might be. As I said it runs great so don't think it's a vacuum line or anything like that. Anyone have some guidance for me? Thanks.
  • I have a very similar problem on my 2002. How do you "pull the codes manually"? I rended an obd scanner but it says that there are no problems. Is there another place to plug in the scanner to get TOD problem codes?
  • My trooper dash goes constant green when i put the vehicle in 4wheel drive however the front wheel do not engage. Anyone with knowledge or problem please advise asap. 20 inches of snow in NJ.....
Sign In or Register to comment.