Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Dodge Dakota Radiator and Cooling Problems

124»

Comments

  • I recently bought a pre-owned (1 owner) '04 Dakota SLT Quad Cab 4X4 with 133K mi. It has been a great truck & I thought, living in the mountains in E Tennessee, would be an ideal vehicle for me, being an EMT (& an avid hunter), so I could still get out & make it to work during our occasional bouts of unpredictable inclement weather during the winter & quite honestly just to "play around" a little. However, I am now hesitant to even drive it a mere 35 miles to Chattanooga, as I have had some overheating issues since the weather has turned a bit chilly. The 1st incident was about a month ago during a weekend hiking trip to the Smoky Mountains. After an evening hike, on the way thru the winding roads in the National Park, the engine overheated & the heat would not work properly. I immediately pulled to the side of the road. After searching under the hood & finding nothing apparently wrong, I waited a good 45 mins to allow it to cool down. When i started out again, it began running properly & I had no more problems the rest of the way home. That week, I changed the Tstat & flushed the radiator & had no more issues until this morning (this is the 1st day since my hiking trip that it's been cold enough to use the heater). Now, it is overheating again. It runs at normal temp & everything is ok as long as the revs stay above 1500, but once it drops below, especially during idle (as you would expect, since there is less air moving across the radiator), the temp will rise & it will begin to overheat. Also, after starting & allowing it to run idle for about 15 mins this morning in the driveway, the air coming from the vents was still ice cold. Conventional wisdom would tell you the Tstat is bad, but as I said, I changed it about 3 weeks ago. Mechanics I have asked just sctatch their heads & have no idea what the problem could be. I hope someone out there has some answers, as I really don't want this to turn into bigger & more costly issues like a cracked head gasket & engine rebuild. Thanks for any suggestions you may have!
  • Run this by me again?

    You say that the engine is overheating, yet you are feeling cold air out of the vents?
    How is this possible, unless the vent vacumn operated heater door is not functioning or the heater core is not getting hot coolant from the engine coolant pump.
    Something is definitely not right because engine overheating and heater core still blowing cold air means that a blockage is possible somewhere.

    What kind of thermostat did you install ..a 195 degree or a 160?
    Is the thermostat installed correctly? The thermostat can be considered a one way valve when it finally opens when the temperature is reached. Install the thermostat incorrectly and it acts as a restriction to coolant flow and that could bring on those symptoms you are observing.

    Usally thermostats have a stamped "top" on it indicating the installation orientation, to avoid improper installation.

    If you are sure that the thermo is installed correctly, then there could be a restriction of coolant circulating throught the aluminum rad cross tubes.
    If corrosion build up in these, you may not see this corrosison and everything appears normal looking down the rad fill tube, but the rad could actually be partially blocked and that would cause engine overheating, unless the fan is moving enough air through the rad fins.

    so to summarize, possiblilties and things to check..

    1. thermostat (possibly) installed upside down
    2. thermostat not of correct temp range
    3. possible rad corrosion/blockage..in this case, the rad needs to be replaced
    4. Heater core blockage
    5. Heater/A/C vent vacumn operated doors or vacumn servo that operates them is not functioning correctly

    A fast way to check is to place a cardboard in front of the A/C condensor (the one in front of the rad) and cut a 8x8 hole in the middle to allow some air flow while engine is idling, or even running on the road.
    With heater running...if you are still getting cold air..you have some kind of blockage to the heater core, or the vacumn operated door heater vent are not working.

    If you start to feel some warm air coming out of the heat vents, then it's either the rad or the thermostat.
124»
Sign In or Register to comment.