Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Jeep Grand Cherokee Gauges

12357

Comments

  • john251john251 Posts: 1
    i seem to be having problems, hopefully minor.

    the fuel gauge drops out, low fuel light comes on, then it jumps right back to normal.

    any ideas ???
  • dawn16dawn16 Posts: 4
    i'm having same issues did you ever find out the problem?
  • tuggajbtuggajb Posts: 646
    i would try a new enigtion switch
  • Hi, I'm new to this site, so bare with me please!!
    We have a 2004 Grand Cherokee Limited. About a moth ago the windows would work 75% of the time, then 25% of the time and now not at all!! Also, the locks on the doors won't work, and the dome lights are on all the time while driving. The automatic preset seat button does not work either. The other night at 1am the headlights were turning on and off by themselves with nobody around the vehicle. Has anyone else had similar problems and if so, what did you have to do?
    PLEASE HELP!!!
  • kbtdelkbtdel Posts: 2
    Maybe someone can help me.

    A few months ago my gauges went crazy in our 96 Laredo 4.0 V6. The check gauges light light up. The dials then bounce off the scale back and forth. This happen a few times and then went away however, well driving it occur almost consistently. Now the gauges do not work at all sometimes they light up and bounce back and forth and then shut down.

    When you put the key in the ignition the only light that illuminates on the dash panel is the ABS light. I check for codes and there are none being thrown.

    Whatever circuit controls these dials and digital odometer meter also controls the electric windows because that does not work either.

    I thought bad ground so I check and clean the battery terminals. That did not resolve the issue. The jeep runs perfect. Everything except the gauges and the electric windows work including headlights etc.

    Can someone please advise what to look at? I check my fuses and I believe they are find. When the gauges come on I can raise the windows up and down but most of the time I lose power to that circuit before I can get the windows up or now. Right now they are down.
  • tuggajbtuggajb Posts: 646
    replace the ingnition switch one of contacs have gone bad
  • kbtdelkbtdel Posts: 2
    My issue ended up being a short somewhere in the radio area. I removed the radio and checked all connections. I put it back and everything so far as been fine. I suppose a power wire was grounding out against the metal frame work of the dash.
  • I have been having the same issue with my 2001 Jeep Grand Cherokee Limited of the door locks not working, the preset door settings, and the head lights coming on and off by themselves. Has anyone discovered a fix for this?

    Thanks!!
  • When I tap on the switches the fan speed control light comes half on the light behind the temp nob and direction nob are fine its just the light behind the left of the fan speed nob. So my question is, is there a bulb back there and its just loose or am I just that stupid(please dont answer that) can anyone help real quick?thanx. :confuse:
  • jaynote99jaynote99 Posts: 2
    I recently bought a 2006 Grand Cherokee limited with a Hemi. Yesterday I recieved a message saying "Service 4WD System", has anyone got this before? If so, what came out of it. It is driving me nuts, I have the car two weeks!!!
  • dkolczdkolcz Posts: 1
    ABS Light will come on only when raining or really damp outside ? Off when dry outside. Where are the sensors located.......any help will be appreciated

    Thanks
  • humbledhumbled Posts: 1
    Hey, I had the window issue also and it was 2 wires broken in the rubber boot between the body and driver door... as for the interior light issue and headlights coming on randomly... havn't figured out yet.
  • jcarey1jcarey1 Posts: 2
    I have a 99 4x4 Grand Cherokee Laredo and am having a problem starting. It only occurs from time to time. When I turn the key it clicks and all the gauges bounce back and forth and continue to bounce even after the key is removed. If I keep trying it will eventually start. The first time it happened I pressed the brake and the gauges registered normal and it started. This morning the gauges started bouncing again then it finally started but now the gauges are dead.
  • Climbing a grade (Mt. Hood area in Or) temp guage dropped to 0 and started smoking blue from tail pipe. When I shut it off, temp guage went to 150. 45 pounds oil pressure same as always. No smoke out of valve cover. Radiator cap has pressure. Engine seems to be cool, ample coolant in resovoir. After sitting for a while drove another mile to top of mountain, didn't smoke, didn't miss, but temp guage at 0. Any suggertions.
  • tuggajbtuggajb Posts: 646
    could just be temp sender blue smoke is oil smoke if you were pushing if could just be pluged pcv valve
  • Thank you Thank you Thank you. That's exactly what it was.

    francie
  • smithedsmithed Posts: 444
    All the panel warning lights were intermittently lighting up for a few seconds, then going back off. Thanks to what I've read here, it was easily fixed by cleaning the battery posts and cable terminals and tightening them down well. (2005 Grand Cherokee 3.7L) :shades:
  • I have a rubber hose coming off the front differential but the other end is not connected. Where does it get connected to? ABS light now stays on. I don't know if the two are related.
  • Hello,

    Can I continue about 100 miles to Amarillo with steady check engine light and codes p0204, p0208. Initial code read was reference to throttle position sensor, but that went away.

    Vehicle is 2000 Jeep Grand Cherokee V8 78K miles
  • tuggajbtuggajb Posts: 646
    mounted througj the backing plate in the rear mounted just below the capaler on the front
  • tuggajbtuggajb Posts: 646
    the ecm (engine control modgl) is on the pass side in the engine compartment right behind the ac aculmator (which swets real bad when running ac ) drips on computer plug in and gets contacte caroded

    disconect bat and remove plug clean contacts real carefuly (what i did was plug in and unplug couplt times put dilectic grease on contacts solved my prob
  • Hello, the rubber hose coming off the front differential is actually a breather for the front differential case... that hose is not supposed to be connected to anything.
    As far as the ABS light coming on... it could mean a number of things. Start by going to your local auto zone store and having them check the code, either that or buy your own generic scanner along with a service manual for your particular year and model to help guide you on what the code numbers mean. If I had to take a shot at it without looking at your vehicle, I would say it is associated with a front hub bearing, if the bearing is going bad it could create slop which in turn would cause the ABS light to come on due to the fact that the vehicle thinks it is actually slipping when in reality it is not.
    The only other thing I can think of is something to do with the ABS module... however I have not seen many cases of this... more or less it is always usually a bearing or corrosion in or around the sensor for the front wheel hub bearings.
  • hi

    i had similar problem, i had to change the coil pack. This is a comon fault with Jeeps. Also check the Lamda sensors (oxygen sensores)? is it running on LPG? if it is then replace the injectors.

    good luck
  • myposmypos Posts: 5
    After 250,000 miles I have had just about enough! 4 engines, brand new shock, got the death wobble, some brake issues and as if that's not enough now when i fill up the gas tank the gauge still reads empty. No more of that satisfaction of having the gauge read full and the gas light be off. When the problem first started i tried jiggling all the wires under the steering wheel, which made the gauge read about a quarter tank even though it was full and now just nothing, I have to go by the mileage. I am thinking it is a wire that has shorted somewhere because of that initial jiggle and got somewhat of a reading, however i have no idea which wire it may be or even worse if it is actually the sensor in the tank. If anyone has had this problem with solutions please please please let me know how you fixed it (for my sanity and the life of this '93 JGC). :cry: :sick: :lemon:
  • I just purchased an 03 Limited. The VIC display is blank. Is it possibly a blown fuse or something else?

    Scootter1
  • Checked all the fuse's and all is good. Any ideas?

    Scott
  • smithedsmithed Posts: 444
    " I am thinking it is a wire that has shorted somewhere because of that initial jiggle and got somewhat of a reading, however i have no idea which wire it may be or even worse if it is actually the sensor in the tank"

    I agree that it sounds like a wire problem if your "jiggle" did something. You need a wiring diagram, which I think you can find on line for your 15 year old JGC. :)
  • hurz2phurz2p Posts: 1
    I have a 1998 Jeep Cherokee sport that keeps blowing the airbag fuse causing the airbag light to come on. I replace the fuse and within 5 minutes of driving it blows again. Any ideas?
  • My airbag light stayed on and I thought it was the fuse too. I took it to the shop and they found that they connection in the back was loose. He plugged it back in and it never came on again. Might be that simple. Good luck!
  • My turn signals quit working the other day. When you turn the signal on to the left or the right they will work for a couple of seconds and then they quit working. It is not any of the bulbs, or the flasher. I replaced the flasher and they still do not work. Any ideas.
Sign In or Register to comment.