Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Chevy S10 - GMC S15 and Sonoma Vibrations

135

Comments

  • Before I rebuilt the drive shaft it would vibrate, accelerating from a stop but it is only vibrating at high speed now. If I accelerate slowly up to 70 MPH sometimes it will not vibrate to bad but as soon as it starts to vibrate I have to slow down to stop it. There is no sound associated with it just a vibration.
    Does the dealer recommend the spacer you installed?
    Thanks
    Phil
  • monsonmonson Posts: 5
    to everyone out there with the vibrations, i had the same problem with my 1995 sonoma. rotated tires balanced tires. i even put in new ujoints and carrier bearings, still vibrates. a driveshaft place said the yokes were bad and suggested making a one piece driveshaft. it took about 4 hours to make and about three hundred dollars. it took care of the problem. finally i can drive down the road without the vibrations and noise.
  • gonogogonogo Posts: 869
    Interesting post on vibration. Back in 2000 I test drove a extended cab and first thing I noticed was the vibration, mentioned it to the salesman and no comment. Later I learned the fix was the one piece drive shaft as monson stated.
  • I appreciate the feedback. Thanks for the reply. The car ran perfect when I bought it brand new and I can't imagine what could be wrong with it if the wheels, tires and drive shaft are all new and the pinion it good. I will take your advice into consideration if it is vibrating when I lift up the differential off the ground on blocks with the wheels off and it is still vibrating. The weather is bad this weekend but as soon as it clears up I will get back to you.
    Phil
  • monsonmonson Posts: 5
    phil
    i couldnt figure it out either basically no one could. it wasnt until the guy who worked on my truck spoke to the driveshaft place. the guy who worked on my truck couldnt. dont know it the problem will solve everybodys but i have the two piece driveshaft. the yolks were bad so t hey couldnt balance it. they suggested the one piece. i drove it down the interstate last night at 70 and had no noise or vibration. ive been putting up with it for about five months

    dave
  • Truck was recently purchased. 93 S10 Extended cab 4X4 short bed. Rear end started to howl, replaced with identical complete rear end and noticed when installing the drive shaft (1 piece) it was to tight, had to pry the reared back to get the universal joint in place. It was jammed between the transfer case and the rear differential, which would cause excessive pressure on the ring and pinion and eventual failure of the rear end. I found and ordered another drive shaft on eBay from a GMC the same year, body style, and engine as mine. When received, it is a two-piece with a center bearing. The one in the vehicle didn't have a center bearing nor does it have cross member to mount too. Does anyone know what the correct length of the drive shaft is? The original drive shaft that came out of it was 58", I am guessing the correct length should be somewhere between 56 and 57 .5 inches. Can anyone confirm this, and tell me where I can get one????Engine is a 4.3 Vortex, not sure of the transmission/transfer case. There are holes in the frame that look like a frame cross member could bolt into at the correct location to center the mounting of the center support bearing. I do not have a cross member there.
    It appears that a previous owner had put a lift kit on the truck then took it back off before I got it some brackets had been welded onto the frame at the suspension mounting areas but have been removed. That is probably the reason for the extra long drive shaft originally in the truck when I got it. We dropped the rear leaf springs when we originally replaced the differential and didn't notice how tight the drive shaft was any ideas or help would be appreciated

    ---------------------------------------------------------------------------------
  • gonogogonogo Posts: 869
    I would take the one piece shaft to drive shaft shop, they can shorten it for you.
  • I just got finished raising my S10 off the ground and taking it up to 85 MPH and to my surprise there was no vibration. Would this mean that one of my tires is defective?
    Phil
  • hoodlatchhoodlatch Mid-westPosts: 255
    I took your advice and fabricated the spacers. It's a lot better than it was. Thanks for the info. :D
  • hoodlatchhoodlatch Mid-westPosts: 255
    What did they say at the tire shop? What would happen if you took the back tires and swapped them with the ones on the front?
  • That is exactly the same thing that I was thinking of doing, Hoodlatch. I will go to the place where I bought the tires and have them rotate the tires and see what happens.
    Thanks for your advice!
    Phil
  • I had my tires rotated today and the vibration is still there. It is still on the left rear tire. When I had the car on blocks the other day I noticed that the tire was running about a wobbling about 3/8-1/2 inch while looking at the tire tread against the ground as it was rotating. The other rear tire was perfect. I will raise the car off the ground again, after the coming snow storm and check to see if the new tire on the rear is also wobbling. If it is do you think it could be the axle?
    Phil
  • hoodlatchhoodlatch Mid-westPosts: 255
    Short of being involved in a car accident, I haven't heard of it before.
  • You are a smart mechanic Hoodlatch. I took the car for a long ride today and it is definitely vibrating in the front left tire which is the same tire that was vibrating in the rear before I rotated them. As soon as I change the tire I will get back to you.
    Phil
  • This is a complex vibration. After changing the front left tire the vibration was still there. As I stated before the drive shaft was totally rebuilt and balanced twice and the tires were rotated and balanced twice. I made an appointment with a mechanic on Wednesday who thinks that it might be the differential ring gear. Would the ring gear make a noise if it was bad?
    Thanks
    Phil
  • hoodlatchhoodlatch Mid-westPosts: 255
    I'm confused. Does it have a noise problem, a vibration problem, is it in the front of the truck, at the back of the truck, a low speed vibration, high speed vibration. I don't see what the ring and pinion gear has to do with a vibration. :confuse:
  • 1, The truck had a small vibration at 52 - 54 MPH.
    2, 5 months ago I had 4 new tires put on. The vibration changed from 52 - 54 to when accelerating at start and again between 55 - 70 MPH.
    3, The tire store had all the tires re balanced but the vibration remained. The tire store drove the car and thought that it was the drive shaft.
    4, I had the drive shaft totally rebuild and balanced. The vibration at acceleration went away but it still vibrated at 55 - 70 MPH.
    5, The mechanic shop re balanced the drive shaft and the vibration was still there.
    6, I lifted the differential off the ground onto blocks and ran it in drive up to 80 MPH and there was no vibration at any speed.
    7, While on the highway I put my hand on the drivers door and the passenger door and the vibration was much more noticeable on the drivers door. There was no vibration on the steering wheel or my feet.
    8, I swapped the left rear tire to the front and the vibration went to the front.
    9, The tire store replaced the tire with a new one but it didn't help and the vibration is still in the front.
    10, I have a repair shop appointment on Wednesday.
    I am confused also.
    It is great to have you help me with this puzzle.
    Thanks
    Phil
  • 1, The truck had a small vibration at 52 - 54 MPH.
    2, 5 months ago I had 4 new Uniroyal Tiger Paw tires put on. The vibration changed from 52 - 54 to when accelerating at start and again between 55 - 70 MPH.
    3, The tire store had all the tires re balanced but the vibration remained. The tire store drove the car and thought that it was the drive shaft.
    4, I had the drive shaft totally rebuild and balanced. The vibration at acceleration went away but it still vibrated at 55 - 70 MPH.
    5, The mechanic shop re balanced the drive shaft and the vibration was still there.
    6, I lifted the differential off the ground onto blocks and ran it in drive up to 80 MPH and there was no vibration at any speed.
    7, While on the highway I put my hand on the drivers door and the passenger door and the vibration was much more noticeable on the drivers door. There was no vibration on the steering wheel or my feet.
    8, I swapped the left rear tire to the front and the vibration went to the front.
    9, The tire store replaced the tire with a new one but it didn't help and the vibration is still in the front.
    10, Today I got my truck back from the mechanic and he balanced and rotated the tires again. The vibration changed from 70 MPH to 60 MPH now and he thinks that it is vibrating from the rear of the truck. His best guess is that it is bad tires. Just to rule it out, if it was the differential and I put the car in neutral at 60 MPH should the vibration go away?
    Thanks
    Phil
  • hoodlatchhoodlatch Mid-westPosts: 255
    My 92 S10 came with Tiger Paws. I like Tiger Paw tires. For several years now I've been running Michelin only because Sam's and Wal-Mart quit stocking Tiger Paws.

    The most common problems I've encountered with differentials is the pinion seal starts leaking grease because of age or the pinion bearing is worn out and it knocks out the seal. The other is the carrier bearings get worn out and the rear end starts howling. In either case you would definitely know it.

    Some trucks have limited slip and when they get old the clutch packs get worn out. But in that case, the limited slip quits working and that's pretty much it.

    In all the above I haven’t ever came across a vibration problem in the differential unless it was just about to give it up. When the differential is sick it will let you know by noise and leaking grease, if it has grease left in it.

    I'm in the middle of replacing a rear wheel seal on mine. On mine you have to drop the inspection cover and remove a horse shoe keeper to pull the axle. It's kind of a throwback to the GM's of the early 50's. It's not that big of a deal but it has gone on long enough that everything is soaked with grease so I'll have to replace the brake shoes too.

    I guess you did check things like broken/worn shocks, broken leaf spring, loose spring shackles? Don't give up the ship. Half of being a mechanic is you need patience and the other half is you need to be persistent as a stubborn old weed. Good Luck
  • Hi Hoodlatch,
    I checked all the springs and the shocks and the differential is not making any noise. Since it only vibrates under load do you think a dynamometer would help locate the vibration?
    Thanks again, Kindly
    Phil
Sign In or Register to comment.