Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Chevy S10 - GMC S15 and Sonoma Vibrations

124

Comments

  • nelson76nelson76 Posts: 1
    I'm having the same problem with my 02 Chevy S10, I have uneven tire wear on the rears(tires spin a lot though with not a lot of accelerator depression) and the front left wheel has a wobbling sound at lower speeds, roughly 60-65 km/h. I don't get any vibration in the steering. I am going to re-grease and check wheel bearing since I've heard it may be causing the problem and rotate the tires. Are any of you getting a vibration while steering or is it just a noise? :confuse:
  • phil2252phil2252 Posts: 14
    Hi Hoodlatch,
    I finally had a chance to bring my S10 to the tire store. they changed all of the tires with Michillan Harmony tires. It may be because of the extra weight of the tires but the vibration has gone away except a little bit when I accelerate at 70 MPH (which is tolerable). But for any other speed it is running great.
    I wish I could tell you that it was the tires but I can't say. All I want to do is thank you for helping me get through this nightmare.
    I owe you my sanity.
    Phil
  • hoodlatchhoodlatch Mid-westPosts: 255
    Glad to here it all worked out in the end. I'm sure it was quite a quest for anybody.

    Another good S10 forum is Yahoo. I sometime pick up some good tips from the guys on it.

    Have a nice spring and enjoy the pretty weather.

    John
  • I have a 1991 S10 that has 130,000 miles on it. Recently I replaced the rear seal and then decided that it would be a good idea to rebuild my driveshaft. I replaced all of the U-joint bearings and the middle carrier bearing. I had take the driveshaft to a shop that specialized in driveshafts to replace that portion. I watched them replace everything and complete the balancing on the driveshaft. When I got back home, I replaced the driveshaft and took it out for a test drive. The truck vibrated at 32 mph and kept on vibrating as I accelerated. I took the truck back to the shop and they pulled out the shaft, rebalanced, and installed it. Vibration still there. The owner of the shop personally drove it and could no tell what the issue was. The truck is my weekend hauler, so I am now using it around the immediate area. Any help or suggestions would be greatly appreciated. Thanks.
  • hoodlatchhoodlatch Mid-westPosts: 255
    When you say rear seal are you referring to rear main bearing seal in the engine, or rear wheel bearing seal, or the pinion seal in the read end?

    I replaced the drive shaft in my 92 long bed last winter. It was cheaper to replace the cardone joints with regular U-joints. This causes a vibration :) till I get up to speed. The up side was the shop could build it for about $400. Less and when it's time to replace the u-joints I can do that myself.
  • I replaced both rear wheel bearing seals. Another thought is that I may have reassembled the rear end wrong... but it only seemed to go back together one way. May just have to put in a single axle.. Thanks
  • ok here is a question i desperatly need answered i just purchased a 96 s10 blazer 4x4 with the 4.3 vortec and the guy i bought it from lifted it and in the rear he just muved the back springs down on the shacle how do i lower the front so i can ride with stock highth
  • dbawseldbawsel Posts: 1
    edited August 2010
    i have a 2003 extreme with a vibration and roaring noise from rear of truck it vibrated the drive shaft bolts almost out only one was tight. rear end has plenty of dope .tires have 4000 miles on them. truck only has 55000 miles this is a joke every mechanic scratches there head and says it could b could b my [non-permissible content removed] someone know what it is im sure i just havent asked the right person yet.has anyone figured out what it is vibrating our trucks .thanks david
  • ronpatronpat Posts: 1
    2003 Chevy vibrates and roaring noise comes from rear of truck at 40 mph and up.
    Had the Chevy dealer replace 2 bearings in rear end but did not fix problem. Dealer says it might be the ring and pinion($800+ labor). I'm not sure I want to pay that kind of money that might fix the problem.
  • i lowered my 03 s10 extended cab with 1" coils and 2" spindles in the front and 4" blocks in the rear. i have 18 inch rims. sometimes when i turn the wheel right it makes a roaring noise. and sometimes it will switch and make the noise when i turn left. and stop making it to the other side. and even stranger sometimes it makes the same noise when i hit the brakes. and when it switches sides it stops when i hit the brakes. what the hell is going on?
  • wolf27wolf27 Posts: 1
    My truck makes like a whirling whistling noise when i hit 60mph it quiets down after 70mph. Nothing seem loose or anything but i dont remember hearing it before. Anyone have any ideas help me out. I hit the clutch in at 65mph and it goes away i just put in a new clutch slave cylinder and 4 days later it started to make the noise.
  • I have a 2002 Chevy S10 LS ZR2. It has 80,000 miles on it and runs great. I am just having a little problem with vibrations. I put new tires on not long ago and I had them rotated and it still shakes or vibrates. The back driver side tire wobbles and I have had them reblanced and it still wobbles. When i took my old tires off the front passenger side tire would fall over because the inside tread was worn down. I have gotten it aligned and I don't think my new ones are wearing. The vibration isn't as bad anymore. I also lifted my torsion bars so that the truck sits level. Could this cause any problem? I hope it isn't the drive shaft because I don't have the money for it. I think they sent me bad tires. Does anyone know what the problem could be?
  • bmockbmock Posts: 7
    I have a 99 Gmc sonoma and when i get on the gas and the arpm's get up about 2200 to about 2500 its a real loud rattle right at my feet on the drivers side floor board it sounds like it was coming from the flex joint right out of the manifold so i replaced the flex joint and it seemed alot better but its been a couple weeks since i did that and the rattles back now and i don't know what it is can u guys help me out?
  • gonogogonogo Posts: 871
    I would check your motor mounts.
  • bmockbmock Posts: 7
    The motor mounts look good but the rattle seems to only be coming from the drivers side right there at the manifold? u can't hear it or feel anything from the passanger side
  • gonogogonogo Posts: 871
    Loose shield?
  • bmockbmock Posts: 7
    The shield on the manifold? If ur talking about that no but it could be loose and maybe thats rattling i will check it out....another thing is there a spacer between the manifold and the downpipe? Because when we replaced the flex joint we just put some exhaust high temp. sealer on it
  • hoodlatchhoodlatch Mid-westPosts: 255
    my dad's s-10 had a rattle going on after my son borrowed it to tow a camper from mo to sc. at first i thought it was the heat shield on the cat. as it turned out it was some of the tile inside the cat had come loose and i had to change out the catalytic converter.
  • gonogogonogo Posts: 871
    Yes , manifold shield. To check converter per Hoodlatch, just go under with cold cat and hit it , if loose innards it will rattle.
  • bmockbmock Posts: 7
    I cut the cat out and put a straight pipe in it when i bought the truck but last night i took the down pipe loose and replaced the donut gasket and put alot of high temp. silicon on it and so far its not rattling anymore so i think its fixed...Thanks for all the help guys
Sign In or Register to comment.