Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Dodge Dakota: Problems & Solutions

1121122124126127144

Comments

  • cujo1cujo1 Posts: 2
    Thanks for the info. I know the recall for the dakota included the 2000 model do you know if it includes the 1999 Dakota also. Thanks
  • bpeeblesbpeebles Posts: 4,085
    The front end (upper ball joints) issue could only be on 2000 and newer. The design of the front end was changed to have rack-n-pinion steering starting in 2000.

    I also beleive this would be a four wheel drive issue.... the 2WD design is different.
  • I just purchased an 05 Dakota ST Quad. Love it with the 4.7 and tow pkg. :)
    anyway i noticed that the needles on the gauge cluster do not glow when the headlights are on. are they supposed to?
    everything else on the cluster seems to work properly.. all of the service lights work as well as the gauge faces. only the red needles themselves do not glow.

    if this is not a normal condition, is it something that i can fix? (im very experienced with component electronics repair.) or should i just drop it in for service and let them "find" the problem?

    i would hate to put it in the shop and lose use of it for a whole day if i can fix it myself.

    thanks for any help!

    -Joe
  • I have a mystery for you. On cold starts after putting my '02 Dakota in gear, I get a series of backfires and loss of power intermittantly. So far, I've replaced my water pump(leaking), plug wires & plugs, rotor cap, & crank sensor. I've had the fuel injectors and computer system checked several times with no problems showing. I, the dealership, and my expert mechanic have run out of ideas of what else could be wrong. Any ideas? Anyone else have this problem?
  • I recently overhauled a 97 dakota 3.9 engine. Nothing bore or ported, but replaced crankshaft and a piston, new rings and heads installed. I've received several P codes after engine installation. I've replaced crankshaft sensor, ignition coil, and now have a fuel injector code that points back to the PCM as the fault. (after replacing the component that the P code indicated crankshaft sensor and ignition coil the engine ran fine for a couple days then another fault) I check on a replacement PCM and was told that if I replaced it I would have to re program the module.

    So I guess my question is two fold here. Do I need to re program the PCM from one vehicle to another? And two, If I do then when I overhauled the engine could that of caused a need for re programing?
  • bpeeblesbpeebles Posts: 4,085
    Generally, each PCM is specific for a vehicle, year, engine, options, ...etc. and the programming is not "transferrable" to another vehicle. (unless you lucky enough to locate a donar-vehicle that is virtually identical in every way.)

    It is NEVER a good idea to swap out PCMs. Do not forget that re-programming is not a trivial task and may only be doable by a dealersip with the proper equipment. Even then, they are trained to install NEW (unprogrammed) PCMS and may not be able assist with a "swap". Some of the programming is not UNdoable for security reasons.

    Consider a PCM as part of the vehicle identity. (in fact the VIN is coded into it)

    My suggestion, forget about swapping out the PCM and look for other causes of the issues you are seeing. I would be looking for a poor ground or power connection to the PCM or an engine component.
  • dustykdustyk Posts: 2,926
    How many miles on the vehicle and what engine?

    Regards,
    Dusty
  • dustykdustyk Posts: 2,926
    Check the brakes and ensure their not dragging.

    How's the engine run? Good idle and no performance issues? If not, the intake manifold gasket may be bad.

    High mileage? Check the O2 sensor. Actually, just replace it if its over 100,000 miles. A check of the timing chain could be warranted as well if real loose.

    Regards,
    Dusty
  • Hi Everyone, I have a 01 QC 4x4 auto 4.7 and need to do a brake job. The parts list for the rears are 9 inch or 11 inch drums. I have just the regular 4x4 sport model, does anyone know what size they are? Should I take off a wheel and measure or are the 11 inch for optional brakes??
    Thanks
    Tom.
  • yoshioyoshio Posts: 18
    The engine light display suddenly lit on the dashboard of my 2001 dakota (4.7). I looked at the owners manual and it said it has to do with the emissions. I'm not able to get to a shop right away and need to drive the truck. How serious is this problem. Does anyone know what it could be? Or how to go about checking for the root of the problem?
  • 77,000 and 3.9 v6. Any thoughts?
  • I am having this same problem on my 1998 extended cab dakota sport with the 3.9l v-6. Did you ever find any information as to the cause of the problem? I am ready to try replacing the power train control module. Any help you can offer would be great.
  • johnc6johnc6 Posts: 2
    I have 30600 miles and decided to change the coolant and thermostat. First I was shocked that the thermostat replacement was $36 because you have to change the housing too. Then I crawled under the truck and the petcock is not visible. I looked all over, even pulling the plastic underbody down and it still wasnt visible.
    It looks like you have to pull the front bumper off to get to the petcock....if it`s even there. Does anyone know how to get to the drain without removing the front end ?
  • see post #2479 (near the bottom) for radiator petcock location.

    Are you sure that you have to change the thermostat housing when you change the thermostat?
  • I have a 98 dak that I did heads on this summer. My drain valve was on the driver's side of the radiator with a small rubber hose that wrapped over the valve knob. I had to remove one side of this hose and turn the knob. the coolant drained out of the hose and I believe the design was to prevent leaking out of the drain valve. I hope this helps.
  • johnc6johnc6 Posts: 2
    Hey guys, thanks for your responses. After reading Post # 2479 I went out to the garage and removed the plastic shroud under the radiator on the drivers side and I found the petcock. Originally I removed the shroud on the left side and of course it wasnt there. I have a Chiltons Manual and it never mentioned where it would be located. As far as replacing the thermostat housing, I don`t beleive it has to be replaced. The Chiltons book showed the thermostat in the housing as a normal
    installation. I think the guy at Auto Zone was just trying to run my bill up and make a commission.
    Anyway thanks for your help, this is a great website.

    John6 ">
  • when i have driven the truck for 20-30 miles or so and am going at highway speed, if i let off the gas the transmission will downshift from overdrive to the next lower gear and the rpm's go up to 3000 or more. the truck sould not downshift at speeds of 60 mph when i let off the gas. has anyone else had this problem ? If so, What was the fix/problem?
  • dustykdustyk Posts: 2,926
    First, to make sure what we are talking about, I define a "backfire" as the ignition of fuel somewhere in the down stream, or exhaust system of the vehicle.

    Two things are required for backfiring to occur: raw fuel and enough oxygen to allow combustion.

    A few more questions:

    How is the idle speed and quality, both cold and hot?

    How is the engine performance?

    How is the fuel consumption?

    Best regards,
    Dusty
  • mtrialsmmtrialsm Posts: 159
    I decided to replace the TPS on my truck, $33.00 and that did the trick!!!
    Cold starts are smooth and idles also very smooth!
    I hope my gas mileage goes back up also!
    61k miles and I'm still happy with my '01 Quad.
    MM
  • Thank You All B :shades: etter
  • 2001 quad: 4yrs and 6 months old. Was idling through local fair, when Rpm's dropped to 3-400. :( Throttling the gas had NO effect. Shut off A/C and radio while friend opened up the hood. 2 seconds later back to normal operation 600rpm.
    Figured I was skirting the new battery issue, but was convinced after Voltage check. Truck running fine with new battery. Just adding that I've read some odd problems with old batterys resulting in some weird problems, but never saw this one. Glad it didn't cut out while on the local or interstate.. :P Ger
  • bpeeblesbpeebles Posts: 4,085
    I have been reading about the woes and tribulations caused by OE (Original Equipment) batterys. I have been expecting the battery in my Dak to start to show signs of age... yet, after 5 Vermont winters, it is still going strong. In Vermont, 5-winters is a long time for any battery to survive.

    My guess is that it will fail suddenly ...perhaps this winter on a -20F morning 8-(
    When it does fail, I will be installing the most powerful battery that will fit in the batterybox.
  • We took our Dakota in when the Check engine light came on.

    this is what the dealer did:
    1, found on cyclinder mifiring and low compression
    2,.valve no sealing properly check out found low compressionon #1 cylinder remve left cylinder head and inpsect and found value not sealing properly, grind valves on all cylinders on left head. replace head gasket reseal, change oil and filter, install coolant and clear codes and road test.

    The service writer said that we need to have them do a BG treatment and the change the rear axle lubricant.

    Question:
    has anyone had a probleming wanting until the scheduled 36,000 miles on changing the rear axle lubricant? we have 13,000 miles and tow a Trail-lite batam Flyer traveler that weilghts 3,000 when loaded.

    Thanks,
    craigm2 :confuse:
  • bpeeblesbpeebles Posts: 4,085
    The only problems I have heard of is when folks did not use the required SYNTHETIC lube in the rear end when towing. Certainly, changing more frequently does not hurt.

    I changed my rear-end lube in about 20 minutes by sucking out the old then adding fresh lube... all thru the fill-hole. By doing it this way, there is much less possibility of introducing contaminants that could damage the internal-workings of the differential.
  • sunburnsunburn Posts: 319
    As previously mentioned, you should use the required 75W-140 synthetic lubricant in the rear differential if towing. Either Redline or Amsoil can be found for around $8/qt. If you use the Dodge synthetic, it is horrendously expensive. When I have provided the fluids, my dealer charges me $35 to change the rear diff fluid.
  • bonkozbonkoz Posts: 3
    Well I've had my axles replaced and slowing but surely the vibrations are coming back. This is going to be my third trip in for this. Any one know about NY's lemon law?
  • bookittybookitty Posts: 1,303
    Bruce, good move! When the battery engineers from the various suppliers would come to the plant for recommendations for OEM batteries on newly developed models of construction equipment, I would always talk to these guys. Some of them told me, that when buying a battery, to find the physically largest one that will fit into the box and clear the hood. Then, take these an weigh them. The heaviest wins. So I buy batteries with a ruler and a scale. Usually works. Manufacturers like to stay marginal with tires and batteries to save cost.

    Bookitty
  • dustykdustyk Posts: 2,926
    I think it's three attempts to fix the problem in 12 or 18 months.

    Regards,
    Dusty
  • sunburnsunburn Posts: 319
    I'm getting ready to do the 60K tune-up on my 02 QC this weekend and was putting together my parts list. I started looking for a PCV valve, and noticed what appeared to be one connected to the tubing coming from the top rear of each cylinder head. Are these the PCV valves?
  • dustykdustyk Posts: 2,926
    No. I'm not sure exactly what you might be describing at the moment, but the PCV valve attaches to the side of the oil filler tube just below the oil fill cap.

    Use care when removing the PCV valve. Unlike older engines, they twist in and lock into position. I found you need to remove the vacuum hose that goes to the PCV valve and a number of collateral items in the area in order to gain good access. I remove the air filter box.

    You can see the PCV valve, but there's enough stuff around it and in the area that twisting the valve to remove it is problematic.

    Best regards,
    Dusty
This discussion has been closed.