Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Chevy TrailBlazer Loss of power

13

Comments

  • Well it turns out that the issue with our TB was that the #1 cylinder coil was not operating properly, it had a Code P0301. It took it in and had it diagnosed and repaired, runs like new now, it cost $227 and change, but well worth it. I think it's time to invest in a code reader.
    The RPM gauge is working now, the mechanic said he did not do anything to it, so I'm not sure what the deal is with it.

    Eli
  • Worried about being killed at intersection. TB for no warning, has no power when pressing gas pedal. No warning when it is going to happen. Very random. NOT SAFE!!!!!
  • gmcustsvcgmcustsvc Posts: 4,001
    Hello Hjhildo,
    Have you had the vehicle diagnosed for the concern? How intermittent in the problem? Can you please e-mail me the VIN of the vehicle? Thank you,
    Mariah GM Customer Service
  • I had the trailblazer into the mechanic. There is NO code on my computer that even says this is happening. If no code, how can it be fixed? What is causing the problem? Will it happen to me in a life or death situation? It happens whenever.
  • I am extremely concerned about the gas pedal situation. Some one could be killed. The computer in the vehicle does not even acknowledge the problem. There is NO reason for a hardly used 2006 vehicle should have this problem or ANY year vehicle to have such a harmful problem.
  • greddengredden Posts: 30
    I had the same concern with my wife's 2005 Trailblazer. We almost caused a serious accident. It's a good thing the other drivers were paying attention. You are correct, there was never any codes either. I took it a dealer to be checked out and they found nothing. I then started search and found that there is a SB for this issue and it recommended having the computer software upgraded. It took the trailblazer back to the dealer and told then I wanted the upgrade. I had to give the copies of the information that I found and argue with them. They finally did it.
    I sometimes still experience some surges but the dealer says that GM tells them this is within their normal limits. They are going to think "normal limits" when this causes someone to die due to an accident.
  • I am having similar issues. I was driving down a straight road at about 35 mph and hit the brakes going up to a red light and all my internal lights and gauges went out. Headlights still worked, but all inside power went out. It has happened 3 times today, all around 0400-0430. The next thing that happens is the flat tire signal comes on, then the check engine light, and then all other instruments come back. However, the stereo stays off until I stop and restart the truck. It's an after-market, so I have to reset all my settings, as if I just installed the radio.
  • The vehicle was hooked up to computer. NO READING about faulty gas pedal. Happened twice so far, not a warning as to when it will happen again. Hoping it is not in an intersection and someone is killed.. There is NO power in the vehicle to move because the gas pedal does not react. The TB hardly has any miles on it, just 37000. I feel like I am driving a death trap, I should not have these worries or expences in a fairly new vehicle.
  • How do you get the computer software upgrade? Is it at chevy's expense? It's not MY fault the TB is broke. :cry:
  • Where is there an answer to my problem? It is a serious problem that chevy should be concerned about. It is not only me with the problem. It should be a recall before somebody is killed.
  • greddengredden Posts: 30
    Here is the information about the service bulletin. I had this done at it resolved all of my issues. The dealer charged me $85.

    Subject: Intermittent Stall During Low Speed Deceleration - kw 4.2 calibration LL8 PCM turn #PIP3304 - (01/21/2005)

    The following diagnosis might be helpful if the vehicle exhibits the symptom(s) described in the PI.

    Condition/Concern:

    Some 2005 models equipped with the 4.2L (VIN S - RPO LL8) may experience an intermittent stall or near stall during low speed deceleration. If the engine stalls, it will restart fine and no DTCs will be stored. Typically, this will only occur on low mileage vehicles.

    Recommendation/Instructions:

    If the SI diagnostics do not isolate a concern, the following information may help: If the 11th digit of the VIN is a 2 and the last 8 of the VIN is less than 52114278 or if the 11th digit of the VIN is a 6 and the last 8 of the VIN is less than 56105324, reprogram the PCM with the latest TIS2000 calibrations. An updated engine calibration has been released to address this issue. In TIS2000, this updated calibration is titled "new calibration to reduce the potential for a stall during low speed coast down". This calibration or any that follow are designed to address the above concerns.

    If the 11th digit of the VIN is a 2 and the last 8 of the VIN are greater than 52114278 or if the 11th digit of the VIN is a 6 and the last 8 of the VIN are greater than 56105324, the PCM already contains this updated calibration.

    Models:
    (05 Buick Rainier S1 T1 with the 4.2L VIN S Engine) and (05 Chevrolet TrailBlazer S1 T1 with the 4.2L VIN S Engine) and (05 GMC Envoy S1 T1 with the 4.2L VIN S Engine)
  • gmcustsvcgmcustsvc Posts: 4,001
    Hello Hjhildo,
    Have you had the vehicle into an authorized GM dealer to diagnose the concern? Would you please e-mail me your VIN so I can look into this further? I look forward to your response.
    Christina
    GM Customer Service
  • gmcustsvcgmcustsvc Posts: 4,001
    soldiermedic79,
    Good morning. Have you had your vehicle into an authorized GM dealer to diagnose your concerns? How long have you been experiencing this? Can you please e-mail your contact information, VIN, current mileage, and involved dealer? I look forward to your response.
    Christina
    GM Customer Service
  • I had the TB to a mechanic. The dealer is going to charge me too much just to read the computer..the same way the mechanic did! How do I email you to give my vin?
  • gmcustsvcgmcustsvc Posts: 4,001
    Gredden,
    How often are you experiencing these surges? Can you please e-mail me your VIV, current mileage, and involved dealer? I would like to look into this further for you.
    Christina
    GM Customer Service
  • gmcustsvcgmcustsvc Posts: 4,001
    hjhildo,
    If you click on gmcustsvc, after the post title and “by”, my e-mail information is located there. Please address it attention Christina. Thank you!
    Christina
    GM Customer Service
  • No, I have not had it looked at by my local dealer due to the fact that my local dealer wanted me to buy a new alternator from them for an engine whine that ended up being the idler pulley. My wife went to the same dealership to get a problem with her 2004 Trailblazer instrument panel looked at and ended up having to buy 2 control units because they didn't warranty the first one that ended up going out in 2 weeks.
  • mikesaintmikesaint Posts: 2
    edited November 2010
    Ok where to begin. Well I purchased a 02 trailblazer about 2 weeks ago. The previous owner told me it needed an o2 sensor and a rear reverse light, so I took it in for a diagnostics check. Only thing that came up was something about "emissions" which I was told was the o2 sensor, which I didn't have the cash at the time to change. So last week I was driving when all of a sudden I loss acceleration power, no electrical problems....yet. I coasted to the side of the road and restarted it, no problems after. This happened twice that week. But since then my left blinker would not work and the left blinker indicator stays on. Well 2 days ago I brought my 2 & 3 year old to a "Kid Friendly" haunted trail. Upon leaving there my truck had the loss of power happen again. This time I was going about 55 when it died....my Wife freaked!!! So I coasted to the side and tried the restart like the previous 2 times. This time nothing. It sounded like it wanted to start but wouldn't. Almost as if it wasn't getting any fuel. I turned the key into the first position and could hear the fuel pump. I did this about 10 times until it started, but then died again a second later...it was cold out so I walked back to the Haunted Trail and borrowed a friends car to take my wife and kids home, which they ended up freaking out when I left them... Anyways came back next day with a mechanic friend and it started right up.....BUT....on my way home my Buddy was behind me and said everytime I hit the brakes my reverse lights would come on, but the left side was so dim it was barely visible....that's when I noticed my left head light was barely lit and my left mirror had no power. When i got to a stop light I hit the left blinker signal and it stalled....but it started right back up. When I got home I took off the left rear tail light and the wire harness that connects to the tail light was all black, like it was burned. I disconnected it and my left front headlight or mirrors still do not work and it stalls when I use any turn signals!!!! My O2 is being changed 2moro. DOES ANYONE have any suggestions as to why my left side is not working correctly, and after I  disconnected the rear taillight why it still shuts off after I use my blinkers?
    Will a new O2 sensor stop it from stalling and potentially save me from an accident with my children in the car?

    PLEASE HELP!!!  
  • gmcustsvcgmcustsvc Posts: 4,001
    soldiermedic79,
    I apologize you are having trouble with your dealer. If you would like I would be happy to assist you in finding a different dealer and setting up an appointment to get your vehicle in. If you would like me to do so please e-mail me with your contact information and we can get this started for you.
    Christina
    GM Customer Service
  • So my o2 sensor is replaced, feels like i have more power. The mechanic found in my headlight that it was wired backwards, maybe that is why the rear taillight connector was burnt out, replaced that. All my lights work now but.......as i recall, everytime my car died was at night, and when I look back it was when my brights were turned on. Even now it dies when I turn them on......why? He couldn't figure it out with out taking apart everything....also my left side mirror still doesn't work. Also code p1481 and p1482 still comes up...any ideas about the headlight and why it kills my car? Also reduced engine power popped on again lastnight. I shut car down and restarted and it went away......any help or ideas would b nice. Thank!!!!!
Sign In or Register to comment.