Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Chevy TrailBlazer Loss of power

124»

Comments

  • burdawgburdawg Posts: 1,524
    The only time our 02 TB went into low power mode is when my wife tried to drive it backwards on the interstate in drive........Do you want me to look codes p1481 & 1482? They're both powertrain codes of course.
  • I had the same issue, NO code showed up. Ended up being the O2 sensor was bad....
  • jg11jg11 Posts: 1
    02 TB - Loss of power - engine rpm rises - buit loss of accelleration, power - does not matter is cold or hot engine

    Replaced fuel filter - no fix
    read where it could be O2 sensor, or fan clutch
    How would a bad fan clutch affect power?
    I hope that it is not the transmission.
  • burdawgburdawg Posts: 1,524
    Is it making a constant roaring noise? If the viscous clutch for the fan has gone out and it's running full on all the time, it saps a lot of power out of the engine due to the large size of the fan itself.
  • My fiance was driving her trailblazer this morning and experienced a sudden loss of power, and barely made it a few blocks back home. It barely had enough power to make it up a small grade hill. She made it home and turned off the car and called dealer. She then re-started the car and it drove fine. Dealer says it is the Fan Clutch, and to replace costs 1000.00! There was never any noise or overheating problem. How can this be the issue, and what fault code should I have seen? I asked for a paper readout of the fault codes and the dealer said he has no paper for his diagnostic read out! It looks like this is a very common problem with the 04 trailblazer, so why has this problem not been re-called by GM? Also, how do we know this was the issue and not a throttle body short in the wiring harness? I had her get the old Fan Clutch, so is there a way I can test to see if it was bad? Never leaked, made noise or anything!!
  • greddengredden Posts: 30
    Did the fan clutch fix the problem? This is exactly what mine did and I spent $85 on a software update that fixed the problem.
  • so far, the low power has not happened since they replaced the fan clutch, but from reading some of these posts, it appears its a intermittent problem and might not happen for weeks or days at a time. I'm just curious as to how they narrowed it down to the fan clutch when there was no indication that it was going bad. I know they run diagnostics, but does anyone know the DTC # for this problem?
  • klg1011klg1011 Posts: 1
    edited May 2012
    I own a 2008 TB LT it only has 42,227 miles on it and I have not had any problems with it until two weeks ago. It starting stalling on me while I was driving it. At first it was mainly at lights and then it stalled on me while I was driving on the interstate going about 65 mph. Of course it is past the 3/30000 warranty, but I took to a dealership that used to be a GM dealership locally here in town. They had it for a couple of hours running diagnostic testing and it stalled on them while it was in the racks and they pulled a P0601 code which was to replace the ECM/PCM. They also told me that it would be covered under GM Factory warranty and to take it to a GM dealership since they are no longer one. I took the car back to where I bought it and they wouldn't take my word for it and ran their own diagnostic testing and they said that they did not get the same code they only said the stering angle sensor needs replaced and of course it is NOT under warranty. How can two different places get two different codes???
    the the stering angle sensor cause the car to stall while I am driving it? Money is very tight and I don't want to pay for something if I don't need it.
  • Can someone/s please provide me with some feedback on solution besides go to the Dealer. I have a 2008 Chevy Trailblazer and just recently my idle engine light has came on. It comes and goes once I turn the engine off. It only comes on when I go around 30mph. When I go above that it runs smoothly. Then engine losses power and feels like it wants to shut off. I have over 90K miles. I have changed the oil, oil filter and air filter. I've never changed spark plugs so Im leaning towards that or the fuel filter.

    ANY IDEAS, THANKS

    GIO
  • Does your vehicle make a slight whinning noise when you first start it? We have a 2004 with the same mileage and had the same problem. It would stay running until you tried to give it gas but would not go nor had any power. Long story short, it was the Fan Clutch. This can be replaced very easily by youself, and you can save a few hundred bucks. I work on the road so had no choice but to go to dealer, but this is a common issue with this vehicle, and chevy needs to address this.
124»
Sign In or Register to comment.