Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Ford Taurus Fuel Pump

1234689

Comments

  • yes the car does run, only now after i run it for about 4 miles or let it idlel about 20 minutes then it shuts down and I am unable to start it again for about 2 to 3 hours. when it shuts down and i try to restart it, it souds like its not getting any gas, or theres no spark. does that make sence?

    open for anything , thank you guys again...
  • wrenchedwrenched Posts: 12
    This might sound really dumb but here goes. Is there a hose that is dedicated to venting the tank? If not does the car have a vented gas cap? This could be a simple case of just being vapor locked. In other words if the inside of the tank cant draw air from outside then it could be what they call vapor locking. Try running the fuel cap loose and see if the same problem persists and let me know.
  • oldfordmecholdfordmech Posts: 124
    If you have a FORD fuel cap it is vented to let air into the tank, DO NOT leave your cap loose.
    any excess pressure in the tank is stored in the fuel vapor canister. If you leave your cap loose, it could trigger your check engine light to come on.
    After it dies
    Remove the tire valve looking cap on the fuel rail and see if you get a shot of fuel or not. Press on the valve stem. DO NOT have your face over this valve when you press it.
    Let me know
    Cliff
  • wrenchedwrenched Posts: 12
    Just so ya know Cliff........................ been doing this about 20 years......... and it will not set an immediate code if she loosens the fuel cap for a couple of minutes. It has to have a couple of drive cycles on it before it will set that code. That code is for the evaporative emissions system and WILL NOT set immediately!! I thought this would be a good way for her to determine if its vapor locking once it dies. Ya know........... the car dies ........... loosen the cap.......... see if it starts and runs with full pressure!!! quick easy way to see if its vapor locked. Oh yeah .............. and in the future............ don't come back and make me look like I'm a complete fool................it REALLY pisses me off!!!!!!!!!!!!! Been doing this a helluva long time PROFESSIONALLY I might add............ with great success.......... I pretty sure I know what works and what doesn't!!!! Have a nice day!!
  • Well i did all the test with the fuel pressure regulator, checked the injectors and the fuel pressure, everything seems to be working as it should, the only thing that i have not checked is the ground running from the tank, I am getting ready to crawl underneath there and start from the Tank to the front of the car to see what i find, I do how ever need to check the throttle positioning sensor and degrease the rest of the car and around all the connectors because it is nasty I surprised anything is reading properly. My gas gauge is still not reading right however it is reading over a half a tank now.(progress maybe). If you have ANY OTHER SUGGESTIONS PLEASE LET ME KNOW. I REALLY APPRECIATE EVERYONE'S INPUT AND HELP...
  • Thanks I have the exact same problem and today it finally gave up the gun even when the car was cold.

    My mechanic said he thought it was the fuel pump also, problem is he says, is the fuel pump is an assembly that has a bunch of other components that costs in the neighborhood of $400.. Will look for a junk yard special or internet special.

    Thanks for the info.
  • coach59coach59 Posts: 5
    Where do you find the ignition modulator on a 94 Taurus. The book shows it as if it's right under the distributor cap but that does not seem to be the case. We're are trying to replace the plugs, plug wires, distributor cap, and modulator. The plugs also seem particularly hard to get to, especially the one underneath. What is the best way to do this? Do we need to remove other components?
  • oldfordmecholdfordmech Posts: 124
    I've been gone for a while, Still having problems ? What have you done &
    what did you find out ?
    Cliff
  • Hi, guys! I used to have a similar problem with my 1990 Ford Taurus L 3.0 6cly 4 door sedan, though live in Novosibirsk city. After being stranded several times, I also thought it was a pump: during the tests with pressure gauge, sometimes the pressure dropped to 28-29, and also PCM returned a code 41 "system lean" on daily basis after some 10 minutes of driving) so I have ordered a new pump from Walbro Inc. When it has finally arrived from U.S, I have replaced original Motorcraft's one -- only to find out the problem is still there.. luckily, it got reproduced in the garage, after several cranks and running idle.

    When engine started to about to stall, we quickly started probing all the wires under the hood and near tank to see if any wire makes the difference. Imagine, it was as simple as the plug to the ingition distributor: when pressed, the engine recovered quickly. Looks like one of the plug's pins got oxidized/covered with some corrosion over time, so the solution was basically to switch off the ignition, have the plug out and then back in.
    I think I should have done it earlier because I have seen the codes in memory: 14 (PIP circuit failure) and 18 (SPOUT circuit open or IDM circuit failure). I do advise to replug the connectors under the hood (incl. the PCM one) if you have your engine to randomly stall still.

    The other problem to find out was that the newly installed pump is probably also flawed:
    after returning home happily from the friend's garage 15 miles away, on the very next day, I heard no humming buzz from the pump on the key switch. The wires near the Ford's fuel shut-off switch (in the trunk) were warm. I measured resistance on the switch plug pins and it showed about 1.5 Ohm -- exactly the same value as the installed Walbro's pump had on itself.. So I knocked the fuel tank with a wooden hammer several times, and tried the key again -- barely heard humming suddenly buzzed back? I knocked it again and tried cranking the engine -- it almost did it, but still no go.. If that was a fuse, it wouldn't behave this way i think. But I was told Walbro's pumps are very good? Anyway, it's a public parking near the 9-storeyed block, so I guess they'll have to see my shoe sole more often this week :)
  • she is all fixed and running like a champ, the problem was a loose wire harness connector located underneath the distributor, the ignition module. After locating the bad connection and correcting it's problem, everything seems to be going great, another important reminder is resetting all the trouble codes, I got lucky to have a friend that happened to have the code reader and he took care of everything for me, what we couldn't find in a month he found in 2 days. The only thing is my fuel gauge still does not work. Any suggestions what might be causing that, i almost do not want to bother with that because of how great she has been running, we don't even think it was the fuel pump at all, because my old one was running strong.

    Well if anything else comes up I will be sure to let you know. Sorry it took me so long to get back to you, but having my car again I had a lot of things to catch up on and take care of.....

    Best Wishes and If any one needs to know anything let me know and I will do my best to help out any way i can...
  • oldfordmecholdfordmech Posts: 124
    Glad you got it fixed. INFO ONLY- you can clear all set codes by disconnecting your pos. batt cable for 30-60 sec then reattach,and walla, light is off.
    On your gas gage, if you can find the hot feed back to your fuel pump,Not the feed for the pump, but the 1 for your gage, ( it will be smaller gage wire than the pump takes) When you find this wire, have a helper turn key on and watch gage while you connect that feed wire to ground for just a sec. if your gage goes to full than your gage and wiring to it are in Good Cond and problem is most likely in your tank unit.
    Keep in touch
    Cliff
  • I have a 1996 ford taurus GL 3.0 v6 fuel injected It had stopprd running awhile back we had someone drop the tank and put on a new fuel pump when key on I get 12 volts to the safty shut off switch but drops down to zero volts when the clip is in the safty switch when i pull it out and turn the key off then on the meter jumps to 12 volts then backs down to 7 volts its only when i put the clip in that sends power to the fuel pump is when i get 12 volts when key turns on then drops down to zero. The car cranks over but will not start It was starting but now not starting at all I also dont hear the fuel pump kick on. I wonder is there some kind of short in the pump or wires or am i not getting a good ground can anyone help me? thx
  • Check for corroded wiring connector located around the bottom of the dist. Also check the fuel pump relay located in outside fuse box.Find it and swap it with another 1 of the same value.
  • Sounds like the power wire going to the pump from the inertia safety shutoff switch is grounded between it and the pump. I had a similar problem with my 94 taurus. With the key off; take a multimeter and read the wire going from the switch to the pump to ground. You should see about 27 ohms which would be reading a healthy coil of your fuel pump. My guess is you will read much less as your voltage is going to ground. I found that the wiring bundle going to the fuel pump was smashed flat between the fuel tank and the underbelly of the car. I had to replace about 8 inches of wire and it cleared it up. Unfortunately, you have to drop the tank to get to it. Its just a bad design.
  • The other day when I gave my 96 Taurus the gas it was like it was in park. The engine revs fine but it didn't move. To get it to move I had to put it in park, shut the car off and start it again. I was curious what this is because I know I need about $1,200 worth of underneathe work. I really don't want to make payments on a newer car if I don't have to. I know this drives pretty well on the snow and even when we get a little ice because it's a top heavy car. All the others in my price range are way less safe than this one. So please if anyone knows what this is please let me know so I can decide if having it fixed is the best option.
    ~B
  • so sick of this fuel pump fails again. I heard from a friend that ford made bad fuel pumps for the taurus'. But I've replaced my 4 times already. So done with this. It's too hot outside to have my car not start especially with two toddlers.
    Any after market or suggestions for a different fuel pump? :mad:
  • Four times is rediculous there has to be a logical reason why this is happing. Either there is a electrical short in wiring damaging fuel pump motor or in my case after the new motor was installed they pinched the wiring damaging the replacement fuel pump motor. The car was driving for a long time ok till the pump went out again. One other thing i would change is the fuel relay note: the relay is actually several relays intergrated into one module mine was located on top to one side of the radiator. One other thing the fuel pump inside of the fuel tank needs the gas to Cool the electrical pump to prevent overheating the fuel pump motor so keep at least 1/8 to 1/4 full at all times.
  • Wiring over tank could be pinched OR look for wiring connection around your distributor or running under dist for any signs of green corrosion.
    Problems have been found there also.
    Cliff
  • Hi folks. Im new to this group. Im having a problem with the ladies 2000 Wagon. She ran it out of fuel...After adding fuel...No start. Towed it home, pulled tank and found that when supplying 12V to pump in the garage, the pump ran great. The problem...and what is Baffling me is that when I hooked up wiring and lines under car and turned key...all the pump will do is run for approx 1 or 2 seconds and shut off...HELP!!!!!! Point me in a direction if at all possible..
  • The pump is doing what it should. When the pump builds up pressure it will shut down with the eng off and the key on.
    Find the pressure test port on the fuel rail, remove cap and press down valve with small screwdriver, make sure you DON"T have your face over this valve. It should shoot a stream of gas for a sec. If you have the key on the pump should kick on again.
    Cliff
Sign In or Register to comment.