Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Mazda 626 Troubles

199100102104105125

Comments

  • veerentveerent Posts: 4
    Hi,

    I bought a second hand 1997 Mazda 626 V4 automatic 3 weeks back with 93K miles on it. The engine was doing fine until last week when the engine started to heat up all of a sudden and stopped in the middle of the road. I got it towed to the nearest Mazda dealer. He took a week to diagonize and told me that the compressor is bad and would cost a lot to repair it. So he suggested on changing the engine itself for $2600($900 engine[85K miles] + $1700 labor). Before this problem there was a lot of vibration in the engine during drive (D) and would come down a bit when in N or P. I do not know the cause for that! Can this be one of the reasons for the engine to heat fast and stop abruptly? Is there any other reason for the engine to heat up so fast and stall? Should I get the engine replaced or take it to any other local mechanic? I am student and can't afford to spend a lot on the car right now. Can anyone suggest what needs to be done?
    Any replies will be greatly appreciated.

    Thanks.
    :mad: & :cry:
  • Mr_ShiftrightMr_Shiftright CaliforniaPosts: 44,420
    I don't see the connection between a bad compressor and the overheating. I'd hook it out of there and get a second opinion or get some kind of credible explanation from the dealer. Is the engine damaged or not? How does the dealer KNOW the engine is damaged, that is, what quantifiable evidence is he presenting?

    Overheating needs to be carefully diagnosed, as there are many reasons this can occur.

    If you can't get any straight, solid answers, get the car out of there.

    MODERATOR

  • veerentveerent Posts: 4
    Well, actually I had posted it wrong. Sorry!
    The dealer told me that the engine has "bad compression" or "low compression". The head and the head gasket are OK. But since the compression is low, he will have to change the engine. Is it a good idea to get it done from a dealer or a private mechanic? The dealer is quoting US $2600.

    Any idea's how much does the engine for a 1997 Mazda 626 I4 automatic (2.0L, I think) cost?

    Thanks!
  • Mr_ShiftrightMr_Shiftright CaliforniaPosts: 44,420
    I still don't think you are getting enough information from the dealer, upon which to make an intelligent decision.

    What you need is results of a cylinder leakdown test to determine the cause of the low compression. This can be pinpointed exactly. Either bad valves, warped head, bad rings????

    MODERATOR

  • backybacky Twin CitiesPosts: 18,682
    Well, good news--sort of. No problems with the engine mounts. The engine vibration is caused by some sort of vacuum leak, according to the shop. They weren't able to pinpoint it before they closed for the weekend, so I will bring it back next week. They think it could have been caused by the accident (pinched/damaged hose maybe) but are not sure. If it's accident related my insurance company will cover it.
  • veerentveerent Posts: 4
    Thank you for your help/reply.
    Good news...The mechanic said, he has stopped the engine from overheating. He had to change the water hose for this. But he also told me that the compression is low/bad. He wants me to change the engine as soon as possible.
    1) Can I drive my car with a low/bad compression? If so, for how long?
    2) How will the low/bad compression effect the engine?
    3) What must the ideal compression be for a 1997 626 Mazda I4 automatic?
    4) Is the compression a serious problem?

    He told me that the head and head gasket are OK.
    Is there a site where I can read more about all this stuff?
    All the info that I have posted so far is from the mechanic.

    Thanks again!
  • Mr_ShiftrightMr_Shiftright CaliforniaPosts: 44,420
    Well you need about a minimum of at least 85 lbs of compression in a cylinder to fire it, so sure, you can run with LOW compression but not with TOO LOW compression, or the cylinder or cylinders below about 85 lbs won't fire. You don't want to drive with cylinders misfiring...not only will the car be incredibly slow but you'll ruin your catalytic converter, which will be overwhelmed trying to burn raw gas.

    Here's a good explanation:

    http://www.motorage.com/motorage/article/articleDetail.jsp?id=16170

    MODERATOR

  • sicsty8sicsty8 Posts: 1
    I've got a '99 626 6cyl with 114K miles on it and it's been running pretty good. I recently had an accident though. Another car misjudged and made a left turn from their opposite lane of traffic too soon. I smashed into the side rear of them. I was going about 35mph and both driver and passenger airbags deployed. Most of the impact of my car seems to have been absorbed by the front, passenger side of my car. Aside from that body damage, the car still seems to be running pretty good though. Since the impact was absorbed by the front, I'm not completely sure what, if anything, I should tell the mechanic to double check as far as damage goes. Any advice? :sick:
  • vicvazvicvaz Posts: 1
    I just got a '95 626 4 cyl. 92,000 miles, infact driving it on the way home and the O/D light started blinking.. and then I did notice this morning a small spot of transmission fluid under it. I have been reading the forums here and it doenst look good.... does it. Any advice? :confuse:
  • backybacky Twin CitiesPosts: 18,682
    My advice is, if you like your car, pray. Pray very hard. It is likely the damage from the accident will be more than 70% of your car's value, meaning it will be totalled. My son's 2000 626 had a front-end collision at much less than 35 mph recently, and due to the high cost of replacing the airbags and sensors the damage was a few bucks less than the "total it" limit (because they found a couple of used parts, the front bumper and headlamp cover, to bring the cost down), so they repaired the car. But the body had minimal damage--the hood wasn't even damaged, for example, and only one body panel needed to be touched up (and the bumper replaced).

    Check the engine compartment very carefully. It appears my son's 626 (I4) developed a vacuum leak of some sort due tot the collision. It got past the shop's inspectors, but we noticed a lot of vibration in the engine after we got the car back, so it is going in for a detailed analysis tomorrow (preliminary analysis is the vacuum leak).
  • backybacky Twin CitiesPosts: 18,682
    Update: just talked to the shop, they confirmed the engine is missing but they can't figure out why after 2 days of analysis. They mentioned a TSB for an intake manifold gasket but said the car doesn't have a problem there. So they recommended I take it to a Mazda dealer. (FWIW, the car had a 60k-style servicing 2000 miles ago including new plugs.) Could bad spark plug wires cause this kind of problem? I seem to remember reading about the wires being an issue with the 626.
  • backybacky Twin CitiesPosts: 18,682
    The "thunks" from the rear of my 2000 626 are gone. It was the rear sway bar bushings. Replacement cost, parts and labor, was $130 (not done at the dealer). I thought this was reasonable especially considering the shop didn't charge me for two days of work spent trying to find the cause of the engine missing slightly (and checking lots of stuff in the engine bay, including cleaning the mass airflow sensor).
  • standarkstandark Posts: 2
    Thought maybe somebody saw a similar problem..
    The driver side headlight does not work (Passenger side is fine), The brights do not work either.Checked all fuses, they are ok.. Tried 2 new bulbs.. When I press forward on the stem (head light controls) to put on the Brights, the Blue Indicator light does not come on on the dash panel (The brights do come on on the Passenger side headlight though).

    With the headlamps on, no brights, I checked the voltages and the 2 side connections to the headlamp bulb are both at 12V. The center Connection (TOP) has no voltage.

    I think the issue has something to do with both sides being at 12V, possibly cause the Brights switch is left on?

    Any suggestions are appreciated..

    TIA...

    Stan
  • skibry1skibry1 Posts: 174
    Good morning backy,congrats on silencing those pesky
    trolls in the trunk. How many miles on your double
    ought and how long had those trolls been active?
  • backybacky Twin CitiesPosts: 18,682
    The 626 has about 86k on it now. I bought it in January with 84.2k. The trolls were in the back when I bought it. Since the car had been thoroughly inspected by a mechanic before I bought it, I assumed (stupidly) that the thunks were something loose in the trunk. Fortunately it didn't cost much to fix. The car is perfect now, save for a driver's power lock actuator that is going (still works, I will wait for it to fail) and the engine vibration I mentioned earlier, that started after my son's accident. It has stumped one mechanic, so I will take it to the dealer soon and hopefully they can trace it to the accident (meaning it would be covered under insurance).
  • davew58davew58 Posts: 1
    I have a 1999 626 - 4 cyl auto that has an annoying habit of stalling out when idling. The idle is rough- normal is approx 800 rpm, but it will drop down below 500 rpm, and occasionally will stall out. A quick shift from drive to park when parking will also result in a stall out.

    Any thoughts?
  • mazda626atxmazda626atx Posts: 227
    Have you pulled the codes. Is it a bastardized version of Ford EEC with Mazda components? If so it is simple to pull codes from it with just a back testing wire jumped to the neg side of battery and flashes can be read from check engine light on dash.
    This can be done from the second small box on the left of the battery not from the large DLC box. This small second box is overlooked in many manuals and not everyone knows about its existence. The STi ( self test input) is by itself at theend of the connector. If you have problems pulling codes let me know. I will check back in a day or 2
    PGP
  • backybacky Twin CitiesPosts: 18,682
    Well, my 2000 626 I4 idles roughly also, but only when in gear. I have had two mechanics check it over thoroughly, including a Mazda tech this week. They can't find anything wrong with it. The Mazda tech said that is how the engine idles. So I guess I will live with it.

    You might try adjusting the idle speed?

    The good news is that the dealer did not charge any diagnosis fee after working on the car all day. I thought that was very decent of them (Walser Mazda in Burnsville, MN).
  • chacha62chacha62 Posts: 4
    I have a 01 626 v6 and recently had the front axle replaced. Since that time the left front tire sounds like its rattling (similar to lug nuts not tightened). Took it to a shop they thought it might need to be balanced. Tires rotated and balanced still having noise. Another shop said my right axle looked to short, he was able to move it up and down. Still can't figure out what the noise on the left is. Also is there a 4 cylinder 01 626 maybe Pep boys gave me the wrong right side axle and thats why it appears short. Has anyone had any problems with axle replacement?
  • p100p100 Posts: 1,116
    Most likely your healight switch is defective. It has sliding contacts in it which have either pitted or broken off inside the switch. I had a similar issue with a 95 Nissan truck. It was the headlight switch (intergrated with the turn singal stalk).
Sign In or Register to comment.