Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Mazda 626 Troubles

1106107109111112125

Comments

  • skibry1skibry1 Posts: 174
    We have never been stranded in our 4cyl 5spd and really
    enjoy the economy. Simple prevent maintenance and would
    buy again.
  • Thanks for the input. From all of who are 626 owners, would you say its wise to get one with about 100,000 miles on it already. I live in the DC area and I assume about 9,000 miles done a year
  • gyatesgyates Posts: 55
    Just my 2 cents worth. I bought my daughter a 99 ES V6 with just over 100k in August of this year. It has the auto trans as well. So far, no problems. She has about 103k on it now. Only 2 minor issues had to fixed after I bought it. Issue one was the Check engine light popped on, and all it needed was the EGR passages cleaned out. Second issue was a fluid leak, which turned out to be a bad gasket at the transmission. Had service performed on transmission, including new gasket, and problem is resolved. So far, we are pleased with the car.
  • Ive got a buddy with a 626 with a 2.0L with an auto trans in it. He has had a lot of problems out of the car, the trans went out earlier this year, last month the timing belt broke on it. He had some troubles with it today, he is no mechanic, he hauled it to our shop and the engine is locked up in it. His wife said the oil pressure light flickered on and off a couple times and then it quit. I was wondering if there are any other vehicles that we could swap out an engine with? Would a Ford Contour engine bolt up in this car? Any others that anybody knows about? :mad:
  • guestguest Posts: 774
    I'm still looking for info about an automatic transmission in a 1990 626 that was working fine one day, then the car would not move when cranked later that day. No warning signs of trouble. could this be some type of transmission switch or electrical switch?
  • Seems to me that the car just has so many issues. Ofcourse the biggest is the auto tran (I would get manual anyway)but there seems to be so many others too. I am seriously having 2nd thoughts now
  • I have recently encountered a problem with my dash lights coming on and off. When I have the lights on bright or turn signal (left) on, the dash lights come on but with normal light position will not come on. I understand it is probably a short or bad connection that is causing the problem. Any information about how to fix this or how difficult a job that would be to repair would be very much appreciated.

    Proud owner of a 95 manual 626 with 140K miles that gets about 32 miles to the gallon. Great little car but I'm not very handy mechanically.

    Thank you.
  • p100p100 Posts: 1,116
    Your light switch is most likely going bad. This is the switch built into the turn signal lever. It has sliding contacts inside which will wear out in time.
  • Hello.I'm new here and need a little advice.Thanks in advance for any help.
    I was driving my Mazda 99 626 (98,000 miles)on Sun and it started sputtering and then died out.I had the car towed home and it will try and start,but will sputter and die out without turning over.I changed the battery,plugs,wires,coil pack about 6 months ago and the PCV Valve.
  • Ha! I'm trying to decide if I should buy my
    neighbor,195K 5-sp 626 LX well cared for mazda but, burns 1QT.- 500 miles or so. 90% Hi way driven.
    I was thinking intake valve seals like a
    GM car.
    Please explain this old school device,and
    is it available to fit this mazda? :cry:
    Do's it, if installed stop the oil burning?

    Needing your adivce.....87WING
  • Hi all,
    I have a 2002 626 V6 and when it's cold outside it is very slow to start. When it's warm or warmed up, it starts fine. It also starts fine when wet. I had a remote starter installed but it's useless because the car takes too long to start when it's cold.
    What could the problem be?
    Thanks a ton,
    Casey
  • Hi, our 626 pulls harshley to the right when accelerating and pull harshley to the left as soon as you let off the gas. The front end components are tight, just had a control arm bushing replaced which was very badly worn
  • Thank you. Does this repair require removing the sterring wheel? Also, any suggestions about where to obtain a switch for the 1995 Mazda 626, manual transmission, V6?
  • I have a 2000 626 4-cyl & Auto. Upon heavy acceleration (such as start into highway traffic or go up steep hill) I experience what can best be described as a Grinding Noise and sensation coming from the front end. :sick: This was after the local shop replaced all motor and tranny mounts as well as transmission dynamic damper. Also replaced was right transaxle (bad) and right bearing (also bad). Upon first 'repair' it was noted that left Motor Mount was improperly aligned, since "corrected." Repair shop ending up taking car to Mazda dealer at their expense - mechanic suggested checking Motor Mounts as well as control rods and bushings (OK). Mechanic noted that front Motor Mount goes to full mechanical limit upon accel -- could a new motor mount be bad? :lemon: Any suggestions greatly and desperately appreciated.
  • patpat Posts: 10,421
    Try asking here as well: "No Start" Problems. That's a generic discussion, not model specific, but you may find some help there. Let us know what happens.
  • I recently took my car for an oil change... while he had it up, I asked him to look at my control arms to see what was making so much noise when I turned. He said I need to replace the ball joints. I then took the car to get another opinion. This guys says to me that I need ball joints but i have to replace the entire control arm because of something to do with it being all the same part. I don't believe him... because I found a site that sells just ball joints for a 1995 Mazda 626. Does anyone know the truth about ball joints?!?! Please help and much thanks to those that do. :confuse:
  • You can buy the ball joint seperatly from the control arm, however I would not recommend it. The ball joints are not designed to be pressed out of the control arm and when you try to press in an aftermarket ball joint it is often a loose fit. I have seen people spot weld the aftermarket ball joints in place to keep them from pulling out, which is not safe. So the control arm is costly but it is the only safe way to repair your car.
  • It is possible for a new mount to be bad, but highly unlikely, especially if was a Mazda part. When you replace all the mounts or have the trans or engine out you should "neutralize" the engine and trans. This is done by loosening all the mounts and letting the engine and trans settle into a position where the is no more stress on one mount than any other. When you tighten each mount completely at a time it may have too much stress on it. This is one possibility, another that comes to mind is the axle you had replaced. I have seen aftermarket rebuilt axles give vibrations on acceleration. It is usually because of improper machining on the inner cv joint. The only way to know for sure is to try another axle. Hope this helps.
  • If this condition started after the control arm bushing was replaced I would go back to the repair shop immediatly. It is a good chance something is misaligned or out of position with the control arm, or worse something is loose.
Sign In or Register to comment.