Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Mazda 626 Troubles

1525355575884

Comments

  • mazda626atxmazda626atx Posts: 227
    Hi Guys I have been reading posts in here for weeks and finally posted #1642. a few days ago.Please look at it when you get a chance. IRISH you posted something #1114 about MALF codes and that site (goldennet ) no longer exists. Could you repost the info or know where I could get it now? Also ALCAN seems to have some info on these cars that may be helpful I have the HAYNES mazda 626 ford probe manual 1993-2001 but it does not go into reading 3 digit codes on OBD I cars in any depth.
    TIA
    PGP
  • chrbchrb Posts: 4
    Can anyone help me find a fuel injector seal for my Mazda 626 LX (2.0 4-cyl). I think it’s also called a “hat”. According to the dealer they found the seal broken while fixing another problem (see below). Now I have fuel all over the engine and can see it spraying out around the injector sides while the car is running. Needless to say, the fire extinguisher was moved to the car and the keys put far away.

    It seems that the seal can only be purchased with a new injector ($350 OEM and $100 after-market). Look at this picture for clarity. By the way, the injector functions just fine.

    I can buy a used injector for about $25 just to get to the seal, but that’s a used one. Any advice on where to get this? Tried all the major parts shops and also some importers to no avail.

    Let me also explain two other resolved issues I’ve just had for the benefit of others. The engine light came on a few weeks ago and the car started having idling problems. The engine would run fine otherwise, but idling got progressively worse over weeks. Replaced the spark plugs and the leads. The code read too lean on cylinder one. Finally I took it to the dealer who found the intake manifold gasket leaking. That was replaced and problem fixed for $355.

    Also had a leak on the metal oil pipe running from the gearbox to the radiator. Luckily, it spilled the transmission fluid on the exhaust pipe and caused a lot of smoke, so I could catch it before too much oil was spilled. After replacing the pipe for $40 (actually two pipes attached to each other), I found that the leak was caused by excessive corrosion. So, check those metal pipes before loosing a gearbox to it.

    Otherwise, I had very little trouble with this car and hope to be driving it for another few years. Current mileage is 85K.

    Drive safe.
    Christian.
  • Mr_ShiftrightMr_Shiftright CaliforniaPosts: 44,564
    I think these seals are rather standard sizes. You might find out who makes the injectors and talk to them.

    Also talk to another dealer. I've always been able to order injector seals.

    MODERATOR

  • I RECENTLY BOUGHT A 1994 MAZDA 626 WITH 155,000 MILES ON IT. OKAY, I REALLY LIKED THE LOOK OF THE CAR, SO I DRIVE IT FOR A ABOUT A DAY AND WHAT DO U KNOW, THE HEADLIGHTS WOULDN'T COME ON! THEN TO MY HORROR I EXPERIENCED A WILD JERKING MOTION WHEN I ACCELERATED!!! THIS SCARED ME OUT OF MY WITS!!! AS IF THINGS COULDNT GET ANY WORSE WHILE DRIVING, THE STEERING WHEEL SHAKES HORRIBLY. IM AT A LOST FOR WORDS. THE OTHER NIGHT I ACTUALLY FELT LIKE CRYING. PLEASE, IF ANYONE HAS ANY SUGGESTIONS OR COMMENTS ON WHAT I SHOULD DO (OTHER THAN TRASH THE CAR) PLEASE LET ME KNOW.
  • alcan,
    thanks again for your help! after thinking about it a little, i realized that even if i COULD break those bolts loose, they would hit the knuckle before they could come out anyway... so basically, like you said, they need to be pressed apart/ back together. i was hoping to get away without doing an alignment, and new wheel bearings - but seems inevitable at this point. my acura is the same - press in/press out. if he hadn't waited so long to do his brakes, then his discs would still be good, but the pad backing has worn them down to almost nothing!

    again, sincere thanks. (from my roommate too.) =)

    chad

    (ps, i'll be tackling the rear drums next. should be easy from what i've heard, but i've just never done drum brakes before - so i may be back! fortunately i've already been able to remove the drums, which i hear can be real tough sometimes.)
  • alcanalcan Posts: 2,550
    First, TURN OFF THE CAPS LOCK KEY. You don't need to shout.

    Second, did the check engine light come on? If so, take it to AutoZone, have them retrieve the trouble codes (no charge), and post the code #'s. We can go from there.
  • alcanalcan Posts: 2,550
    Chad, when you do the rears, do one side at a time and use the other side for reference. If not, you'll get amnesia 1 second after removing the last spring from the second side LOL.
  • mazda626atxmazda626atx Posts: 227
    Hi ALCAN. I posted #1645 and #1642 When you have time could you give me the benefit of your experience please.
    TIA
    PGP
  • LOL - definitely good advice! i get that type of amnesia a lot i think... the just-after-it's-completely-disassembled amnesia. =D

    i forgot to ask; when i pulled the axle out, there was a significant amount of gear oil that came out. on my acura, because the motor is longitudinal, i have a differential that takes 80/90 gear oil. this mazda i'm working on is horizontally mounted, so the axle goes straight into the tranny? (let me know if i'm wrong!) my acura takes 10/30 in it's 5spd trans, but what came out of the mazda definitely smelled like gear oil. what's recommended for the 5spd trans in this car? i'm guessing i get to pump it up into a fill bolt somewhere...

    thanks, thanks, thanks... not sure how many more times i can say it. =)

    chad
  • alcanalcan Posts: 2,550
    You have a good nose. The manual transaxle fluid spec is SAE 90 EP gear oil if the temperature is above 0°F (-18°C), or SAE 80 EP gear oil or Dexron III ATF if the temperature is below 0°F (-18°C).:

    To check/add lube, remove the speedo gear and housing from the top of the transaxle. The fluid level should be at the upper shoulder of the gear.
  • alcanalcan Posts: 2,550
    Hang in there, I'm on it. Trying to locate the least expensive reader that will do the job.
  • mazda626atxmazda626atx Posts: 227
    THx Alcan. Also when running car (parked) to warm it up pre testing, it is almost impossible to maintain 2000 rpm . Get near 2000 then surges to 2500 and then when I try to back off it drops back to 1500. I know people have mentioned surging here but only happens when not under load THX GOD Also CEL used to come on only under load (uphill accelerating etc)I have installed xternal trans cooler and now it comes on at lower speeds and occasionally stays on till I come to a stop.Do either of these things indicate anything to you my GURU :)
    PGP
  • j626j626 Posts: 1
    I have a 94 mazda 626 and recently replaced the ball joints without having to replace the lower control arm. All you need to do is rent the press (ball joint removal kit) at any autozone, murrays, or auto parts store. They won't even charge for the rental, just the deposit you leave till you return it. Just take off the tire, disconnect the hub (ie. spindle, wheel hub, etc.), once the ball joint is exposed use the press to take the ball joint out, reverse the press and use it to put the new ball jooint in. It's really simple to do, and anyone with basic mechanical skills can do this. Just never use a torch to take the ball joints off a vehicle because this will just expand the collar and when you go to put your new ones on they will eventually begin to slip.
  • I just baught a 96 mazda 626 4cyl. great cond. 100k miles 3 months ago and it started to idle funny and my check engine light came on. so we took the car back to the dealer and they called mazda and they said it was the idle air control valve and to clean it out realy good and that should work. they did that and everything was fine and the check engine light went out. a couple days later the check engine light came back on and it started to idle funny agian. know the car wont drive over 1200 RPMs and it will try to cut out on me but once you force it over 2000 RPMs it drives perfect. and some times it wont start up on a incline or hill. I was wondering what really could be wrong and should I pay 400-600.00 for the Idle control valve? thanx james_andrea :sick:
  • alan1999alan1999 Posts: 1
    Not sure about the headlights but the jerking is a fairly common problem due to a cracked intake hose (big, black accordian type hose from the air filter box to the intake manifold). The symtoms are that the car will not jerk in reverse or if you start of verrry slowly. What is happening is that the torque of the engine is pulling apart a crack in the hose and allowing too much air into the manifold. The part is about 60 bucks and it will take you about 45 minutes to change it. You have to save a couple of parts from the old hose so don't throw it away until you have installed the new one. As for the headlights, check the fuse first, then I would probably inspect the switch after that. Good luck.
  • drboeingdrboeing Posts: 1
    Hi all,
    I have a 96 626, the starter just crapped on me, the parts place need to know which month the car was produced as there was a change in mid year. How do I decode the VIN to tell me which month this car wasw produced.
    Thanks in advance for the help
  • alcanalcan Posts: 2,550
    Look on the sticker on the driver's door.
  • mazda626atxmazda626atx Posts: 227
    When running car (parked) to warm it up pre testing, it is almost impossible to maintain 2000 rpm . Get near 2000 then surges to 2500 and then when I try to back off it drops back to 1500. I know people have mentioned surging here but only happens when not under load. Also CEL used to come on only under load (uphill accelerating etc) but since I have installed xternal trans cooler, now it comes on at lower speeds, stays on longer and occasionally stays on till I come to a full stop at a light. Any ideas ?
    THX PGP
  • Mr_ShiftrightMr_Shiftright CaliforniaPosts: 44,564
    Some kind of fuel delivery issue...sounds like its running rich. Do you have somewhat disappointing fuel mileage on this car?

    MODERATOR

  • mazda626atxmazda626atx Posts: 227
    Thx Mr Shiftright. I am in NYC at the moment . I am going to have wife do a mileage check before I get back . This way if I need parts I will bring them with me when I go. I sense the mileage was dissapointing but I thought that was more due to my aggressive driving style. Plus I never really checked because gas is sold in liters there so I will have to pay attention and convert to gallons.What type of highway mileage should I expect . Also mixed city freeway driving. :lemon: If its running rich what might it be ?
    Thx :) PGP
  • Mr_ShiftrightMr_Shiftright CaliforniaPosts: 44,564
    well it'll have to be diagnosed more carefully. There are no error codes from a Check Engine Light? Usually some sensor or valve gone awry and messing up the fuel mixture.

    MODERATOR

  • 626town626town Posts: 7
    i also had the same problem but it only cost me $55.00 AT A MAZDA DEALER IN CHICAGO WILLIAMS ON THE SOUTH SIDE
  • 626town626town Posts: 7
    THANKS BUT I CHANGED BOTH CONTROL ARMS , BUSHINGS WERE BAD BUT THANKS FOR THE INFO. I`LL GIVE MY MURRAY GUYS SOME SH-T
  • mazda626atxmazda626atx Posts: 227
    I get a 159 MAF and a 181 (lean condition) or 118 (ECT). I was rushed when I got these codes and it was my first time. I will have to read them again when I get back to Greece and I hope to get better at recognizing them. I was curious if the surging to 2500 then dropping to 1500 might confirm something, because I am considering buying parts here before I go back and have an opportunity to retest. I cleaned the MAf and checked all the wiring and will either buy a new one or wait till I get there and have a shop check it out with the info I now have.
    Also I was wondering what sensor would become more sensitive by adding external tranny cooler as I mentioned in post #1642. ( The whole scoop on the car is in this post ) Its sorta tough cause I dont have a parts store there , so I have to sort of guess what I will buy here and take with me.
    Thx again PGP
  • Mr_ShiftrightMr_Shiftright CaliforniaPosts: 44,564
    If we're going to get into codes, you should prepare your question exactly and then post it here,where it is more likely one of our visiting techs would see it.:

    Technical Questions

    thanks

    Shifty the Host

    MODERATOR

  • temniktemnik Posts: 1
    Hi there, do you have solution for code # 113 ?
    There might be a few causes: I drove a couple of miles (about 20) with gas light on (according to the spec) and I changed air filter at the same day.
    Please, help:)
    Thank you in advance! :blush:

    P.S.
    Diagnostic Trouble Code Description
    Trouble Code: P0113
    Vehicle Qualification: Mazda 626
    Description: Intake Air Temperature Circuit High Input
  • mhannermhanner Posts: 1
    What was the check engine code? It could be a sensor in the transmission- 626s are notorious for tranny problems if it's an automatic. Did you check the fuel filter?
    Also try cleaning the MAF sensor. Mike
  • mazda626atxmazda626atx Posts: 227
    A 113 code is IAT like you said. Check that sensor , circuit all wires , fuses etc. There is a way of cking it using an ohmeter and a hair blowing gun , but unless you know what you are doing bring it to qualified tech. Also make sure air filter is seated properly cause the MAF is closely connected in Mazdas and in some models 93-97 V6 the IAT is part of the MAF. Also which engine 4 or V 6
  • does anyone know what might be wrong with my 95 mazda 626, i just had the cylinder head reconditioned and when im stopped at a light the car revs up by itself and i now have an oil leak that i didnt have at first. please help this is is breaking my pockets and the check engine light blinks off and on as well as the o/d light
  • pteezypteezy Posts: 3
    SO here's my dilemma.. i have a 94 mazda 626 4cyl 2.0 automatic.. tranny needs rebuilding.. has errors in 2nd and 4th gear... so those 2 gears slip.. ALOT!! and it has an overheating problem.. also just recently, after i drive maybe bout 15-20 miles, black smoke starts to come out from underneith the car.. , but its not overheating... i found tranny fluid on the ground so could it be leaking onto the manifold? also has an idling issue..NOW! I was made an offer to buy an RX-7 engine.. have it put in with tranny and all for $1000... AND i was made an offer on a 96 vtec civic for $2000... which should i go with?
Sign In or Register to comment.