Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Mazda 626 Troubles

19192949697125

Comments

  • According to my manual there are 9 different possibilities for general loss of power. Prolly the reason mechanic is stumped.`But there should be a pecking order to what should be diagnosed. Have you joined ALLDATA? Maybe you could direct question to Alcan he seems to know a lot about Mazdas if you can get his attention or Email him.
    Good Luck
    PGP :)
  • I have a 1997 mazda 626, 5 speed. I got into it the other day and noticed that my car was staying reved at about 2000 rpms even with the clutch in, and the charge (battery) light came on, and on top of that my heat stopped working (i know, its a handful). I just put a new battery in it, but am a little stupped on what this problem could be with all the symptoms...if anyone has any suggestions it would be helpful

    Thanks
  • Yeah ok I have a 92 Mazda 626 Automatic..but My Charge light came on aswell and my heat stopped working...what it was with mine was the Alternator Belt needed to be re attached (ok a new had to be put on)..But newayz..I didn't know that until the car died 45 minutes from my house b/c the battery had been drained...thought it was strange b/c I had just gotten the car and Had just put in a brand spankin new battery and it died...found out earlier in the day when i was test running it making sure it ran..the alternator belt snapped and fell off..look for the alternator and see if it had a belt attached..If it does take it to Advanced Auto Parts or Autozone and get them to check your alternator

    Tom :)
  • I have been having problem with my Mazda 626 1.8 LXi 1997 (manual) for last 3 weeks. Car has done 63000 and was very reliable for last 5 years.
    I have seen few mechanics, including Mazda service. Mazda suggested to change catalytic converter, which I did, but the problem is still there. I was trying to speak to the technician who diagnosed the problem, but they said that I have to come again for diagnoses and I would be charged again (£50)...
    The symptoms of the problem are:
    - Car loosing power under load, especially on higher revs and when it goes up a hill. The problem is worse when the engine is cold
    - When the car is stationary, pressing on accelerator the engine works smoothly even over 4000 rpm. Car starts OK when hot or cold
    - Car has stopped few times going up a hill with cold engine. After about 20 seconds the car would start and run like before (going hardly up the hill)
    - On motorway can go up to 75 miles/hour

    Parts that have been changed:
    - spark plugs
    - air filter
    - engine filter
    - Catalytic converter

    Mazda garage suggested changing catalytic converter, silencer and pre-silencer. After changing converter there were not any improvements, so I did not bothered with the rest.
    I would be grateful if someone can help.
  • I have a 1997 mazda 626. It had a complete engine overhaul 2 years ago. After every oil change (roughly 4 weeks) oil color starts to turn black and eventually burn rapidly. I have to add 1 qrt every 2 weeks. The problem had even before the engine overhaul. Any expert suggestion would be really appreciated.
    Thanks.
  • pdanapdana Posts: 19
    I was wondering if anybody knows anything about the 1992 mazda 626, with four cylinder and automatic trans? I need something to get around town in. I saw this one and it says it only has 80k miles on it and that it runs good. I've seen where a lot of these cars seem to have transmission problems, was this also the case for the '92? Thanks for any info.
  • hi bolts,

    I have the same car as yours and is dead since 4 months.the engine is not going on, at mazda they said it is the distributor, here (lebanon)I could not find the part,even used or new.I waited 4 months to bring from outside the country and it did not work.
    I finally saw your posts.
    PLEASE PLEASE help me. what is the crank sensor, where does it fit? etc...Because I exchanged the complete distributor with all what's inside and the engine still doesn't start.(No sparks from the plugs)
    I do really appreciate if you can help.
  • Hello. First time poster wondering if anyone could give me some advice. Got into my 93,626, 2.5L, Manual yesterday and turned on the ignition, and when the car started a strange beeping noise started coming from the dashboard with none of the dummy lights accompanying it. Turned the car off and on again and there was no beeping the second time. I'm really scared to drive the car because I Know I need to check my timing belts, and I don't need another blown engine. I'm a 19 yr old female and I need to use my car this week or I'm gonna miss an important photo shoot.
    Please Help
  • Hi, usually if the key is in the ignition switch and the door is open you should hear a beeping noise, but in your case you said that when you turned off then on no more beeping, I think this can be the seat belt reminder.
  • I have 1990 Mazda 626 GLX, 4cyl, 12 valve, 2.0 l, 5 spd manual trans. I recently changed the head with a 1989, but now it keeps going out of time, does anyone know how many teeth are on the '89 camshaft sprocket versus the '90 as I think this may be the problem. :confuse:
  • if your timing belt should break, it wont harm the engine. You have a "non-interference" engine in that car. You would have to tow it to a garage and replace the belt, but no harm to valves or pistons...
  • I need to find a after market exhaust manifold for my 2001 MAxda 626 4-litre...Can anyone help?
  • Hello:

    Can anyone help me with this question, please? I'm tired of asking my mechanics what’s the problem with my car and getting nowhere for they’re always giving me the run around and fix something other than the one I want to be fixed (female situation I guess…)
    Every time I start the car... first thing in the morning or after a few hours there’s a squealing sound. I believe it’s a belt but ‘m not sure which one. Can anyone help me with this?

    Thanks!
  • Sounds like a common slipping belt symptom, or a bad bearing in the idler pulley upon which the belt revolves. I'd replace the offending belt and tighten it properly and/or inspect the idler pulley for excessive wear and wobble.
  • tdreotdreo Posts: 17
    Here's the story:
    I bought my 4th Mazda, a 2001 626 (4cyl, auto) and about a year later my 5th, a 2002 626 (4cyl, auto). At the time, I was under the impression that the transmission problems were solved, boy was I dumb for believing that.
    The 2001 tranny died at 22,000 miles, under warranty thank God.
    The dealer claimed "we've never seen a 2001 go bad"
    The 2002 died last week. The car was 3 years old (almost to the day) with 60,000 miles on it. After much complaining and dealing, Mazda went from "you're on your own" to being so thankful that I have bought 5 cars from them they would cover half of the cost (what a treat!). What a ungrateful, arrogrant company. To make the story a little shorter, it cost me $2000 for my "half". I flat-out told them that this 5th Mazda would be my last if they did not cover the repair but they didn't seem to care. Bye-bye Mazda, I guess 5 isn't enough. I'd lay odds Mazda will be the next GM in a few years.
  • Sometimes my Mazda 626 (2002, 6 cyl.) starts slowly from a stop - almost seems to lose its breath when I press on the accelerator. It feels like there's an air bubble in the gas line or it's about to stall or something. (Not a mechanic, sorry.) Problem is worse when engine is cold. Sometimes this is almost dangerous, like when I need to move a little faster to catch a space from a turn, into traffic. I wind up having to wait for big long spaces because the car literally moves in slow motion for about 3-5 seconds. Has anyone seen this in their Mazda or know what the problem is / how to fix it? :confuse: Thanks.
  • thank you Mr_Shiftright. that's exactly what was wrong. hmmm i like this site :) i should visit it often.
  • tdreotdreo Posts: 17
    Mine (2002, 4 cyl)does the same thing.
    I've changed the plugs, wires and the ignition coil with no change. My next guess is a bad injector or fuel pump.
    Let me know if you find anything on yours.

    Thanks
    Tony
  • k_mank_man Posts: 1
    My 98' 626 4cyl, 5 speed, does that exact same thing. It always seem to hesitate when accelerating, and then all of a sudden take off as I let off the gas (should work the other way around). Lately it rattles as it accelerates, as if it is out of breath. I changed, sparkplags (then for a little while it went better), gas pump, etc..nothing really helps. Now, the stupid thing even drops RPM to about 450...when idling and when the engine is warm. I keep thinking it will die on me any minute. This car never seemed to be doing well. I had an RX7 before and had no problems, yet when I buy this dumb sedan it never runs right,
    I bought it with 49000 miles, but I never liked the way it ran...

    Please help if you have any thought on this.

    k-man.
  • qbrozenqbrozen Posts: 16,886
    someone asked not too long ago about the 4-cyl tranny in a '92 626. I'm curious about the same year. What year 4-cyl autos should be avoided?

    thanks.

    '13 Stang GT; '86 Benz 300E; '98 Volvo S70; '12 Leaf; '08 Town&Country

Sign In or Register to comment.