Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Dodge Stealth Twin Turbo

1235»

Comments

  • crashn2ucrashn2u Posts: 2
    its probly your fuel pump, this happens when your fuel pump starts to go out and it overheats.
  • crashn2ucrashn2u Posts: 2
    I read through alot of these posts. I must say first thing to check is your ECU, your engines computer. Mitsubishi used low grade capaictors in the ecu they leak onto the board and the fluid eats through the boards. the capacitors are rated for 2000 hours. so if you are having no start issues or fuel issues or any crazy issues you cant figure out pull your ecu out and check to see if the capacitors have leaked. you can get the capacitors changed out for 50 bucks or buy a new or used rebuilt ecu for around 250 bucks new i think are 450. these need to be checked every so often if you leave them it will eat holes in any of the 3 boards in the ecu and can lead to a spendy repair. I sent my ecu to NW tv and radio repair in bremerton washington the guy charges 50 bucks+ shipping to change out the caps and clean up the boards. He is familiar with these ecu's. Good luck
  • ajakajak Posts: 1
    My 1991 Stealth RT Turbo with only 8,500 miles started cutting out when I started driving it after taking it out of winter storage. I store the car with fresh fuel and a good stabilizer that does not contain any cleaners. I have been storing this car using the same methods since I purchased it in 1991 and have always had great luck. Similar to one of the posts that I read, I took the car to the Dealer I purchased it from and after a day they called me and said they did not have the equipment to diagnose the problem as the equipment was all obsolete. After I drive the car about 8 miles the problem seems to go away and the car runs fine. The Dealer did say it could be the crank position sensor or a turbo waste gate. None of these seem logical to me. I would appreciate any comments regarding this situation. I thought it may have been a problem with bad fuel or moisture but one of my other cars, with fuel purchased from the same source, ran perfect. Thanks for any help you can provide. AJAK
1235»
Sign In or Register to comment.