Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Chevrolet Blazer Emissions Control System Problems

joshh33joshh33 Posts: 1
edited April 18 in Chevrolet
Im 16 and this is my first car, today driving the check engine soon light came on, it didnt come on to school, but it came on, on the way home. It gave me the code P0452, which it says is a emissions control system low pressure sensor. What could this be? Is it something i can buy and fix myself or do i have to take it to te dealer? How long can this go?

Comments

  • jlflemmonsjlflemmons Posts: 2,240
    Okay, first make sure your gas cap is on and tight. I remember how it was many years ago when I was in school, and someone may have stolen your gas cap.

    Next, disconnect your battery for about 10-15 minutes and reconnect. This will reset the trouble codes stored in the computer.

    As a friendly suggestion, when you post list the year model and mileage on your car. Makes it easier for the nice folks on this board to help you. ;)
  • nmartnmart Posts: 3
    HAd to edit the prior post here

    I have a 1989 S10blazer The 4.2 V6 fi 175,456 mileas. Went for emissions test and Air inj sys, egr,pcv,fuel inlet restrictor, Cat Coverter,Evap control sys, gas cap integrity all passed, tail pipe #'s
    CO%
    Idle limit 1.20 reading 7.22 fail
    2500 rpm 1.20 reading 6.86 fail
    HC ppm
    Idle 220 ...382. fail
    2500 rpm 220... 267 fail

    Seems there is to much emisions coming out of tail pipe all other things are ok. I do smell fuel when it starts though, and iot runs rough sometimes. I always kept up on tunups. also seems to eat more gas.. Need to know what parts would effect emissions that would cause high CO%. need to know something before having it fixed. thanks

    added OBD code
    I did th OBD I code flashes 44 lean mixture. if that helps any

    thANks again
  • jlflemmonsjlflemmons Posts: 2,240
    With all the measurements showing a rich condition, and getting a code 44 on the oxygen sensor, I would wonder if the O2 sensor is bad, or if the wire is off. With the miles you have on the car, the O2 could have just flat croaked.

    Bosch O2 sensors are something like $20 from O' Reilly's (The local franchise parts house) or about $45 for a Delphi.
  • Hi! I have a 1996 Blazer L-10 with the 4.3 Vortex engine. The Service Engine Soon light recently came on. I brought it to AUTOZONE and they nicely ran the error code for me. It came back "Evaporator Control Problem" The gas cap seems OK, No obvious loose vacuum hoses and the canister looks OK. I do have gasoline leaking out of the rubber hose that connects the fill pipe to the gas tank pipe whenever I fill up with gas. It only leaks when I get gas. I think it's the short lenght of rubber hase between the fill pipe and gas tank pipe. Could this do be the problem? If not which vacuum hose do I need to check. I need to get it inspected and they can't inspect it with the engine light on so I'm kind of "up a creek with half a paddle". Thanks. Ken :sick:
This discussion has been closed.