Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Chevrolet TrailBlazer 4WD Problems

2

Comments

  • Hi...when I switch my Trailblazer in the Auto mode, it appears to just drop into 4WD. As I turn on pavement, it clunks just as it would as if I had put it into 4WD. As I was going down the highway last night, it felt as if the brakes were on and the vehicle was holding back. I had it in the shop last week for this same problem, and they couldn't duplicate it. When I took it home, there was no problem, but last night I had the problem again. Has anybody else experienced this problem and what was the solution?
  • dendaddendad Posts: 4
    68runner That is on of the many intermittant problems I had with my 2002 trailblazer. See my threads (dendad). I don't know if mine has been fixed with all the items replaced.
    Time will tell. Right now I have a new problem. In 4WD I get a whine when slowing down to a stop.
  • Hi,
    I have been having problems with the front end of my trailblazer. When I make a right turn it feels as though the truck wants to stop, when I start to slow down and apply the brakes it feels as though I am going over a speed bump and I just heard a banging noise in the front end. The truck only has 37,000 miles and the oil is changed every 3,000 miles. What do you all think this could be and should I take out a 2nd mortgage to pay for the repair. Thanks for your help.
    Claud :cry:
  • burdawgburdawg Posts: 1,524
    Is it 4 wheel drive?
  • My 2003 Trailblazer attempts to engage 4AWD without me changing the selector switch. The vehicle bucks severely in the process. I have to pull over and shift into Park before I can get back on the road. The ride will be OK for a while, however it won't be long until the problem returns. The A4WD light blinks, while the the 2HI light remains lit. Any ideas?
  • It's probably the 4WD computer which is under the RH windshield. Either it needs reprogramming or water has leaked into it from the windsheild. That happened to mine and it was replaced. But now I don't have AWD. It actually goes into 4 wheel high instead of AWD. Thes Trailblazer's 4WD seem to all have similiar problems.. So far mine has not been fixed.
  • So I have read thru these threads and still come up with the question what is the solution to this problem with the 4 wheel not engaging? What should I believe? Your answer seems simple and cost effective since I am experiencing the same symptoms as the other bloggers. Did re-setting this work for you long term? Thanks. Jim
  • My Trailblazer is over 8 years old (purchased Dec. 2001) and has 100,000 miles. The computer reprogram fix done by the local mechanic is still working (about 6 months now). Over the years the 4X4 switch has acted up about a handful of times (switching light on its own or just no lights and not working). The dealership has always "said" they replaced the switch but this was the first time I took it to the local mechanic and they said the computer needed reprogramming and it was fixed. I'm the furthest from a mechanic but it's worth a shot if you know a trustworthy mechanic.

    I'll post when/if the 4X4 switch goes out again (or if I sell it for something more fuel efficient in the next couple years). It is still in excellent condition and I try to keep new vehicles at least 10 years
  • vtxmanvvtxmanv Posts: 2
    Thanks for the info. I guess I will look for a mechanic that will reset my computer. I will let you know how it goes. Thanks again
  • kmcneishkmcneish Posts: 2
    I have a 2005 Chevy Trailblazer. I don't really drive it around that much. But when I hooked it up to my trailer and went to pull out the tires started to spin so I put it in 4hi and waited for the light to flash the tires were still spinning. So then I tried 4lo and it still did the same thing. So I finally unhooked the trailer and and tried it in 4lo again and the tires were still spinning. I had to finally get out my truck to get it out of the dirt. After it was out I drove it up the road for a while and retried the whole thing over again and it finally worked. Has anybody else had the same problem?
  • gmcustsvcgmcustsvc Posts: 4,005
    edited April 2010
    Hello,
    I am from GM Customer Service. I would recommend taking your vehicle to a dealership to have the 4 wheel drive concern diagnosed. That way you know what is going on with the vehicle. I can locate a dealership in your area if you like. I will need your zip code in order to do that. Thank you,
    Mariah GM Customer Service
  • ibnahooibnahoo Posts: 4
    I got cought in fine sand driving my T/B LT 05, every time I try to get it out, it gets deeper in the sand... I let one of my friends to try driving it out while I was outside helping to remove the sand away from the rear wheels... in the 4LO only one wheel was spinning... the other three were not... obviously the differencial gear puts all the tourque on the free moving wheel... was that normal to happen? cause I understands that 4LO should put the high torque equally on the 4 wheels whether its free moving or not... please advise .
  • burdawgburdawg Posts: 1,524
    I assume you don't have rear limited slip. In that case only one wheel in the back would spin, one wheel on the front axle would spin under certain conditions. 4wd is really a misnomer as I understand it, power is really only transferred to one wheel front and back (unless you have locking differentials). The best thing to have done is to let the tire pressures down to 15psi or so to increase the traction and dig out all four wheels to make the transition easier.
  • ibnahooibnahoo Posts: 4
    Thank you John for the reply. This morning I had a similar experience and it seems that I can only use the 4WD for road stability when conditions are not right... in fact it is great pain offroads while it shouldn't... if differential gear would only spin the free moving wheel and not the loaded ones, so what is the great use then? waste....
  • rayk7rayk7 Posts: 1
    I have a 2004 trailblazer with 98000 miles. Just recently i've had the following issues come up. The passenger side front window will not go up. I think the button is stuck in the down position. The check ABS light went on a couple of days ago and now the service 4 wheel drive light went on today. Are these issues common for this vehicle and does anyone have any suggestions? Thanks
  • i have taken mine to the dealership numerous times for 4 wheel drive problems and it still is not fixed. the four wheel drive has never worked properly! i had to pay extra to get 4 wheel drive on the vehicle and now have to continue to spend money on it and it never works when i need it! i am so frustrated i would rip it out if i could!
  • As posted above (2 years ago), my4wd service light came on and would start jerking and running rough. I didn't fix as I could deal with the 2wd, but now that the TB is used by my daughter, I finally had my dealer fix the problem. The dealer diagnosed and replace encoder motor/actuator ($566.46) acouple of weeks ago. Well, it finally snowed and it worked for a day. It's jerking again in 4 Hi and 4awd and it is difficult to get back to 2wd after turning the switch back, but after while, it went back to 2wd. Plan to take back to dealer next week. Hope they can fix it this time. If anyone has an idea (including GM) I would appreciate it.
  • I have a 2003 trialblazer...we rarely use the 4x4 but just a few days ago we got some good snow and used the 4wd and all of the sudden I heard some sounds like if some gears were hitting with rocks!!
  • I have a 03 tb ltz and when I put it in 4wd and start picking up speed my car starts to sh ?ake can someone help plz
  • Was wondering if you had ever got your issue resolved. I've used 4wd a few more times than others and for about 4 months now it's been jerking and in the last two weeks 4wd service has came on. I've had my truck now almost 4 years and have put a lot of miles on it. Just wondering what solved your issue. I want to take it in to the dealer soon...
2
Sign In or Register to comment.