Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Dodge Sprinter low boost problem

2»

Comments

  • The initial limp mode problem was caused by a crack in the turbo hase. Some super glue and monster duct tape fixed it for a year, then I had to replace the $95.00 hose. The second limp mode problem was caused by a blown-out resonator. I replaced the blown-out resonator with the aluminum one made by Riordan. My Sprinter has never ran better! At least the resonator problem is fixed; hopefully for good!
  • jimf36jimf36 Posts: 3
    The MAP pressure is good 29.5 The turbo resnator and intercooler hose's are good .It was put on a smoke test and passed.I did notice the EGR valve humming which never did before.It is has a $597.00 list price.WOW!If I disconnect the EGR valve it seems to run fine.iIf I hook it back up it gives me code P0299 and goes back to limp mode.If I clear code it runs good for about 1 mile and goes back to limp mode.The EGR valve gets its information from the mass flow and the charge air pressure sensors could one of this be my problem .The EGR valve is s humming can they be taken apart and cleaned .I havve never worked on aEGR valve before.I would appericate any input .Thanks
  • I have the same problem with a 2008 Sprinter, looking for an Aluminum Resonator, but have found nothing. Could you let me know where I could get it?
    Thank you
    Fred
    Fred's Mobile Service
  • Fred........the website for the aluminum turbo resonator is riordanco.com. You will need to ask them about a replacement resonator for the '08. Also be sure to check your turbo charger hose. I had a very small hairline crack in mine and it caused me to loose power. I had to squeeze the hose to see the crack. I temporarily fixed it with super glue and Gorilla tape and eventually bought a new $95 hose. Good luck!

    I have driven 35,000 miles since replacing the plastic resonator on my 2005 Sprinter and it has performed flawlessly. I am also getting 24-26 mpg. Every 5 or 6 tanks of diesel I add a bottle of Lucas gas treatment. Seems to really help the mileage and the performance. When the Sprinter is good, it is great. But when it is bad, you want to go shoot it........
  • k4wcbk4wcb Posts: 1
    Jim, how do you unhook the EGR valve? My van is in the shop now and my mechanic said the EGR might be the problem. I haven't got the time or money right now to replace it. If I can disconnect it and everything run ok, I may go that route for a while.
  • jimf36jimf36 Posts: 3
    I dissconnected the EGR valve connector it's on the side of the EGR valve and my ran fine , it gave me a different code but still ran good.I read that you can clean them with mopar #04318039ac rust penetrant and to use a new gasket #0510 4007 aa.I have bought both of these but haven't tried it yet.It's worth a try just not high on my list now. I would not recomend driving not hooked up for long I don't know what other damage that will cause.
  • hi, have a 2006 2500 high top 158", been reading all the post, check engine light on, limped home, currently in shop, my question is we hear a humming,someone meantioned a humming egr valve, once you replaced with the new resonator did you still have humming from your egr valve or did you replace it,
  • jimf36jimf36 Posts: 3
    MY 2006 the EGR valve was humming .If you unplug it it you can be sure it's the egr because the humming will stop. My resonator was not bad .I had it on a smoke test and also removed it and epoxied it at the seam for piece of mind.Mine system passed the smoke test.There's a couple sensors that can affect the egr valve.A new egr valve is over $450 just for the valve. I'm told you can clean the egr sometimes and it will work.I bought a gasket and cleaner ,but got buzy at work. Hope to get back to it soon.Please post your out come. Thanks
  • hi, just got back my sprinter, it too is a 2006, it threw codes of P5025,P2359, they replace fuel cap, changed charge hose assembly,new intake pressure sensor and air temp sensor, it running with power but am testing it over the weekend with hills to see if it throws any codes,check engine light is off presently, but still have that humming,beginning of the week transmission is due for a flush has 162,000 miles all open road driving,
  • I have a problem with my 2006 Sprinter 3500. it died on me without warning and l had to be pushed of a ferry.The power connection to the Mass Air Flow Sensor had to be unplugged before l could start it. When the connection is in it will crank but will not start. l have had the Mass Air Flow Sensor, Oxygen Sensor, Resonator, Turbo, EGR Valve and all 5 injectors replaced, problem remains. With the connection removed it starts immediately and drives but with poor performance, no power and smokes a bit. it can barely go up any hills. Please help me. lt has been almost 3 months and it is my main source for work.
    thank you
  • I have a 2005 dodge sprinter cargo van. while driving it losses power, when shut the engine off and restart it get going normal. I am puzzled as why this is happening? I read all of your comments and if i apply all of your suggestions it will be very costly. I need an expert opinion as what to do to fix my 05 dodge sprinter, is it the swirl valve actuator the EGR valve, DPF, MAF sensor? what would you wonderful folks suggest i should do to get my truck back to work? please advise
  • romaneyromaney Posts: 2
    I have a 2006 Sprinter 2500 2.7L that I purchased used at 114,000 miles. I noticed after I drove it 1,000 miles that it had a power loss so shut it off and restarted with no issue for a while. Had the turbo resinator eliminator replaced with a factory issued one but still had the same problem occasionally. Before driving it from Colorado to Baja, Mexico had the part replaced again with the Riordan Co. aluminum aftermarket one. After driving to Baja and most of the way back had the power loss one more time close to the border. Then went home, shut it off and didn't drive it for a month. Left home to go to Utah camping and had low power loss and high power loss for 200 miles straight; shutting it off did not correct problem. Mac Daddys in Grand Junction looked at it, ran a smoke test which it passed with flying colors, and declared that I needed a new turbo. Kept driving it in G J for a few days while waiting for the part with absolutely no issue again. Ultimately did not get the turbo as the gaskets did not show up with the turbo and they could not reschedule for a while. Took it to Denver to the German Auto shop I usually have work on it and they told me it is not the turbo. They replaced the PVC (ERG) valve and that took away some of the codes it had been throwing, drove it 180 miles and had power loss once at about 150 miles. Took it back to Denver and they replaced the Turbo Booster and it wouldn't throw any codes, but power loss within 10 miles of their shop and then again at 100 miles from their shop. Am at my wit's end trying to get my vehicle to run smoothly. Any advice will be welcome. Oh yeah, had power loss one more time when I had driven it again 150 miles, but shut off and it cleared each of the succeeding times since trip to GJ.
  • romaneyromaney Posts: 2
    Replacing the fuel filter tomorrow to see if that corrects the power loss.
2»
Sign In or Register to comment.
Dodge Sprinter low boost problem - Page 2 - Car Forums at Edmunds.com