Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Saturn Maintenance & Repair

1333436383942

Comments

  • bookworm3bookworm3 Posts: 1
    Hello,

    I had a similar problem with my 2002 L300. I had to turn off the security system, it should be in your manual. The security chip in the key was sending a faulty message to the computer, basically the car thought I was trying to steal it and shutting the gas off to the engine.

    Hope this helps.
  • natbergnatberg Posts: 1
    My saturn is possessed. I was told it was my BCM. BCM??? What the heck is that? Why would that be screwed up? My question about these cheaply built cars is how does your BCM mess up? Beside the fact the dealer is selling you a cheap POS and raking in the doe by it falling apart constantly and what do you know only the dealer can fix the problem. :confuse:
  • martianmartian Posts: 220
    Anybody know where it is? My wifes RH front turn signal lamp stopped working-replacing the bulb doesn't help-but I don't know where the flasher module is-anybody know?
  • My 6 cyl. 2000 Saturn starts fine when cold but, on hot days, after I drive it and shut it off for just a short time, it will not start. It doesn't even turn over. If I wait a while for it to cool, it will start okay. What should I check? I'm a do-it-yourselfer but this problem does not show up on my OBDII. Could it be crank sensor? start motor? park/neutral sensing switch? Obviously whatever it is gets too hot and won't work till it cools off.
  • Just in case you still need info...
    I just resolved a 97 SL2 with that same issue as one of its problems (hard start, tip in stumble, intermittent bad idle, grey smoke at cold start) :sick: . What finally did the trick was the Engine Coolant Temp Sensor (ECTS) and the Idle Air Control Valve (AICV). :D
  • Hey there --- I too have the same year, make and model of Saturn. My horn did the same thing only recently and I as well unplugged the fuse so that the horn doesn't operate.

    I know it has been almost 6 months since you posted this question but I was wondering what you ended up doing to fix the problem and if you had any advice for a fellow 1994 Saturn SL2 owner.

    Thanks in advance --- MATT06071977 from New Hampshire
  • vincalvincal Posts: 1
    how did you go about turning your system off looked through manuel and could not find
  • I'm looking for comments, advice, etc. from Vue owners who rack up a lot of highway miles. My '02 Vue is a FWD4 5 speed with 140,000 miles. It's running strong and has required minimal maintenance/repairs to date. I'd like to hear from owners with more miles than me regarding what to expect as the miles accumulate, and how to prolong the life of this vehicle as long as possible in a cost effective manner. Thanks!
  • Hi. I'm having a coolant issue with my Ion1. After the car reaches driving temperature, has been shut off, and allowed to sit for more that an hour or so, there seems to be coolant smoke coming out of the exhaust when I first start it back up. I have noticed that if I remove the overflow tank cap and release the pressure when I first turn the car off, this doesn't happen.
    Has this happened to anyone else? As far as I can figure, it is probably an intake manifold problem, since there is no coolant in the oil. I have no idea what this will cost, or if indeed this is the problem. Any suggestions of questions I should ask when I take it in for service? All help would be appreciated.
  • Just a wierd question about your Saturn. Did it start making the horrible clicking sound just after your "tensioner pulley" was replaced? Mine did, but I was dumb and drove it with the belt almost falling off for about 6 miles to a garage with no gauges working. Cost way too much to fix :)

    Ralph
  • lswattslswatts Posts: 1
    Does anyone know where the turn signal flasher module is located? Recently my turn signals and hazard flashers have only been working occasionally and intermittently (sometimes normal speed, sometimes slow, not at all, etc.). I called the dealer but his response was that I should just bring it in. Through internet research, it was suggested that the flasher might be the problem and I don't want to pay the dealer charges if I don't have to.

    Any help would be appreciated. Thanks
  • sbagirlsbagirl Posts: 1
    Just got an '07 Vue (manual transmission). Love it, but it has one problem. Sometimes when accelerating after a period of "coasting" at one speed, engine revs but car does not accelerate, then the RPMs will suddenly jump about 500 and car will accelerate. It's almost like it's getting stuck in neutral for a few seconds (but it's firmly in gear). This has happened on level, uphill and downhill, both 4th & 5th gears.

    Any idea what to make service look at? It's going back to dealer today.

    Thanks.
  • heres one for you guys we have a 2001 L series heres that has an intermittent dash failer (ie gauges tach ect) last time this happened lost park lock dome lights powerlocks A/C No blown fuses relays or bad grounds that I can find messed around and purposlly shortted the trunk pop dash dimmer swith which blew BCM fuse replaced fuse and everything was back to normal now its doing its gauge thing again Im not lacking in wrenching ability but I do hate electrical have read some of the posts here and they point to alt or BCM failure have a repair manual for this vech but does not tell me where BCM is If any one knows would really appericate knowing avoid unnessacary disassembly THANKS
  • i am having the same exact problem when i swaped an angine out of a 96 sc2 into a 95 sc2 if you get any helpful replies please help me an forward them to jay_bauer@student.ntcmn.edu
    Thanx alot
  • im not positive but i think if you pull the left side kick panel and look above fuse box you will see a light brown relay plugged into its own set of wires i believe this is your clicker boxand or flasher relay.
  • Ive heard the same thing did you try a fuel treatment usally takes 24 hrs to work but if you got some water in the fuel it should clear it up usally when tanker is filling it will push condensation that is on top of fuel into fuel
  • I'm having a similar problem with intermittent starting. I have replaced the radiator, water pump, hoses, thermostat, and just last week, the crank position sensor. I'm wondering if the one that was installed was faulty. Can you help me out?
  • I994 Saturn 2 dr.--Temp and fuel gauge inop--Checked and found IGN 1 , 10 amp fuse blown. Replaced fuse and it blew again-Wiring diagram shows a # of items on that fuse. One is the Passive Restraint Control Module. Where is that located and what should I check next?
    Thanks for any help.
  • 04 Vue FWD V6, 55k miles. Last Wednesday with no indication whatsoever, I went to turn the car on after doing business at an ATM (it had just been on not 3 minutes before) and POOF!! the car was completely dead, no interior lights, nothing. Someone was kind enough to stop and try to jump the car off, but the battery was too weak. :mad:

    I had no indication at all that this was going to happen. The car has been extremely reliable and wasnt having any problems cranking.

    Replaced the battery and everything seems to work fine now. Alternator checked fine with 13.9 VDC and almost 90Amps output.

    Does anyone but me think a 2-1/2 year old car should need a new battery? Anyone have any idea how many years the battery is warrantied for? Should I go to my local Saturn dealer and try to get some sort of reimbursement?
  • hsavagehsavage Posts: 1
    I'm having this same issue on my new '07. I've taken it in 4+ times and they aren't able to reproduce it, could you tell me if you have any luck with it? Thank you.
This discussion has been closed.