Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Pontiac Bonneville General Maintenance and Repair

1454648505172

Comments

  • I have a 2000 SSEi with 64K miles on it. About a month ago I was driving it and noticed the tachometer fall to zero, but the car was still running. Then it progressed to the tachometer dropping off with a slight vibration or a stall. I took it in and it was the crankshaft position sensor.
  • I have a 2000 SSEi and the only complaint I have about the car is the power windows. I had to have the power window assembly in every door repaired except for the drivers window. Anyone else had any power window problems?
  • I had that happen on 3 different windows on my 2000 SSEi. 2 were repaired under warranty and the other I had to shell out about $450 to the dealer. I had to place with the window to get it to hold up. I ended up using a little wooden wedge like the kind a locksmith would use so he could insert a car-opening tool.
  • I have a 2000 SSEi and the trunk leaks. I like the car except for some poor quality like the 3 power window assemblies/drives breaking and the leaking trunk. The car had plenty of performance, but I am planning on going back to a truck this Spring.
  • fantascpfantascp Posts: 175
    Hi Everyone- Have not posted in quite awhile- car has been running great- this is just info I'm passing on in case anyone else might run into the same problem

     

    I have a 98 SSE- auto climate control- back in Dec. the blower for my climate control would work one day then stop working the next day- sometimes it worked in the morning and later on the same day it stopped working- after checking out all of the obvious area's- fuses,connections etc.- still keep working on and off- I checked with my friends at the BONNEVILLE CLUB forum for help also.

     

    The problem was a BAD SPOT on the blower motor- had it replaced last week- Climate control blower is working great. (Nice to have HEAT again!!!)

     

    Chuck.
  • im thinking about buying a 2003 ssei with 20k on her, what are some of the things i should look out for when test driving it. just want to have the upper hand on things to look out for thanks
  • k & gk & g Posts: 5
    My '98 Bonneville SLE - 105K, had a new Plenum assembly installed Feb. 2, 2005. The next morning, all seemed fine during my 40 min. commute to work. However, when it came time to leave for lunch, big trouble began as soon as I turned the key.

     

    The engine light began flashing immediately and kept flashing. The car sputtered and misfired repeatedly and thick, blue smoke spewed from the tailpipe. It didn't smell like oil at all. It smelled like nothing I've ever smelled - or would want to smell again! The smell filled the interior of the car even though all the windows and outside vents were closed. My eyes stung from whatever it was.

     

    The drivers manual said it was ok to drive (right back to the garage) so I took it slow and easy. The smoke and misfires got worse. At one point I pulled over to check under the hood to see if anything was leaking and to check the oil level. Didn't see anything unusual. Throughout the drive the engine light continued flashing. A couple of times it stayed on, but then resumed flashing.

     

    The garage couldn't look at it until the next morning. Guess what? They said they couldn't get the car to repeat the problem. They kept it an extra day to drive it; still no problems.

     

    This doesn't surprise me, because except for the blue smoke, that was what the car did BEFORE we replaced the Plenum. It either started and ran great, or it did what I described above. I'd let it sit a day and try it again, and it would be fine.

     

    Should I mention that the antilock brake light stayed on for months in spite of repeated trips to the garage- and they couldn't determine what the problem was? Did I mention that my heads-up display works off and on as well?

     

    This car has made more trips to the garage in one year than my Corsica has in the 15 years, 179K miles I've owned it. I bought the Bonne to replace the Corsica. Good thing I didn't give up the old car!

     

    I just spent a bundle to repair a problem that still isn't fixed. No wonder these cars have low resale value! I'm really at a loss, financially and otherwise. Any advice would be greatly appreciated.
  • alcanalcan Posts: 2,550
    If coolant got into the exhaust system during the plenum replacement it could cause the symptoms you describe. Shouldn't be a problem if it's running ok now.
  • k & gk & g Posts: 5
    Thank you for your quick reply. I really appreciate this forum. Drove it all day, going from car lot to car lot looking for my next car.

    Had no problems, except that I discovered that a Bonne is the only car in my price range that I really like. I can't believe after all the problems my '98 has given us that I'd ever consider buying another.

     

    Two more questions: First, can you suggest which Bonne model years from 2001-04 seem to offer the fewest problems? Second questions, what is the difference between a series II and series III engine? Which is more reliable/trouble free? My thanks.
  • jwallyjwally Posts: 71
    1)I have gas that leaks near the quick connect fitting when the hose(line) going from the connection to the filter is moved in a particular way by hand or by road vibrations.The three metal lines of the fuel sender are very rusty(flaking). I was told I need a new fuel sender which is leaking at the quick connect fitting.I was wondering if anyone has experienced this? What about getting a used fuel sender from a salvage yard? I was told the Fuel sender I need is an AC Delco Part# 25162242 Does anyone know where to get this part from the cheapest New and used? I found the cheapest around $285. Does anyone recommend changing the strainer while apart? My Email is JWALLY063@MSN.COM

     

    2)I just got a check engine light with the code P0401 EGR insuffient flow. Any Ideas of what to do or how to correct this? No noticable performance problems.
  • alcanalcan Posts: 2,550
    If there's a fuel leak, you could end up in the next zip code in a hurry. Fuel pressure is up to 47 psi at open throttle. A used sender module will probably be in not much better shape than yours. Up here in the rust belt we have specialty shops such as Gas Tank King, which repair gas tanks by epoxy coating them. They also rebuild fuel senders by cutting off the rusted tubes and replacing them. Might be worth your time to check your yellow pages.

     

    Re the P0401, what year is it?
  • 98 Bonneville. Car has delayed interior lights which work fine. When driving the car the interior lights always remain on. Fix?
  • Hey Granny: I had EXACTLY the same problem. I pulled the trim strip back from around the windshield and found a gap in in caulking. Get some black silicone gel and fill up the gap.
    The easiest solution to the leaking trunk is to just take the spare tire out and drill a hole in the bottom of the " well". Then, don't put anything in the trunk you don't want ruined.
    My car has 147,000 miles on it, and it has never failed to crank, but as far as stuff like this, it's a piece of junk. The list is too long to get involved with. The strange thing about it, my car gets 29 mpg on the road, plenty of horsepower, is an excellent car to take on those 2,000 mile trips, and everyone loves it's appearance. I just can't stand water inside of my car !!!!
  • imidazol97imidazol97 Crossroads of America: I70 & I75Posts: 18,382
    mlm4, "Pontiac Bonneville Owners: Problems & Solutions" #765, 6 Jun 2002 3:11 pm

    may help. It lists the places to check and seal. Does anyone have the TSB? If not this link gets you to a forum. Post the question for a TSB and someone will supply the text!!!

    markswalk1, "Technical Service Bulletins" #377, 13 Feb 2005 1:47 pm
  • kz700kz700 Posts: 3
    I ended up getting a rebuilt trans from GM. The clunking ended up being the primary drive chain getting loose while in park or neutral at high idle. Once I called to have the trans done, that same day the car began slamming hard on downshifts into first gear coming to a stop and missing shifts when getting on and off the gas under 20 mph.
    I really don't have bad feelings on the trans job, the rebuilt was pricey ($2000) but warranted for 3 years and 50K miles. GM calims that any improvements made to the design were incorporated into the rebuilt unit.
  • kz700kz700 Posts: 3
    Does anyone know where the door switches are located? I think I have a bad door switch. The interior lights don't come on anymore and the delayed radio shut off doesn't work either.
  • alcanalcan Posts: 2,550
    Integral with the door latches, but don't overlook a broken wire in the harness between the door and cowl, especially the driver's side.
  • y2kgmcy2kgmc Posts: 23
    I have a 98 bonneville ,check engine light is on, is there a way to retrive diagnostic trouble codes without a scan tool ? it came on right after I used top engine cleaner to decarbonize combustion chambers....Thanks Ed
  • imidazol97imidazol97 Crossroads of America: I70 & I75Posts: 18,382
    I assume the light is on steady... not flashing.
    That means a pollution control problem. One is that the pressuring test isn't passing.

    Check the gas cap!!! Check the rubber ring and see if it appears to be sealing against the metal of the tank tube. Put some petroleum jelly on it.

    Look under the air intake filter holder for the tubes going to and from the box hidden under it. (I assume your layout's the same as my LeSabre.) A tube pulled off there can upset the tank seal.

    The most likely cause is a gas cap not on and sealed. The test is done when the engine is slightly warmed up. And then is restarted. I'm guessing it's above 110 degrees but below an upper level. Only when started at that range is the pressure test done.
  • alcanalcan Posts: 2,550
    No, but AutoZone will do it gratis.
  • Although I agree with the pain in the wallet at the gas pump, I just can't agree with the 3800 SC being a better engine than the GXP's N*.
    I currently have a 2004 GXP and a 2004 GP GTP, and the stump-pulling power of the N* wins hands down. This thing just keeps going. Not going to go into details, but the Bonny has over 20 MPH faster than the GTP on the top end, and it was still climbing.
    Don's get me wrong. I agree the 3.8 Liter is a great, reliable motor. The GTP is my 3rd 3800 equipped car (All GP's) and it is a rocket out of the hole. But once the supercharger maxes out, all thats left is a V-6 to keep it going...
  • k & gk & g Posts: 5
    Can't say, just that I am having the same problem with my '98 Bonne. Pretty embarrassing driving down the highway at night with the interior lit up like an airport runway. By the second day, the problem resolved itself. It's a mystery why it did this.
  • k & gk & g Posts: 5
    Have spent $3K in repairs in the last 10 months on my '98 Bonneville - (106K highway miles)

    Repeat trips for anti-lock brake and engine light code issues. Anti-lock still not right, and having to replace brake pads every 2-4 months! (luckily, brake pads are still under warranty, but this is ridiculous!)

    Replaced the plenum last month to resolve engine light/performance problems. No improvement! Engine light still flashes when accelerating; feel car missing- poor performance.
    When I take it back to the shop, they say they can't get it to reproduce the problem. Before I get home with it, the engine light is flashing again and the car is driving rough. Just had the plugs and wiring replaced- still no good.
    Now they tell me the plenum is leaking again.

    During the few days it wasn't in the shop, the interior lamps wouldn't turn off while I was driving it.

    Please tell me... was '98 just a bad year, or are these problems common to Bonne's in general?
    My husband wants to get another Bonne - It's the first time I've doubted his sanity!

    Comments, suggestions please.
  • montanafanmontanafan Posts: 945
    And you are blaming the car for this?

    My only suggestion it to find someone who can fix something.
  • k & gk & g Posts: 5
    Yes, for these reasons:
    1. The same problems I've noted are listed repeatedly in posts throughout this forum. They too complain that these problems keep re-occuring despite repair.
    2. We use ASE Certified GM specialty Master Mechanics trained at the #1 Auto Tech program in the U.S. -from two different, well respected shops. The last trip was to the largest Pontiac dealer in our area. We are not dealing with backyard-type mechanics!
    3. We own a '91 Chevy Corsica, 178K miles- that has only required a water pump repair in the 14 years we've owned it.
    4. Our '82 Honda had 190K miles on it when we sold it- It too only required a water pump
    5. Our '79 AMC Jeep J10 is still running, quadratrack and all- It's repairs haven't totaled $1200 in its lifetime.

    This Pontiac has had an easy life. It has 106K, true- but all highway miles, and I don't 'get on it.' It has been kept on a religious maintenance schedule.
  • Can't say I blame you. I've replaced 2 power window modules on my own (cheap plastic piece acting as a reel always going bad & have to buy entire module from GM who imports from overseas...China I believe). Yep...opening trunk causes water to enter trunk when raised. Now have multiple power option problems.
  • There's been a few of us with that issue. I've replaced 2 power window modules on my own for about $200/window. Took about 2-3 hours per window. A cheap, threaded plastic piece acting as a cable reel/pulley has been wearing out for me. Then the metal cable (like a bike cable) gets kinked and becomes useless. Have to order the entire module from GM and they get it from overseas...China I believe. Wonder what China gets paid for it.
  • The water in the floorboards may be caused by a blockage where it's supposed to drain towards the rear bottom of the front wheel wells. I'd suggest partially removing the plastic piece on each rear side of the front wheelwells to inspect for a blockage. Removing 2 plastic fasteners holding it in place toward the rear side of the front tires should allow you to move it aside and see if there's a build-up of sediment, salt, leaves, etc. If the build-up is to great, water will leak onto the floorboards (front & back) of which side has a build-up problem. Check which side it's on and look at that front wheelwell. Then you'll get to dry out the carpeting.
  • For me, the fault has been the white, plastic take-up reel for the metal cable that housed in the round part next to the motor. Replaced 2 in 4 years. Good point...METAL AND PLASTIC HAS NOT BEEN A WINNING COMBINATION...at least not in this application!!!
  • Heated seat in a 2000 just went out in winter/2004.
Sign In or Register to comment.