Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Pontiac Bonneville General Maintenance and Repair

16667697172108

Comments

  • alcanalcan Posts: 2,550
    Pull the plugs and inspect for signs of coolant contamination. The upper intake plenum is probably warped in the EGR tube area, allowing coolant to enter the intake.
  • imidazol97imidazol97 Crossroads of America: I70 & I75Posts: 17,705
    What are the signs on plugs of coolant (Dexcool) contamination? What should I look for when I change my own plugs?

    This message has been approved.

  • alcanalcan Posts: 2,550
    White deposits on the spark plug electrodes, electrodes wet or very clean looking. Also, crank the engine over with the plugs out and look for any coolant or vapour coming out of the plug holes. We do that with a cooling system pressure tester installed, which will force coolant past leaks and into the cylinders.
  • bkm645bkm645 Posts: 1
    I have a 96 bonneville with 93k miles on it. And I drove to the mall in it but, when I came out to go home it would not start. The radio worked, but when I turned the key it did nothing. So I went to sears in the mall and bought a battery. Installed it, both of the screws were nice and tight, but it still would not start, it did the exact same thing. And help would be greatly appreciated.

    Thanks,
    Brian Mullins
  • jwallyjwally Posts: 71
    Regarding post#1347-1350 I like to know if pulling plug and inspect for signs of coolant contamination. How will i know if i need intake plenum and/or head gasket? How can i determine if i need either one or both? when i turn key it cranks but takes a few seconds to run. I use a full gallon on one way 45 mile trip. No signs of leaks. when car idles it leaves one foot round wet spot but no white smoke. also when stop at light feels like it wants to stall and sputters. check engine light on steady and sometimes blinks, also traction off light goes on and off at times. Please alcan or anybody any help is appreciated,thanks. oil pressure at idle about 40-50.
  • alcanalcan Posts: 2,550
    If the coolant level is dropping in the overflow tank but there are no external leaks, it has to be going somewhere and that somewhere is usually through a warped upper intake plenum. I've already posted how to check for this condition. Head gasket failures with 3800's are rare.

    1 full gallon of fuel for 45 miles = 45 m.p.g., very impressive gas mileage.

    The wet area is probably air conditioning condensate, normal.

    For the hard start, locate and remove the vacuum hose attached to the fuel pressure regulator. If there's any evidence of gas in the hose, replace the regulator.

    If the check engine light is on have it scanned at any AutoZone (no charge) and post back with the stored trouble codes.
  • imidazol97imidazol97 Crossroads of America: I70 & I75Posts: 17,705
    Did the dash warning lights stay on after you put the key in -- specifically did the 'security' light stay one. That means the key resistor wasn't being read right. It stays on for three minutes if you try turning the key 3 times and the resistor is wrong. After 3 minutes with a working resistor you can start the car.

    Do you have a second key? Try it -- if the security light on the dash is staying on. I had a problem a few times with dirt, lint, goop, on the resistor contacts not letting the reading be correct. Cleaning with pencil eraser works. But I had to try my second key.

    I also had the wire to the lock cylinder start breaking strands from flexing the tilt wheel up and down. That caused the light to go on but the car still started. If the wire breaks too many strands the resistor reading to far off and the car won't start because it thinks it's being stolen.

    This message has been approved.

  • jwallyjwally Posts: 71
    1 gallon of antifreeze/water not fuel. the one foot round water spot is from the exhaust pipe(tail pipe). sorry i wasn't clear before. hope this helps you help me with more ideas. thanks Alcan(your an asset to the forum) and all.
  • alcanalcan Posts: 2,550
    First, pick up a block and head check kit from any parts store. It checks for the presence of hydrocarbons (fuel) in the radiator. If so, a head gasket is blown or a head's cracked. Neither is likely.

    Next, remove the spark plugs and inspect them as mentioned previously, install a cooling system pressure tester on the radiator and leave it pumped up for a few minutes, unplug the wiring harness from the ignition module, crank the engine over, look for any coolant mist coming out of the plug holes. Probably #4 and #6, rear bank driver's side. Would probably also account for the check engine light, usually code P0300, random multiple engine misfire.

    The throttle body, which attaches to the upper intake plenum, has coolant passages around it to promote cold weather driveability and throttle response. The coolant passages are between the lower intake manifold and upper plenum. The EGR (exhaust gas recirculation) tube is also right there, and heat from the exhaust gases degrades and warps the plenum over time. A slight gap develops between the manifold and plenum, coolant starts leaking into the manifold, and you now have an engine which consumes coolant.

    Keep driving it like that and you'll discover either A: coolant doesn't compress in cylinders and you have a bent connecting rod or wiped out rod bearing, or B: none of the engine bearings like being lubricated with coolant. Either way, you'll be looking for a replacement engine or scrapping the car if you don't get it corrected.
  • I have the exact same problem in my 95 Bonneville- both with the security light and the alarm going off unexpectedly. Any information that would solve this problem would make me and my neighbors very happy.
  • hey, I was in a wreck 12 months ago and my weather stripping around the window and driver and passenger doors woun't hold a seal. do ya have any advice???
  • If your weather stripping is new or in good shape theres not much you can do there..If it is mushed, cracked of extremely flimsy then replacing might solve the problem. If the door is slightly out of alignment then you will have to adjust it at the hinges. Open and close the door a few times very slowly and listen for a perfect click.. If its hitting hi or low you will be able to tell.. Good Luck with it
  • I have 1997 bonneville with climate control. The blower motor is going on & off even though the display shows high. Does anyone have any ideas.
  • imidazol97imidazol97 Crossroads of America: I70 & I75Posts: 17,705
    Had problem with blower motor changing speed and not going on higher speeds. It was a control panel for the speed adjustment... don't know the name. B ut it was an expensive repair for a 'switch.'

    It had a power transistor on it and some small items. Maybe about 4 inches by 2.5 inches.

    This message has been approved.

  • jwallyjwally Posts: 71
    In regards to previous post#1347,1352.I changed the intake plenum which did have holes in EGR ports. Shame on GM for not making good to customers(hope to see classaction lawsuit some day). I still can't get car running. It cranks over but won't run. If I feather(pump) the gas while turning key it seems like it wants to run,also strong smell of gas and black puff of smoke out of exhaust. I don't have a fuel pressure gage or scan tool so I'm limited. I pressed the schradder valve in on fuel rail and get a small one second squirt of gas with key on. I never took out plugs because they were in too tight and were affraid of breaking.any suggestions are appreciated.
  • jwallyjwally Posts: 71
    I changed the fuel filter now I get a good stream of fuel when I press the schadder valve.I hear fuel pump come on when key is turned.Is there anyway to read check engine codes without a scanner?Car still will crank over but don't start.
  • jwallyjwally Posts: 71
    Well alcan was right on target.It was tghe spark plugs I had car towed to King Bear St James,NY who charged me a whopping $199 to change plugs and so call tune up.The only tune up was my wallet.no wires just plugs.so a little advise before you get overcharged(ripped off)listen to Alcan.
  • imidazol97imidazol97 Crossroads of America: I70 & I75Posts: 17,705
    the service he provides here. He helped me without making me feel dumb. I cleaned my own throttle body - got rid of the sticking accelerator.

    His wealth of knowledge is appreciated here.

    This message has been approved.

  • alcanalcan Posts: 2,550
    Well, if they used ACDelco platinum plugs (what it calls for) they're $13 and change each here in the Frozen North and not the easiest to reach, so that price isn't really too bad. Glad to hear you got it sorted out.
  • 2000 bonne ssei Part of the numbers display on the radio will not light. Can this be repaired? Thanks for any reply.
Sign In or Register to comment.