Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Taurus/Sable Squeeks, Rattles and other Noises

jeepgonemad1jeepgonemad1 Posts: 2
edited August 17 in Ford
I have a clunking noise in the front of my Mercury Sable 02 and I replaced the struts and the upper baring mounts but i still have the noise that sounds like its coming from the front of the car....anyone know what might be causing it?
Thanks for your Time

Comments

  • i have the same car, and the same problem. someone told me it would be struts, but i guess not?
  • danielj6danielj6 Posts: 285
    Have your rock and pinion checked, it may have to be replaced.
  • dmysterdmyster Posts: 12
    Ok, so i found out that it is the rack and pinion making the noise... do you know about how much that would cost to have replaced? my sable has been a real money pit ever since i got it, i'm in college and im sick and tired of spending money on my car.
  • danielj6danielj6 Posts: 285
    Sorry for the delay but I was away for the holidays and just got back. It's a somewhat costly repair. I was quoted
    $500 + labor back in 2004.
  • dmysterdmyster Posts: 12
    ouch! well, maybe this will be the last problem I have with the car.... yeah, right. anyway, thanks for the info, I appreciate your help.
  • I have a 2000 Mercury Sable station wagon, V6 w/DOHC. It squeals loudly when it's turned sharply to the right or left. Does anyone have any idea what's causing this noise?
  • chuckhumpreychuckhumprey Posts: 2
    edited October 2010
    ^ this is also happening to me. I've been trying to figure out what's wrong for days, I have no time yet to bring it to mechanic. I've changed a lot of my ford taurus parts, every week i've been encountering different problems.
  • I have a similar clunking noise on my '99 Sable with only 45K miles. It only makes the noise when going over small bumps like lane markers and when going straight. Speed bumps don't make it happen. It's not noticible at high speeds.

    My shop told me it is the lower ball joints. I don't believe him because I put the hole front end on jack stands, got a crow bar and pried on all suspension connections looking for something lose and found nothing.

    My car also has the skwealing noise when the wheels are turned all the way either way. It is some problem with the power steering valving or pump. It has been doing that for ~10k miles but still steers OK. I had the power steering fluid and filter changed but it didn't help.
This discussion has been closed.