Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Mazda Protege Maintenance and Repair

1102103105107108122

Comments

  • I am considering purchasing a 2000 Protege from an individual. It runs and drives great, but the Check Engine light is on. The owner says he's had it scanned and the fault is with the "Clutch Position Sensor". I'll have the vehicle inspected including a scan before purchasing, but I'm curious if anyone has experience with this type of fault code.
  • My 2002 Protege ES cuts out or misses at 2800-3000rpm, above that and below it is fine. Doesn't matter whether you aare going slow or fast.
  • We have a 2002 Mazda protege5, And this is the second time in little over a year, our ABS, emergency Brake, and O.D OFF light comes on, and our speedometer tops at little over 40kmh. when we try to excellerate it just revs. We have an automatic, but it's like we can't get out of first gear. We called mazda where we got it fix and decribed our problem again and they said they have never heard of that problem before!
  • Hi,

    I have a 1999 Mazda Protege that had the OD Off light problem and it was an indication that my transmission had a leak. I had the transmission rebuilt and it is working fine. It seemed to have the problem only after the car sat overnight. Maybe take it to a transmission place and have them do a diagnostic, though it did not show a problem. I got the car in right away when it started having a problem.
  • My 97 protege's fan only works on the 1 and 2 speed. Replaced the blower motor resistor and it did not help. Where do I go from here.

    Thanks for the help!!
  • hey eddie,

    have them change the tension setting on the timing belt tensioner. i just had the same problem on my 03 protege, and had to have the shop fix it. if they are not adjusting the tension on the belt properly, you'll get that nasty squeal!
  • I've seen this posted befor but i couldn't find the answer so here it goes. I have a 2000 mazda protege ES. Just recently when I go to put gas in it I can only put a little at a time because it starts to overfill. What it does is allows me to put about a half a gallon and then it overfills. Then I wait about 20 sec and start the whole thing over again. It is very much a pain in the [non-permissible content removed]. It takes me about 10 min to put $10 in my tank and thats at $3.50 a gallon!! Any help would be great.
  • autonomousautonomous Posts: 1,769
    recently when I go to put gas in it I can only put a little at a time because it starts to overfill
    I'd bring it into the shop to get it checked; you don't want to damage the guage within the fuel tank as I've heard that could be an expensive repair.
  • Hi All,
    I got a 2001 Protege LX 2.0. Recently I hear some cranking noise from front left bottom when I do the U-turn (left U-turn). I went to mechanic and he said there is a problem with left axle. But after I changed the left front axle ($180 cost), there noise is still there. Does anyone got any idea about this problem? Thanks~~
  • user777user777 Posts: 3,341
    In order to put fuel into the tank, there has to be a means for the air in the tank, displaced by the entering fuel to exit, otherwise, you'll have what is occuring to you, the pump will click off, or you'll have a backflow of gasoline.

    I'm not an expert in this area, but this is what comes to mind:
    You could have a crimped filler tube; that's the tube going from the filler neck down to the tank, or conceivably (and you'd have to call a shop that knows about Mazda's and the fuel system arrangement in your car - I'd suggest looking in the yellow pages for an independant shop) I believe there's a gas tank vent solenoid and vent line as part of the evap system which reclaims gas fumes and returns them to the tank. Either the vent line is kinked, or the vent solenoid isn't doing it's thing.

    Google it.

    Good luck.
  • Ok about a month ago my 99 pro lx(125000mi) was vibrating at hiway speed and stopped. then last week i start the car put it in drive and the check engine light started flashing and i could tell it was misfiring. i stopped at a light and the CEL went steady. i checked the the code and it was P0302 ( misfire in cylinder 2) does anyone have like a clue as to what could cause the misfire. mind you i just had a tune up ( brand new wires and brand new double platinum spark plugs). any help would be greatly appreciated
  • I'm sorry I don't have an answer for you, but I do have the same problem. I let it go for few months and recently checked it out. I removed the tank and the filler neck, but did not see any restrictions. I suspected that the venting system me be not working correctly and really didn't want to pay to have fixed. I let it go a little longer, but realized that that the car would seem to run out of gas a lot sooner than normal. I know its bad to run a car that low, but I always liked to check and see exactly what point the car would run out, just in case. This new problem has been getting worse and worse, it now chugs like its low on gas at a quarter tank. The car always starts and drives well when it first starts up, but a few minutes go by and it chugs and hesitates. I immediately suspected the fuel filter, but realized these cars only have a sock filter on the end of the pick up tube. I also removed the charcoal canister to see if it was plugged and was causing a vapor lock, which would explain both problems, but that did not help. At this point I suspect once again that one of the emissions/vent solenoids are to blame, but am not sure which one, or how it all works. Please let me know if you have fixed your problem yet, and if anyone else could help, or supply some info on this vent system that would be greatly appreciated. Thanks.
  • Hey all.
    My wife has a 2002 Protege 4 speed automatic.
    About 5 weeks ago, she noticed that the engine was running a little rough and the "Check Engine" light would come on. When it came on, it flashed for about 5 seconds and then stopped. We took it in for the 60,000 check and they did everything they were supposed to.
    Well, we noticed within a few days, the car ran worse than before the 60,000 mile check up. It ran rough at stop lights, the check engine light came on a bit more, and a new twist - when driving on the freeway, the car seemed to hesitate a bit or, when it would lurch to a degree.
    We took it in 2 weeks ago, appararently, during the tune up, the mechanic forgot to put some conductive agent on the coil which was causing a misfire, hence the check engine light. Well I got the car back and we are still having the problem of hesitation on the freeway, almost near stall outs at stop lights (Though that was a one time thing and generally runs smoothly at stop lights) and the "Check Engine" light is making new visits. Flashing at first, then turning off after about 5 seconds. But, definetly, more often.

    Our trip to the dealership yesterday didn't yield any results. They had the car for about 7 hours. According to the computer, the engine is misfiring still, but they cannot locate the reason why. They did check the EGR valve and it is working fine. (Though this was a problem of the "Check Engine" light about 8 months ago.) We got one phone call wanting to know if we had changed gas stations lately. End Result: Drive the car for a week and bring it back next Saturday and see if anything new is on the computer.

    Well, this morning on the way to work, the car started a few new things. One, between 30 and 40, the car surges. You can see the tachometer moving up along with the surges. Two, when downshifting, starting at 40 mph, the car surges there as well and you can see the RPM surge about 500 rpm for a second.
    Does pretty much the same thing at just below 20 MPH.


    Anyone have any additional thoughts as to what this could be?

    Thanks.
    Dave
  • after checking the coils and wires and fuel infectors etc. so finally as i suspected my spark plug was the culprit. the tip broke off ( i really dont know how that happened). so the 2nd cylinder wasnt burning gas so it was damaging the cat converter. my car doesnt like spark plugs apparently one flew out another stripped the cyl head and this one just up and broke
  • Where is the fuel filter located on 1993 Mazda Protege? Thank you so much for your help with this.
  • neesieneesie Posts: 13
    I have a problem with my OD Light Flashing. I noticed there are old posts with the same problem. Has there been any resolution to this issue?

    My OD light started flashing over two months ago. I took it to Goodyear for a check. They suggested transmission flushing but before they did it somehow the radiator was damaged which cost me $500 for a new one.

    They had said that the transmission fluid was low and very dark. But with the radiator repair, I told them not to flush the transmission but put in more transmission fluid. Anyway, when I pick up the car, the flashing light was off and stayed off for several weeks. Now it is back on. I took it to a different service repair person who said that one of the solenoid was sticking and I should have it flushed which I did. He also said that if that did not work I may have to take it to a transmission specialist like AAMCO. But the light still flashes occasionally. I have 114050 miles on the car, what should I do? :cry:
  • just a thought ditch the platinum plugs, I found in my 01 dx they ran like crap and caused problems, next inspect the #2 boot/wire. Look for light gray marks and small cracks.

    J
  • autonomousautonomous Posts: 1,769
    the transmission fluid was low and very dark
    Hmm, not a good sign. Is this the first time you've had the tranny fluid changed?

    Are there any other symptoms like suspicious sounds or vibrations? Does the car appear to change gears properly or is there slipping?

    I'd check a reputable tranny shop recommended by AAA and see if they can provide a diagnosis.
  • neesieneesie Posts: 13
    This is the first time I changed the fluid. I car has always had a lot of noise especially when the car sits idle when at a stop light. The noise is only heard when inside the car particularly when the windows are closed - it is very loud.
  • I have a 98 Protege. One of the pullys is rattling when the car is on. I am wondering if it just needs to be tightened, or if it needs to be changed, and if either of those are the solution, how would I go about this?
  • I noticed that the ABS and brake lights stay on when I drive my 2002 Mazda Protege ES. It's something I haven't noticed before and so I plan on having it checked at my local Mazda dealership. Why would these lights be showing up on my panel?
  • Hi Im new to this forum and I have a 92 mazda protege lx that was given to me about a month ago. I was told by my friend who gave it to me that it was in great running shape. This morning I went to go to work (I live in alaska yes its cold!) and I couldnt get the car out of part. Its an automatic. It is now afternoon and it still sits in the driveway because it still wont go into drive. This has never happened since I got the car. I read what the book told me to do but in order to check the tranny fluid it says to start the car put the hand brake up and put the shifter into neutral but it will not go out of park. Any ideas??? I cant afford to fix this at a shop it would require towing it. Can this be done at home? :confuse:
  • I had the trans. fluid changed on my '01 Protege at 30K. I think the dealer did a flush too. Now at 60K, I was talking to my mechanic who has been working on my other cars for 25 years. He says you should not change the trans. fluid on a Protege or Ford because that is guaranteed to cause it to fail. Come to think of it, I gave up on Fords after trans. failures on a Sable and a Taurus, fairly early. I don't think the manual specifies a change is needed (didn't see it). Advice? Thanks.
  • autonomousautonomous Posts: 1,769
    my mechanic who has been working on my other cars for 25 years. He says you should not change the trans. fluid on a Protege or Ford because that is guaranteed to cause it to fail.

    Bizarre. What I have heard is that for a very old car that has never had a transmission flush, you may run into a problem; the flush in effect causes a bigger problem than it solves because it "stirs" up the gunk that has accumulated in the tranny. But if you have maintained your transmission, you should not be running into that type of problem.

    I would try calling a few transmission shops to see what they say. A transmission flush is inexpensive.

    p.s Although Ford is the parent company it does not make all the components for its partners, Mazda, Volvo, Jaguar, etc. The four cylinder engine in a Protege is not a Ford product as far as I know. The 6 cylinder is another story but that is used in the 626 and Mazda6 and not the Protege or the Mazda3.
  • I have somewhat of a problem, wonder if anyone knows the answer to this..I am trying to replace a catalytic converter assembly on my 1997 Mazda Protege LX. I do not have an owner's manual for the car.

    Apparently there are two (2) different catalytic converters, depending on whether your MAZDA has a 1.5 L engine or a 1.8 L engine. I cannot find this info anywhere on the engine, in the engine compartment or anywhere else on the vehicle. Sometimes the VIN identifies these things, but I do not know how to interpret the number...
    The VIN on my vehicle starts with JM and ends in 7 digits. If anyone can tell me how to get this info I would appreciate it.

    Thank you.

    Doug
  • newbie here, i need advice. i have a '94 Protege 4 dr auto, near new condition,not many miles. bought used, no trouble for several years then auto trans went out. too bad to repair. put wrecking yard trans in it, did good for about 1yr then after using passing gear one day it starting leaking trans fluid very bad,just pours thru,no hole in case. it sat for about 2yrs, now needs fuel pump and tank,bad rust. going to cost $500. to have fixed to run so the trans shop can fix or look at trans. what to do.... great car, great mpg, great engine but has what is termed " the ford fragile transmission". ?? thought about changing over to manual trans. money is a problem,limited. got 22yr old daughter moved back home,starting over. needs transportation. got suggestions????
    thanks
  • I just replaced my engine and the new one wont start. I'm getting fire to all plugs,
    and fuel to the injectors or at least i think fuel is getting to the injectors. I puled the
    fuel pressure regulator off and fuel is in the line leading to the injectors. I put the
    timing at TDC on the compression stroke and the rotor was at #1. I'm stumped.
    Any suggestions or tips.
  • You can call the Mazda dealership with the VIN number and they can tell you the
    type engine you have. Hope this helps.
  • 1redtag,

    I'll probably upset the protege fans, but I get the impression you need transportation rather than a car hobby. my advice is to unload the protege and find something else. you're looking at spending a grand or more on a 13 year old car that's sat for a couple years - sitting is bad. personally I wouldn't touch a car that old with an automatic.

    imo the cheapest transportation deal right now is a used Taurus. stay away from pre-96 because of tranny problems though.

    an alternative, if you're able to do some work, is to find another BG protege ('90-94) with a manual tranny and solid mechanicals. use your existing car as a parts car. swapping wheels/tires, even interiors, is much easier for a diy'r than a transmission swap.
  • ...I would try calling a few transmission shops to see what they say. A transmission flush is inexpensive...
    My Mazda dealer charged me over a $100 for the trans flush and service at 30K. My mechanic must have been thinking about manual trans. He is also from the 'old school' so I tend to discount some of his advice. However I looked in the manual and there is NO mention of a transmission service being required. The flush or don't flush is controversial I know.
Sign In or Register to comment.