Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Mazda Protege Maintenance and Repair

1140141143145146183

Comments

  • mshutemshute Posts: 1
    Hello all, recently brought my 99 ES 1.8L to the dealer to check out the A/C since my compressor would not kick in. I was told it was the PCM not sending a ground to the compressor. I'm obviously not going to replace the PCM for $1200 for this but I'm hoping someone can tell me they were diagnosed with this same problem and found an alternate solution. Thanks for any help..
  • sambo4sambo4 Posts: 22
    You can always try a used PCM.
    Where I live, the auto-wreckers sell PCM's for
    Protege for about $100. They come with a 30 - 90 day
    guarantee. I have replaced used electronics and they
    have worked now for years.
    I'm not familiar with the part, and don't know if you
    can change it yourself or not.
    Just call up every wrecker you can until you find one.
  • creon448creon448 Posts: 3
    After having my motor mounts replaced, my transmission failed and needed to be serviced. Since receiving my car from the mechanic, I have noticed that the exhaust note has become very raspy. Moreover, after coming to a complete stop, my car will hesitate breifly when I press the gas. I read on the net that when the transmission is removed for service, that the transmission mounts should be replaced. Is it at all possible that the problems I'm experiencing are related to the transmission mounts?
  • creon448creon448 Posts: 3
    Does anyone know the technical explanation of the o/d button?
  • adisaradisar Posts: 4
    I have a 99 Protege, with 59K on it.
    Recently, it has started blinking the O/D light once in a while, which goes away if i turn off the engine and turn back on. Shifts are somewhat rough. I can also hear some sort of a noise when shifting in lower gears. Hasnt given any problems on the highway yet - works absolutely fine when running at speeds.
    Having read all messages rgding auto-trannies on proteges, can someone give me a couple of options to diagnose issues for the autotransmission?
    Thanks
  • creon448creon448 Posts: 3
    Does anyone know how to safely clean the EGR valve on a 98 Protege?
    I was thinking about adding "SeaFoam", but I would prefer only to apply it to the gas tank and engine oil.
  • sambo4sambo4 Posts: 22
    Here's a few questions:
    1)Is the check engine light on at all?
    2)Have you scanned the engine for a code?
    3)When the "O/D Off" light is blinking, can you
    get into overdrive, or does it stay in 3rd or 2nd gear?
    4)Is the air hose in good shape- no cracks, or air leaking out?

    Okay, just to give you more info, go to this site:
    protege5.ugly.net/
    Then go into page 15, that's DTC TABLE[FS]...01-02B-15
    If you look across the headings, DTC NO.,Condition,MIL,
    then "O/D off indicator light", follow that down to
    P0122 TP circuit low input, and P0123 TP circuit high
    input, you notice that those both show Flashing, right?
    I was informed by a mechanic that the computer does this
    blinking thing just as a safety mode, possibly to prevent
    bigger damage, and it makes the driver stop the car.
    Your car may possibly be in the early stages.

    By the way, I can't take any credit for that other site I
    mentioned, since someone else mentioned it here first.
  • sambo4sambo4 Posts: 22
    I forgot a couple of details when you go into that site:

    Look for ENGINE, then ON-BOARD DIAGNOSTIC [ENGINE CONTROL SYSTEM (FS)], click on 01-02B,

    then go to page 15, DTC TABLE, etc.
  • adisaradisar Posts: 4
    Thanks for that sambo4. I did get the OBD test done, and it returned a P0734 Gear 4 Incorrect Ratio.
    Can anyone tell me what it means? The mechanic said it will be an electrical problem with a solenoid.
    What are my options in this case? I have an extended warranty on this car.
  • adisaradisar Posts: 4
    To reply to your questions:
    1) No check engine light on
    2) P0734 Gear 4 Incorrect Ratio code returned
    3) I will have to check if it goes into 2nd or 3rd if OD light is blinking. Till now it has always happened on local roads, so I have immediately pulled over.
    4) The air hose DOES seem to have some cracks in it, and air IS leaking out.
  • sambo4sambo4 Posts: 22
    If you go back to that site:
    protege5.ugly.net/
    then look under: TRANSMISSION/ TRANSAXLE 05
    ON-BOARD DIAGNOSTIC, click on 05-02.
    Look under DTC PO734, and it tells you to go to
    page 30. When you go to page 30, there are 11 possible
    causes for that condition, including ATX fluid low,
    solenoids may be stuck, etc.
    I guess you'll have to go thru the diagnostic procedure.
    I don't want to confuse things any further, but the air hose being cracked suggests TP or Speed sensor.
    I noticed when I got my scans done, some shops are
    better than others. Some places won't pick up all codes.
  • single female with dog moving across country. my o/d light was flashing on, a different feeling to the gas pedal so decided to pull over. my non-stickshift '99 protege LX w/100k miles was not shifting correctly, stopped at a gas station/service center at the last exit on the east side of albuquerque, nm; when i came back out after speaking with the tech. there was a "pissing stream" of tran. fluid coming from a cylinder about 8 inches long a few inches diameter with a band around it near my driver side tire. i'm pretty sure all my tran. fluid is out of my car. SO...what to do? no shop is open until monday and again, i'm moving across the country with no connections in new mexico. basically, any advise to who i should take it to and how not to be taken advantage of - like do i need a new transmission or could it possibly be something else by the above discription? i'd appreciate any help! -stuck in a hotel indefinately.
  • sambo4sambo4 Posts: 22
    The air hose is easy to remove- there's only 2 screws on those circular clamps, and just ease off the wires and things near the top. You can use duct tape as a temporary measure to seal the cracks. A brand new air hose is about $ 40. I asked my mechanic and he said the air leaking out could screw up the TPS or the PCM.
  • phillygrlphillygrl Posts: 1
    I hope someone can help me here...
    my protege is having technical difficulties to put it lightly. the car would turn off while driving, I had to jump it 2 times to get it home. I bought a new battery for it, changed the spark plugs, oil...it ran for 3 days and then it wouldn't turn on and the battery was dead.
    I was told to check the alternator which I did...3 hours later it had been removed and checked at pep boys, after 2 tests it had passed. today I bought another new battery, new battery cable wires, fuses hoping this might be the solution...if anyone lives in the Philadelphia, Pa area..I make a mean [non-permissible content removed] london broil an baked potatoe and chicken parmesean! *hint hint hint*
  • pattywpattyw Posts: 1
    I have a 98 masda Protege and all of a sudden I can't even turn the key. Any ideas. The steering wheel is not locked.
  • adisaradisar Posts: 4
    Hi sambo4

    Used duct tape to temporarily fix the air-hose. Seems to make quite a difference. Idling smoothly, feel lesser vibrations....need to change the hose soon though. Still need to get the transmission checked.
    Thanks for the tip...
  • katek8katek8 Posts: 2
    please help. I have a 97' mazda protege. the a/c works for about 20 minutes and then gets not cool. then continues on the pattern of cooloing and then not so cool. had the ac compresser replaced 2.5 yrs. ago, and had a fan replaced 2 months as well as freon, and an ac check. please help! Thanx K8
  • ayipayip Posts: 1
    I just changed my protege 92' brake pads now my brakes goes all the way down it is like I have no brakes at all, I dont understand what happend, I checked brake fluid level and it is fine, and there is no bleeding since fluid level is fine please help..
  • PFFlyer@EdmundsPFFlyer@Edmunds Pennsylvania Furnace, PAPosts: 5,808
    Summer's here! (Well, just about) Beat the heat and stop in to the chat tonight to talk about your favorite brand... Mazda!

    PF Flyer
    Host
    Automotive News & Views, Wagons, & Hybrid Vehicles


    The Mazda Club Chat is on tonight. The chat room opens at 8:45PM ET Hope to see YOU there! Check out the schedule

    PFFlyer@Edmunds

    Moderator - Hatchbacks & Hybrid Vehicles

  • pblair7pblair7 Posts: 1
    I recently unplugged the negative battery cable on mazda protege 200 to get the check engine light to go off. I was able to get the light to go off but the car runs like total crap now. I must have wiped out its running memory or something. Does anyone know how to fix this?? Thanks, Paul
Sign In or Register to comment.