Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Mazda Protege Maintenance and Repair

1162163165167168183

Comments

  • downtubedowntube Posts: 43
    If there's any air leak between the filter box and the intake manifold, that will cause an idle problem. The accordian-like tube is susceptible to cracking. Since the car's been in a front-end wreck, I'd inspect carefully for leaks.
  • kenjenkenjen Posts: 9
    I have a 94 protege 194k miles dx automatic. I have had this car for about 3 months and it has been great...until I parked it one night and when i got up the next day and cranked it it was sputtering and knocking it will not idle and when i try to drive it there is no power. If I put it in park and floor the accelerator it will only go to about 3500 rpm(still sputtering) and almost sounds like it is flooding.When I got the car I put new plug wires,plugs,dist cap and rotor button on it and accessory belts. I am disabled and only drive the car about 20 miles a week. I thought it may be fuel filter so I replaced it and removed the injectors and cleaned them still the same problem...help please,thanks.
  • MrShift@EdmundsMrShift@Edmunds Posts: 43,699
    You might drive to Autozone and see if they can get any trouble codes out of that OBD-I system, since you've done all the obvious stuff already. They'll read them for free.
  • kenjenkenjen Posts: 9
    thought of that but they said they cant read it cause it is a 94..but it wont drive,no power. I did discover it has a very weak spark off the coil(yellow) instead of blue. swapped the coil out with another to see if that was it but same thing,yellow spark. I am stumped,I looked in a haynes manual but the electrical diagrams are sketchy at best. I am getting battery voltage at the coil(13.2 vdc) and the old coil ohmed out within spec.
  • MrShift@EdmundsMrShift@Edmunds Posts: 43,699
    Well then there are "manual flash codes" you can read off the engine light but you have to know how to do it on the OBD-1. I should have remembered that Autozone doesn't read OBD-I.

    You might have to cruise the specialty Honda internet sites to get this flash code information, or buy the proper workshop manual that tells you how, but you need some hard data to figure out what to do next. You can't just be throwing parts at it, that's expensive and frustrating. Your public library might have something.
  • kenjenkenjen Posts: 9
    I saw something the other day on what your talking about I will just have to remember where it was. thank you very much for your input and if I get it figured out I will be sure to post the fix.. Kenneth
  • bdkaybdkay Posts: 6
    To all you guys and gals out there with a Protege that runs rough with a code that says intermittent misfire, here is what it took to fix the problem.

    Spark plugs, coils , wires, injector flush, new PCV valve and count 'em four fuel injectors. One was really bad and the dealership put in one new injector and 3 used ones. All of this was covered under the extended warranty we bought 5 years ago. All the work worth about CAD 2600. Not a cent did we pay to have this troublesome problem fixed. So far, no more check engine light and the car is purring. Hope this helps other people out there with the same problem.
  • bdkaybdkay Posts: 6
    To all you guys and gals out there with a Protege that runs rough with a code that says intermittent misfire, here is what it took to fix the problem.

    Spark plugs, coils , wires, injector flush, new PCV valve and count 'em four fuel injectors. One was really bad and the dealership put in one new injector and 3 used ones. All of this was covered under the extended warranty we bought 5 years ago. All the work worth about CAD 2600. Not a cent did we pay to have this troublesome problem fixed. So far, no more check engine light and the car is purring. Hope this helps other people out there with the same problem.
  • PFFlyer@EdmundsPFFlyer@Edmunds Pennsylvania Furnace, PAPosts: 5,810
    Tuesday means Mazda chat night! The chat opens at 8:45 pm ET and runs until 10 pm ET. I hope you're able to join us tonight to meet and greet with your fellow CarSpace members!
    See you there!

    PFFlyer@Edmunds

    Moderator - Hatchbacks & Hybrid Vehicles

  • kenjenkenjen Posts: 9
    got the code it is a 7-rich/lean detected,I would expect this being the spark from the coil is weak.there is full battey voltage at the coil,ignitor tested ok and coil ohmed out within spec. :
  • kenjenkenjen Posts: 9
    where is the egr valve on a 94 sohc protege?
  • maltbmaltb Posts: 3,572
    I don't think it has an EGR valve.
  • kenjenkenjen Posts: 9
    could this be the problem???????? if i squirt wd at the base of the injectors the car stumbles which I guess means it is sucking air ,bad o-rings? chime in, the auto parts store wants 7 bucks for the o-rings hardware store 20 cents?
  • maltbmaltb Posts: 3,572
    Chances are it's a non-standard o-ring. Most of what you'll find at the hardware store is nitrile. You can try using it, but it may not fit right or might not be the material you need (EPDM, viton, silicone, etc). So what's worth more: your time or $7?
  • kenjenkenjen Posts: 9
    Yeah i thought about that 2 seconds after i hit the send button,After all the threads I have seen where people have spent big bucks chasing these rough running symptoms down 7 bucks is a cheap fix, thanks,Kenneth.
  • kenjenkenjen Posts: 9
    well the injector seals didn't help, has anyone ever looked at the spark comming off the coil to ground? I am still thinking it is a lack of good spark but I am getting conflicting opinions on wether or not a yellow spark is bad or not.I tried a delco coil out of my jeep and it too shoots a yellow spark, if the timming belt jumped a tooth would that cause it? I feel like i am swimming in a pool of sharks!!
  • maltbmaltb Posts: 3,572
    I would continue to look for air leaks. If spraying around the injectors changed the RPM, look for a leak doing that with a spray carburetor cleaner.

    Focus on rubber parts like intake boots, vacuum hoses and grommets.
  • kenjenkenjen Posts: 9
    found the iac valve is not working properly,any suggestions on the best way to clean it/remove /type of cleaner. could a blockage in the cooling system be a contributing factor/ I just found out the guy i got it from put 2-3 cans of radiator stop leak in it(the kind with the pellets) just before i got it....
  • Were can I find a manual for the protege 1.6 .Is there anywere I can Download the manual,with out paying for it..Thanks!
  • Hi i have a 1994 mazda protege DX and it will not start.. my engine keeps on flooding.. but i am not hitting the gas pedal or nuthing.. its as soon as i turn on the key the engine floods. and i get black smoke coming out of my tail pipe. and i got a strong smell of gas... i do not have a Diagnostic tool and the auto zone has only a OBM II scanner... The next auto repair store charges 75 dollors and hour... all i want done is to run a Diagnostic.. is there a way to extract the codes manually?

    also what could cause my engine to keep flooding? Sensors?? my Fuel injectors. work fine as i had my Brother in law help me with it.. we removed the injectors.. and they all look good tested them they all work fine so we put them back into the car... could it be a Sensor? like the O2 Sensor?
Sign In or Register to comment.