Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Mazda Protege Maintenance and Repair

1169170172174175183

Comments

  • giacomodgiacomod Posts: 9
    Hello
    after i had gone to the dealer i had so many things done and actually it was not what it seems it was ,i have a mazda protege 97 ,this car had so many things done,after i had all this things done my real problem was the timing belt and the water pump,but i also did a completely tune up (coil -rotor- o ring-cap plugs-wires-
    clean fuel injectors replace one , maf sensor-replace connectors-air filter-check all the water and air hose from the radiator and egr valve and fuel line-also i had a new egr valve-a new idle air control valve ,fuel filter,fuel regulator, clean the intake manifold,so many things before i had the timing belt and the water pump.so i will suggest before you try to do so many of this things you should have an honest meccanic check it out and give you an estimate,also if you are not getting enough power it could be a transmission issue and fuel pump issue,or related to fuel,guessing can be expence try to minimize the real problem,one by one,i started that the computer tells me it was an egr valve and it follows by other but the computer was wrong so many times, it give an engine light because there was other real problems causing it ,anyway good luck.
  • brian374brian374 Posts: 5
    I have a 2002 Protege LX with 63,000. Recently while driving, it will not stay in overdrive. Pops out, and I let off the gas and it slips in, put on the gas, slips out again. Does not do any slipping in any other gear, just overdrive. Any ideas? AAMCO wants to rebuild the entrie transmission, but I strongly believe this is not the case because they are not certain where the problem sits. I'm thinking something electrical?? It doesn't have many miles to warrant a total transmission rebuild.
  • jenni81jenni81 Posts: 3
    Hi,

    I'm looking into buying a 2002 or 2003 Mazda Protege with around 70,000 miles to get to around while I'm still in college. This will be my first car so I would appreciate some advice on the following:

    - Is there much difference in reliability between the 2002 and 2003 models?

    - Are there things in particular I should look for when I go check out the car? I've read here about the EGR valve, anything I can check for related to that? Any other problems?

    - I know it depends on a lot of factors, but overall would you say it is a good purchase that won't give me too much trouble?

    Since this will be my first car I am a little nervous about getting a lemon, so I would really appreciate your input.

    Thanks.:D
  • autonomousautonomous Posts: 1,769
    Is there much difference in reliability between the 2002 and 2003 models?
    No, there is no big difference in reliability.

    Are there things in particular I should look for when I go check out the car? I've read here about the EGR valve, anything I can check for related to that? Any other problems?
    Rust around the wheel wells can be a problem. Also, check the state of the disc brakes to see that they do not need replacement.

    I know it depends on a lot of factors, but overall would you say it is a good purchase that won't give me too much trouble?
    Overall, a reliable car. Check Consumer Reports for their recommendations on used cars. To be sure the car has been well maintained ask the seller if they have all the service records and have the car checked at a mechanic of your choosing. Be wary of sellers who do not want to do this. If a seller claims the car is fine they should feel confirdent about it passing this test. Your mechanic will also provide valuable information about items that may need to be addressed in the near future (such as worn tires) so that you can reduce the surprises after your purchase.

    Final words about Proteges: great cars!
  • downtubedowntube Posts: 43
    At 70k there are some things you want to know

    - How does the transmission perform? Drive it on the highway, noting how the transmission shifts as you accelerate onto the highway and how it downshifts as you decelerate. If you detect anything rough or jerky, or if it fails to stay in overdrive while at speed, stay away.

    - When you turn the key on, the Check Engine light will come on momentarily as a test. Make sure it really comes on - otherwise it may have been tampered with. Also make sure the light goes out once the engine is started.

    - Pay careful attention to how the car idles in Park, and in gear while stopped. It should idle smooth and not too fast. EGR problems, IAC valve problems, or vacuum leaks will cause idle problems.

    - If it has power windows, make sure they all roll up and down.

    - Drive slowly over a speed bump or similar, and listen for clunks in either the front end or back. Rear endlinks aren't too expensive to have replaced, but front ones are.
  • jenni81jenni81 Posts: 3
    Really, really good advice there. Thanks a lot downtube and autonomous.

    To clarify, you mentioned,
    Pay careful attention to how the car idles in Park, and in gear while stopped
    I assume this is for an automatic transmission? If so, then for a manual does the same apply when idling in neutral?

    Also if anyone else has some other input it would be appreciated.
  • downtubedowntube Posts: 43
    Yes, the same for a manual transmission in neutral. Most people prefer an automatic (not me), so I assumed that's what you were considering.
    In either case, a vacuum leak will generally cause the engine to idle too low to the point of stalling, then overcorrect and rev too high, then drop down start dropping too low. The air/fuel ratio is wrong and the computer can't compensate. Typically they will run fine when not idling, when the amount of air leaking is small compared to the total airflow.

    BTW, I love my protege. I've been looking for another one for my kids to drive.
  • stmyersstmyers Posts: 7
    I have a 2003 protege es with only 74k miles and I just replaced some belts and the radiator (due to a crack). But since replacing the raidator, my car will not hold coolent and has over heated less than 200 miles from having it back. The mechanic Ive been taking it to says he can not find anything wrong with it. What caused your radiator to have a crack in it? Im only worried because I do not know what other damage this is doing to my car. I do have an extended warrenty, but if i dont know what the problem is, what am i to do! :confuse:
  • autonomousautonomous Posts: 1,769
    But since replacing the raidator, my car will not hold coolent and has over heated less than 200 miles from having it back.

    Is the coolant leaking to the ground (and not into the engine)?

    Were the hoses leading to and from the radiator replaced?

    Were the clamps holding the hoses checked?

    Have you considered going to another garage for a second opinion?
  • stmyersstmyers Posts: 7
    I bought my car new in 2003, Ive kind of have had problems with it form day one. but nothing as major as now. My belts broke on my car so I had the car towed to the mechanic and they replaced the belts. I couple weeks later my car over heated on me so I took it back. It turns out my radiator had a leak/crack in it. I had them replace it a mazda radiator and had them pressure test the hoses and they said it was all good. A couple of weeks later while I was driving my over heated on me . (it had only been 200 miles since getting the radiator replaced) I took the car back the the mechanic and they said they could not find anything the matter with it. They checked the hoses again and the gaskets. they still said there was nothing wrong with it, but it is not holding coolant. I will fill the over flow up and a day later it is empty. I need help. I am in college, therefor i would like to hold on to my car for another year, but with things happening Im worried.
  • stmyersstmyers Posts: 7
    I have NOT seen any coolant on the ground.

    No the hoses were not replaced, they pressure tested them and there were no leaks.

    I will ask about the clamps.

    one of my customers owns a shop who customizes cars and he said to bring it by.

    Did i mention i live in texas!! Could that have anything to do with anything (the heat?)
  • jenni81jenni81 Posts: 3
    Thanks again.
  • autonomousautonomous Posts: 1,769
    I have NOT seen any coolant on the ground.
    If it is not leaking below, then where is the coolant going? How often do you have to replace the coolant?

    No the hoses were not replaced, they pressure tested them and there were no leaks ...one of my customers owns a shop who customizes cars and he said to bring it by.
    Ask your "customer" to take a look at the hoses to see if they still appear usable (no bulges, cracks, softening ...). The hoses and radiator in my 2002 Protege5 are still in tip top shape (knock on wood).

    Did i mention i live in texas!! Could that have anything to do with anything (the heat?)
    Yes, your car is obviously using its cooling system more frequently than someone living in a cooler climate. Also, driving in congested traffic can be taxing. But, your car's radiator is made for that purpose and should be working properly.
  • downtubedowntube Posts: 43
    Did they replace the radiator cap when they replaced the radiator?

    The coolant is going somewhere. Either blowing out the expansion tank overflow when you're driving, or out a leak when driving, or into the cylinders.

    If the radiator cap is not operating properly, it will let coolant flow out into the overflow tank at a lower pressure than intended. This will overflow the tank and spill out on the ground when the engine is hot. As the engine cools, the coolant in the overflow tank will be sucked back into the engine.

    The same thing could be happening with a properly operating cap, if your engine is overheating.

    If it's going into the cylinders, your exhaust will smell like antifreeze. Blown head gasket or cracked head.
  • Hi everyone -- hopefully someone can give me some advice. I'm driving a 1995 Mazda Protege which has some engine noise under load and a loss of power. It's been getting progressively worse over the years, and it's now to the point where I have almost no acceleration at all, and I almost have to floor it just to maintain highway speeds (especially if running the A/C). There's also a loud noise coming from the front of the car when I accelerate -- my dad calls it a "birdcage" noise, but it sounds like some kind of rattling. All the mechanics I've taken it to over the years have just called it engine ping and suggested I use some fuel injector cleaner, but that obviously hasn't helped. It doesn't make the noise while idling -- only while pressing down on the gas pedal, and the noise gets louder as I press harder.

    I'm pretty sure it's engine issues, but I don't know exactly what it is. Does anyone have advice? Thanks in advance!
  • krzykj1krzykj1 Posts: 3
    Searching for answers- HELP PLEASE ! I have 2000 Mazda Protege ES that came standard w/ a 1.8 ltr engine. I bought this car used & love it. Problem : While changing the timing belt & parts, I have found out that the engine was changed to a 2001 2.0 ltr ES. I keep coming up with Engine Codes will not reset readings, every time I try to have an emissions inspection done. Have gone through MUCH grief with the state of NC & quite a few insp. stations. What, if anything can be done ? I'd like to keep it & drive it.
  • downtubedowntube Posts: 43
    You can take to to most any major automotive store, and they will scan the car at no charge and tell you exactly what codes are coming up. They usually even have some suggested causes for those codes. Do that, then post the codes on here.
  • krzykj1krzykj1 Posts: 3
    Not coming up with any codes. It's reading "Codes Will Not Reset".
  • nzwellingnzwelling Posts: 1
    Hey everyone!

    I have a problem with my 1994 protege. It was working fine for a long time, but I recently took a 120 mile road trip, and now it's... not working so well. The engine stutters and feels like it's not giving any power. This seems to happen mainly at 1st 2nd and 3rd gears - things seem to work okay at higher gears... although the problem does seem to be getting worse. I drove it to the store and back to test it out, and I heard what seemed to be a metallic grinding or scraping sound (maybe) coming from the bottom of the car.

    From what I've read on this forum and some other places, it sounds like it might be the clutch slipping. What do you guys think? Futhermore, I am currently 120 miles away from home - if the clutch is slipping, is the car okay to drive for that long? (uphill - along I-40 from hickory to asheville, nc, in case anyone is interested)

    Thanks in advance. I would really appreciate any help thrown my way here...

    oh yeah: the car has 170k+ miles on it. don't know full vehicle history (bought it used a couple months ago), although title check showed no salvage, etc. stuff. No problems to this point, except an axle that had to replaced (front right).
  • mnfmnf Posts: 404
    Can anyone help i am looking to replace a burned out OD dash light on a 2000 Mazda Protege DX. There are no shifting issues or blinking of the light it looks like the bulb JUST burned out. Thanks for the help>>>

    MNF .
Sign In or Register to comment.