Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Mazda Protege Maintenance and Repair

1177178179181183

Comments

  • autonomousautonomous Posts: 1,769
    You might want to get it scanned for a problem code to narrow down the possibilities.

    You mention spark plugs being replaced; did you also check the condition of your wires?

    Finally, a common problem in the Mazda Protege is a dirty / clogged EGR valve; it may be worth a look see.
  • This sound like ignition coil/Wire problem. to check, start car and then spray water on the wire and plugs/coil, distributor and best if done at night so you can see if you see any sparks arc-ing where they should not be. Give it a try, it is free and let me know.
  • jrdwyerjrdwyer Posts: 168
    I have a '95 Protege. I have recently noticed (in the last half year) the fan switch malfunctioning on a few ocassons. For example, the switch can be on fan level 3 and the fan will not blow. If I then move it to 2 or 4 it will work. If I move it back to 3 it will usually work.

    I believe the contacts in the mechanical switch are probably corroded or worn out? and the switch is open and not allowing the flow of current. It hasn't occurred often enough to warrant me pulling off the plastic cover and examing the switch.
  • jrdwyerjrdwyer Posts: 168
    edited October 2011
    I bought this car new in March '96. It has 230K+ miles. I believe the engineers who designed the seats probably did not anticipate a 220 lb. man using this car. Just recently, the metal seat rail broke where the bolt connects to it. A small piece of rail snapped off on the driver's front left side. The bolt at this location connects upward into a pivoting metal bracket while cinching against the rail. The bracket is connected to the frame of the seat.

    Thankfully, I found several good scrapped Proteges at our local pull-a-part junkyard. I got the part for $2.50. It was an easy removal/fix. I just pulled the whole seat out through the back door, turned it upside down, replaced the part, and reinstalled.

    I'm in this car for the long run. I need to attend to some rust in the rear fender wells. Will sanding down to metal, prime, and spray paint take care of it?

    I really don't have much clear coat left on the paint, so matching shouldn't be too big of a deal. The car actually looks very good when washed and waxed. The white color helps. I like the satin or matte look of the finish when cleaned, as opposed to the plastic shiny look of new cars with the clear coat. I may repaint the car down the road. I have a home-made paint booth in the garage and I have become handy with the purple $10 harbor freight paint gun, which is quite good for the price.
  • I"m loosing break fluid, and Im not sure where it's going. I recently replaced my master cylinder, because the seal was bad and it had been leaking into my booster. Days later, my break light came on. When I finally looked under to hood, the master was almost dry. Here's what's weird: Im loosing fluid, but I don't know where. I can pump the peddle up, but it will slowly drop. I can't see any signs of were the fluid might be going. If there was air getting in the line, then the peddle should be junk, and stay junk until I bleed the line out. If the master gets really low, the peddle is junk until I add more fluid. I am totally confused as to what is going on.
  • Mr_ShiftrightMr_Shiftright CaliforniaPosts: 44,404
    sometimes the brake fluid can be burned through the vacuum brake booster.

    MODERATOR

  • i have replaced the TPS sensor which is what that code is for and reset the car but code still comes on and O/D light still flashs 98 Protege LX 1.5
  • Changed the TPS sensor and still getting a P0120 and O/D light flashing...... any thoughts?? 98 Protege 1.5
  • Mr_ShiftrightMr_Shiftright CaliforniaPosts: 44,404
    Could be your MAF sensor, and could be a wiring defect between the TPS and the ECM.

    MODERATOR

  • Hi!
    Long time... but did you ever figure this out? My 2000 protege is doing the same thing and I can't get it to pass inspection since it's unreadable!
  • Ok, so I was reading up on some of the Over Drive problems as well as the O/D Off mixed with the Check Engine light problems. Here is my problem, I have both O/D Off Light on (it blinks on and off constantly), and have the check engine light on. I have no problem, however, driving free-way speeds (65-85 MPH). What are some of the things I should look out for? And some places that do free diagnostics (without having me pay for the repairs right after doing the diagnostic, for they will charge me for the diagnostic check otherwise).

    Is my Over Drive really on, and just have the O/D Off light blinking for no reason? As for the Check Engine light, I have an idea that it may be the Spark Plugs since they do looks rather old, burned out and dirty. But, I wanna know some other known issues if anyone could help. Thanks.
  • autonomousautonomous Posts: 1,769
    edited November 2011
    I have both O/D Off Light on (it blinks on and off constantly), and have the check engine light on. I have no problem ...
    The check engine light is a general alert to a problem with a critical area of your car (i.e. the engine). Driving with it "on" can appear to be okay but then again it could lead to a significant problem. A diagnostic that reveals OBD codes gives the mechanic more information to isolate the problem and solution. I believe Autozone provides customers a free scanning service to identify problem codes. However, be warned: the problem with the problem codes is that they, in themselves, may not point to the ultimate source of the problem but rather another symptom (e.g. fuel mixture may be too rich but is that caused by the spark plugs or some other source). Not addressing a problem may lead to a more expensive one (e.g. fouled spark plugs leads to failed O2 sensor). You might also look for related symptoms like burning more gasoline (i.e. less fuel efficient) than in the previous year to help determine the problem.

    If my car had a check engine light "on" I'd take it in to my favorite mechanic to see what he says. At the same time, he might help explain what is happening with the O/D light.

    Good luck!
  • hi guys.. i am a first time poster..i hope you can help me out. So the other day i was driving and i came to a stop light. When i left the stop light i accelerated and the car wold not shift it would just rev out in first gear. the o/d off light came on for a while and then went out..so i limped home and checked the fluid..it was a litle low but i dont think enough to cause it to stop working..i topped it off and it still did not want to shift..the speedometer works so i dont thinks its a vss issue..do you guys think a flush and fill with a new filter would do the trick or is it more than likely a solenoid or something like that. i do not have the money for a new tranny and i wreally need to fix this..thanks in advance..also the car works in reverse and has not yet thrown an CEL or any codes according to my scanner..i have not tried to manually shift the gears for fear i may hurt somethin..any help would be appreciated..
  • replace the alternator (bad brushes):
  • Kirstie_HKirstie_H Posts: 10,822
    Considering you responded to a message that's over 11 years old, I suspect the person has solved the problem by now and/or sold the vehicle. No matter... the info may help someone else, but you might check the date on the message you're responding to so you don't waste your time.

    MODERATOR
    Need help navigating? kirstie_h@edmunds.com - or send a private message by clicking on my name.
    Share your vehicle reviews

  • I would replace the fuel filter, air filter, plugs and wires, and egr valve. Also make sure your electrical system and spark coils are good. Pull each fuse out and re-insert them one at a time. Check your exhaust pipes for crimping.
  • I myself don't mind time travelling into the past to help somebody out. With all the brake fluid and other stuff I got in my eyes, the vision isn't perfect anymore. Especially for for seeing the date. :-)
  • Kirstie_HKirstie_H Posts: 10,822
    Nothing wrong with a trip in the wayback machine. :) Your response might help someone else anyway, even though the original poster probably isn't around and/or doesn't own the vehicle now.

    MODERATOR
    Need help navigating? kirstie_h@edmunds.com - or send a private message by clicking on my name.
    Share your vehicle reviews

  • osilkyosilky Posts: 1
    hey pmp3, I would like to clean my EGR valve as well, but seems to me that there seems to be no way around it w/o taking things out of the way. Any suggestions on how to get to it?
Sign In or Register to comment.