Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Mazda Protege Maintenance and Repair

12425272930183

Comments

  • rancorrancor Posts: 2
    I live in the Chicago area, which is privvy to humid summer nights. My 01 LX 2.0's windshield inside fogs up very easily. I had an 00 LX that did this as well, but not nearly as bad. Basically the fogging is water (i assume) condensing on the inside of windshield. The only solution I can find is using the heater set on the windshield defroster and a pretty high fan setting (at least 3). When I do this the fogging goes away but it makes for a pretty uncomfortable ride. I've tried a few glass cleaning products but these really didn't help. Anyone else experience this? I'm open to any suggestions. TIA
  • jstandeferjstandefer Posts: 805
    Usually, on a new car, the oils in the dashboard start too evaporate a bit for the first few months and this builds up on the inside of the windshield. Only a good ammonia based window cleaner will get it off, and this really helps with the fogging. Also, ensure that your air conditioner activates when you swtich to defrost. The air conditioner will dehumidify the incoming air to help get rid of the built-up moisture. Another thing is ensure the ventilation is set up to draw in fresh air and not set to recirculate.
  • protege_fanprotege_fan Posts: 2,405
    Yeah I've noticed a film of sorts on the inside of my windshield. I took a microfiber cloth and rubbed (fairly hard!) and it came off ok. I noticed quite a difference.
  • mazdafunmazdafun Posts: 2,322
    I usually keep one in the car to remove this foggy layer of organic compounds from the windshield and rear window (it accumulates much more slowly on the side windows). Takes some pressure, but I find I don't usually have to use glass cleaner.

    Oh yeah, don't use fabric conditioner when washing your towels. They usually deposit fats to make them feel softer and combat static cling. These will fog up your windows.
  • fritz1224fritz1224 Posts: 398
    You mentioned about the A/C activating when in defrost mode. I suspect this is the case since I noticed a slight rpm increase when in the defrost mode, but there is no other indication that shows this is the case. The owners manual doesn't say the A/c comes on in defrost and the A/C light does not come on. I have a 2k EX which I presume would be the same as 2k1. If this is the case then this setup will not allow you to deactivate the A/C when in defrost. This I don't like. Sometimes, unconditioned air is sufficient for defrosting and I don't want to run my A/C unnecessarily.
  • protege_fanprotege_fan Posts: 2,405
    While we're on the topic of defrosters, when I press in the button for the rear defroster, it makes a strange click sound. The defroster works, but I was curious if the sound was "normal" or not.
  • mdaffronmdaffron Posts: 4,421
    Mine clicks too -- the sound of the defroster relay activating. It clicks again when you turn it off. Sigh, another thing I miss about my '92 ... its rear defroster automatically turned off after 10 minutes or so. The new ones will stay on for as long as the car's running!

    Meade
  • vocusvocus Posts: 7,777
    The defroster even stays on if you turn off the car and turn it back on. Wish it was timed like my Pontiac's was.
  • protege_fanprotege_fan Posts: 2,405
    By strange I meant I thought that it might not supossed to click. When I press in the A/C there is no click, so I thought possibly that the rear defroster click may be something wrong. Don't think it's a problem though. Just wanted to see what your guys' experiences were. Thanks.
  • mdaffronmdaffron Posts: 4,421
    It's the defroster relay. It's normal. Don't worry about it.

    Meade
  • jstandeferjstandefer Posts: 805
    Unfortunately, the 2000 and newer models automatically engage the AC whenever defrost mode is selected. On the 2001 and newer, it also automatically disengages recirc and switches to fresh air. It is a convenience rather than having to press all of the buttons and slide the switches, but I do prefer having control over what's happening.
  • My 2001 Pro manual states that the AC kicks on when the selector is set to "floor". I like to run ambient air through there to keep the air fresh, but now the darn AC is running, sapping the engine power.

    I wonder if there is a way to disable the automatic selection of AC when in defrost, mix, or floor mode?
  • mazdafunmazdafun Posts: 2,322
    They seem to like doing the thinking for the driver where the HVAC's concerned.

    I also prefer the old manual controls where I can set the fresh/recirc, AC/no AC controls myself, even if it means handling multiple controls.
  • I was quite shocked that the defroster on my 2000 protege doesn't shut off on it's own. I think my 72 Datsun 510 shut off on it's own, but I could be wrong about that.

    Also, because the A/C and defroster buttons look the same, I sometimes turn on the defroster instead of the A/C and wonder why it's not getting cooler.
  • fritz1224fritz1224 Posts: 398
    My manual says to turn on the A/C if dehumified heating is desired(mode selector is set to the defrost mode), but I'm sure the A/C is already running. The second fan is running when in defrost so I assume the A/C compressor is too. Is this right? When the split mode(defroster and floor) is used, that second fan does not come on.
  • m78marym78mary Posts: 3
    I have a Mazda Protege 2000. It has approximatley 20,000. On 3 occasions the engine will jerk/hesitate. I took it to the dealer, but it did not do it when they were driving. Can anyone give me some suggestion?

    Thanks
  • protege_fanprotege_fan Posts: 2,405
    When did/does the jerking occur? Might also help if you can tell us what engine, trim level, etc.
    Automatic/manual...etc.
  • m78marym78mary Posts: 3
    I have an automatic transmission. I'd didn't look at the RPMs. The last time the car jerked I was going slow in traffic on the interstate. I'm not sure what type engine.
  • protege_fanprotege_fan Posts: 2,405
    If you go to the "sedans" forum in the Mazda Protege Owners club, and scroll way back, there was some discussion on engine jerking. Mine jerks (haven't had it happen in a while now) when I'm at low rpms and making a turn and going over a speed bump. I drive a manual so I just push the clutch in. Guess you don't have that luxury!I believe Chikoo said something about the engine "rebounding" or something like that. Can't remember exactly though. Sorry can't help anymore than that. There are others here MUCH more knowledgeable than I though...(that's your que guys...)

    PF
  • chikoochikoo Posts: 3,008
    you are dead right protege_fan.
    The engine gathers a lot of torque during the lower rpm and when it shifts gear while your are under 20mph (or so), you can feel the engine bieng relieved of the torque...courtesy of the soft rubber engine mounts....which actually make the engine vibrationless at higher RPMs.
    well i guess you can't have everything ;(
Sign In or Register to comment.