Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Mazda Protege Maintenance and Repair

17374767879183

Comments

  • protege_fanprotege_fan Posts: 2,405
    Have you been using the AC system? It sounds like the condensation is leaking back into the car.

    Just my 2 cents.
  • reitrofreitrof Posts: 122
    Sorry Fries1, even though my flag is Canadian I am living in Boston, MA. I ordered it online from SummitRacing.

    ProtegeFan, do you know what autopart chains might carry RedLine.

    Fries1, try going to RedLines site and seeing what places in Canada carry it. www.redlineoil.com

    HTH
  • protege_fanprotege_fan Posts: 2,405
    I've seen Mopac carry it, but I can't recall if they have stores in Saskatchewan for Fries. I believe Napa Auto Parts has it as well.
  • mazdafunmazdafun Posts: 2,322
    I doubt it's the AC. The drain tube from the box goes through the firewall on the passenger side. If it got clogged or disconnected, there'd be water on the passenger side.

    The tube under the driver seat is the heating duct for the rear passenger when you have air directed to the feet (a little comes out, even if you don't). I doubt water is coming in that way.

    Since it's collecting and not draining, you probably don't have a leak in the floorpan. Sounds like you may have a leak around the windshield or rear glass. I'd poke around both for signs of dried salt or a dirt trail (from dust in the water getting into your car). I found the leak into the trunk of my '89 323 this way (it was a worn gasket around the right tail-lamp assembly...cut my own to replace it and it's been water-tight since).

    I wouldn't rule out the weatherstripping around the doors either, but I don't think it's likely. Look for signs of water stains on the headliner too.
  • doublesixdoublesix Posts: 29
    After reading your suggestions, I went to have a close look of the car. I failed to find any leaking trace along the windshield or the rear glass area. But when I opened the trunk and uncovered the floor carpet, I was surprised to see a awful lot of water and ice in the well for the spare tire. Besides, there is also some water and ice in a small concave area in the trunk on the driver side, but not on the right side where the jack jack handle are placed. And the left side of the cardboard that covers the spare tire is also wet.

    Any idea?
  • dinu01dinu01 Posts: 2,586
    B/c of snow that is melting inside my car, undernear the front rubber mats it's almost like a sponge in certain areas.

    This is not a leak IMO, just snow that is melting inside the car from your boots/shoes.

    Dinu
  • chikoochikoo Posts: 3,008
    u got a leaky gasket on the tail-light.
    get it checked.
    I had it and was fixed.
  • mazdafunmazdafun Posts: 2,322
    Remove the plastic covers over each and look for the dirt. If it's still under warranty, you might be able to get any water-damaged stuff replaced too. Worth asking anyhow. If it's out of warranty (believe me, my '89 was WAY out when I found the leak), you can either buy the gasket or cut one yourself out of some closed-cell foam.
  • chikoochikoo Posts: 3,008
    for only $2.51

    Remember the "bad vibrations" that my car would give off? Well i have not had that for the last 3 days. I am hoping the problem is solved with the $2.51 fix that I made.

    I changed the PCV valve. Instead of using Mazda part for $12, I got a purolator one.

    Feels nice ever since.
    Cross my fingers that that was the end of that problem.
  • doublesixdoublesix Posts: 29
    Many thanks for both of you regarding the water problem.

    OK, I was trying to get access to the rear taillight area on the driver's side to check the gasket, but I encountered another trouble: How to remove the trunk end trim with the inside cover in the trunk? What kind of tools could I use for such an opening?

    I tried to pull the center section of the plastic retainers on the trunk end trim with a screwdriver, but it did not work, and even worse, I broke the top of one retainer.

    Any suggestions, anybody?

    And if the gasket is bad, what can I do? Go and ask a Mazda mechanic to replace it, or I can go to some store to get a new one?
  • mazdafunmazdafun Posts: 2,322
    Pry the center pins out. Then use a pair of needle-nose pliers to grab the stem of the center pin to yank out the fastener.

    Still, you'll likely break some, so order several when you order a replacement gasket.

    You can also bring it in for servicing and have your dealership service department replace it. They should replace any fasteners they break.
  • Hi all,

    I guess this is not a 'problem', but I want to get feedback anyhow. In my 96 Protege (1.5L, 5spd), which is a nice little car, I can feel that in 2nd, 3rd, and 4th gear I seem to hit a 'sweet spot' towards the 'end' of the gear. I don't have a tach (DX model), but, for example, 2nd gear is OK below 15 ~ 20 mph, but if I push it a little beyond 20 mph it feels like it 'opens up' (like the push you would get in a 70's VW bug when the second carburator - or is it secondaries - kicks in), and I feel a noticeable increase in power.

    My question is, is ths the 'power band' I'm getting to, or should I have a more even power band. If so, what could be causing this change? I bought the car with 53K miles, and I am pretty certain it has the original plugs, wires, cap and rotor, O2 sensor, PCV valve, etc., etc...

    TIA,

    G.
  • mazdafunmazdafun Posts: 2,322
    What you're feeling is the engine just getting into the middle of its peak torque range.

    I can't say for sure about your 1.5L, but the 1.6L in my '99 Protege seems to accelerate most strongly between 2500 and 4500 rpm. It seems most fuel-efficient around the lower end of this range (from about 1800-2700).
  • theparallaxtheparallax Posts: 361
    Most 4-cyl's are quite peaky. I find that my 1.6 has most of its power after 3500 RPM. You can definitely hear the engine start to roar especially after I had my aftermarket intake installed.
  • chikoochikoo Posts: 3,008
    5th day...still no bad vibes....the PCV did the trick.

    Thanks goodness...just in time for spring Zoom Zoom
  • fries1fries1 Posts: 12
    Thnks to all you people who recommended the RedLine Oil. I made the change last Friday and it made a huge difference to thr driveability of the car when its cold. I changed from the OEM to Pennzoil and that helped a bit with the synchro ticklin but made the shift stiff and hard to move, but now with the Redline in the transaxle my P5 is much better thx to all. Now why doesnt Mazda have a fix for this under warranty, it ticks me off with a new car, you shouldnt hafta be doing changes to the trans at my expense!!!
  • jeepers6jeepers6 Posts: 4
    On a 96 Protege, I am getting a code p0170 which says "fuel trim (bank1) " in the manual that came with the reader.Does anyone know what the hell "fuel trim" actually means? I can't find it anywhere. The car runs very rough and stumbles(intermitent) and the check engine light comes on. I can reset it with the reader but it onlystays out for a few days. I tried basic tune and filter items but no luck. Tempted to go for o2 sensor but there are 2 and don't want to end up wasting over $150 if It's not it.

    Any input will help-Thanks
  • alcanalcan Posts: 2,550
    Fuel trim is the computer's attempt to adjust (trim) the air/fuel ratio because an O2 sensor is reporting a lean mixture. Start by checking for vacuum leaks, especially any cracks or damage to the ducting between the airflow meter and the throttle body.
  • bthomsonbthomson Posts: 1
    Hi all - my '91 SE is emitting a slow creaking when I turn the steering wheel -- it usually happens when I first pull out of my parking spot and seems to get less noticeable after a few minutes of driving. I think the power steering fluid levels are OK; any idea what I'm looking at?

    Many thanks,
    BT
  • chikoochikoo Posts: 3,008
    I think it is simply stretching out after a good nights sleep.
Sign In or Register to comment.