Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Buick Rainier Electrical Problems

my speed odometer will register the wrong speed I am traveling, sometimes it will freeze and I lightly tape on the dashboard, sometimes this helps and sometimes not. This is inconsistent as many days everything is working great, the buick dealership recommends a $500 replacement part. Could a wire be loose, a bad fuse, poor batteries. poor connection somewhere in the dashboard, could condensation and or different outdoor temperture intefer with accuracy????
«1

Comments

  • libre1libre1 Posts: 3
    It seem to me that all Rainiers have the same problem. I said this becaused I bought one from 2005 and I just came from the dealer with the same problem and they want to charge me almost $ 600 to fix it. I guest Biuck knows about the problem and not want to do anything about it. I will be sending a very angry letter to Buick.
  • Anyone have an idea?
    Truck would not start (dim lights, starter "clicking")...replaced battery. Everything fine. 3 days later... "battery not charging" warning light comes on. I charge battery, light goes off. I take it to the dealer figuring the alternator is bad. Electrical check shows alternator and battery good. Nothing showing "drawing" on battery. Can anyone offer a suggestion what the issue is?
  • yqdyqd Posts: 1
    :mad: I have an 05 one and just found out about the same problem. The speedometer doesn't pass 30 mph and the needle drops way below 0 when I drive slow or the car is stopped. I'm hoping it might be a bad sensor (yeah right ...........)
    Were you able to get any other diagnosis of your problem ?? :lemon:
  • My friend had a similar problem. Turned out the "ace" mechanic who installed his new battery did not tighten the battery cables correctly. It might be worth a look...
  • we are still having the same problems, have you found any solutions?
  • Somebody from Buick did call me at my home last week and they only told me to take my Buick back to the dealer from whom I bought it and to let them fix it, that the dealer will charge me half the $600 they told me it will cost to fix it. Iam checking with a lawyer to see if we can join forces to make Buick do the repairs at GM cost. I will keep you guys posted on this. It seems to me that this is a commont problem on this type of vehicle and GM is ignoring it.
  • The Speedo on my "new" 04 Rainier died during a 600+ mile road trip yesterday. Had to use my portable GPS to determine my speed and then just set the cruise. My dealer quoted me $230.00(dealer employee price because I just bought it on the 14th.) for the part plus labor. So I think 1/2 of $600 is still not a fair deal in your case. I would try and get them to charge you 1/2 of actual dealer cost and pay for the labor. I think you would come out ahead. The only good thing is that I believe the replacement will come with a lifetime warranty.

    P.S. My first symptom was 2 days prior with a oil pressure gage that was reading 160 psi. 180 degrees to the right of 0 psi. I believe that the "stepper motor" on each gage is what fails. It sounds like gm has a new stepper motor version on the replacement cluster.
  • Wondering if anyone else has had an issue with the 2005 Rainer headlights flickering & flashing at night? They first did it after the car was about 8 months old, dealer said it was because I didnt' let the car warm up enough and give it time to cycle through all it's check points? Sounds fishy to me....
    Well, it started again 18 months later, at first just a few times per night. Now it is crazy, they flicker so badly it has cars in front of me are wondering why I am flashing my lights like a crazy person.
    Does anyone have any idea or has had the same problem?
    Have had other problems too....alternator was replaced, A/C & Heating vents not blowing enough air, they've been worked on several times, still a problem. Crazy A/C & Heating unit is terrible to adjust to right temp., it's either blowing hot or cold....always at the wrong time. They can keep these automatic climate control units....just give me the old-fashioned type, they work great. And several other items....
    The vehicle had zero issues, not in the shop once (except for service), until it approached 30,000 miles, now it seems we are in the dealer's shop often....Does the Rainier fall about as it ages? Is the future going to be like this?
    Any input is appreciated. Thank you.
  • I have a 2004 rainier that went crazy last night. Yes I had a speedometer that went bad and the shop changed it out without charging me. But does anyone know why the Rainier has two check engine lights? One with a down arrow and one that's just an engine outline? Both went on last night and the car just sat there and idled. I could put it in drive but it wouldn't go faster than 1000 rpms. Once I got it home ( yes Onstar was called and they sent a wrecker), the engine started and I got a gas pedal again! Next morning, it started and no engine lights! Any thoughts?
  • As a followup, I went to Checker and got the code out of the computer. It's P1680.No one knows what it's suppose to tell me...
  • jchurchjchurch Posts: 1
    My Rainier had all of the gauges stop working, and the driver information center went blank after 50000 miles. I've taken it to the dealer and am looking at $1000 in repairs if I decide to go with it. Still runs fine, just no idea how much gas, oil pressure, or engine temp! Anybody have any ideas?

    Jed
  • jblaisjblais Posts: 2
    Couples months ago I had an electrical tourble with my gage, the Alternator batteries gage was reduicing down to 5 amp, the lights were flashing exterior + the dash board. After a scan at Dealer, It appear that my air pump causing this, so I did change the air pump in december 2007. 18 months after (03/2008) same trouble, I did change the pump a second time, 2 weeks after same trouble, Dealer says Buick Rainier has 2 air pump under the hood, nothing to do with the air compressor in the back for the suspension, and the second one is defective also, it's about 600$ each time - Is someone has a solution for me or did someone experimented this trouble ?
  • adf2adf2 Posts: 7
    I just bought a 2004 Rainier which has the much-read-about Speedo problem. Sometimes the speedo needle sits below zero at start-up, which always means it won't move at all when driving. Other times it is perfectly normal. Is it a sensor? Is it a cluster? Can it be corrected easily?

    Help!
  • medgarmedgar Posts: 1
    Our 04 Ranier started having electrical issues about 2 months ago. We had left it parked for 6 days at the airport. Started it up and none of the gauges were functioning. They may operate each time for a day, but then may go several days without working. About 3 weeks ago while driving about 15 mph, the accelerator failed to respond and the tach was locked in at 1000 rpm. After pulling over and restarting, all was well. In the past 10 days, the speedometer and tach have started failing also. Just last night, nothing was working and then it came on while driving. It did that several times.

    I've checked fused and wire bundle connections but have not been able to find any problem.
  • adf2adf2 Posts: 7
    Medgar,

    My problem was solved by having the garage replace a stepper motor. Now I get smooth speedo needle movement, rather than the eratic, twitchy movements I was getting.

    Your problem sounds more serious than a simple stepper motor change. I wonder if the whole cluster is in need of changing.
  • thedrakethedrake Posts: 13
    I also had the problem with flickering headlights on my '04 Rainier. The problem started about 6 months after I got it. I had the truck in the shop 3X for service of this problem, and even had copies of this thread documenting other owners flickering lights but the dealer denied their was a problem. When I bought a new battery after about 3 yrs, that seemed to help, but only temporary, the flickering returned. I returned the Rainier back to GM after my 48 month lease was up.

    PS. I also hated the automatic climate controls, especially on the windshield defrost setting. It was impossible to adjust the temp, either too hot or too cold.
  • lizsheplizshep Posts: 1
    Hello,
    Im having a problem with my 05' Rainier.
    The Gas Gauge seems to malfunction. When I fill up the tank to full it will read that it is empty and will continue to fluctuate up and down. This happened a month after I bought it from the dealer and now I am stationed overseas and cant ship my car to my station until this problem is fixed. Anyone else have this problem and know how much it cost them??
    Thanks.
  • I have had problems with my speedometer racing ahead and freezing at over 100 mph. I have to start the ignition and turn it off several times to get it to go back to 0. This week it is dead, will not move off below 0 mph. I have also had instances when the radio will not function. When the motor is turned off and started, it may began to work normally again. I am very sorry I bought this vehicle. GracemontGirl
  • bob192bob192 Posts: 19
    I had the speedo(instrument cluster) replaced on my 2004 Ranier. They charge
    $700 plus a $900 core charge for the old one. Fortunately, I had purchased an aftermarket warranty on this car, so I had to pay only a $100 deductible. Its ridiculous that GM does'nt give any better warranty coverage than 36 months, This was an expensive car. I believe perhaps mid thirties when new. I'm pretty much done with GM and Detroit too. My wifes Subaru had the same aftermarket warranty. We've had it for over five years now and have had zero claims. nothing but normal wear items. It was way cheaper and older when purchased too.
  • When my low-beams are on for about 20 min. they shut off, then y have to wait awhile and the will work again and not for long... High beams work fine
«1
Sign In or Register to comment.