Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Lexus LS: Problems & Solutions

2456768

Comments

  • dugcardugcar Posts: 6
    To Rxman2bie
    I started having climate control problems as well prior to replacing the LCD unit. The Low air would shut off once the desired temp was reached and when the AC was activated to lower the temp it would just blow ice cold AC air not a mixture of warm and cool. My LCD at that point was totally blacked out. However - I will add that just prior to the climate control freaking out, like the day before, I had it in the shop because my Alternator died and I drained the battery so bad that I had a total brown out of my electrical system so bad that the engine cease to run. I don't know if that fried the Climate control unit or not (everything else is OK) but that same week I replace the LCD face unit (see above)and now my climate control works perfectly.
    PS. Just a thought for you - if you ever plan to sell your LS 400 - no one will by it with a burnt out time-temp read out. So you might as well fix it and enjoy it while you own the car. Its real simple and I would be happy to walk you through it. Dugcar

    Also - regarding your brake light, I know this sounds really simple but when I first bought my LS400 the brake light would stay on until I figured out to hold onto the brake release handle a second longer and it disengaged the switch. Something to try .
  • Thanks Dugcar. Reading your previous post, I think I can replace the unit if I need to. But I don't want to spend 300 bucks yet. I can live without the display for now. I don't know if I ever want to sell my car. It has 180K and it still runs like new. It will last another 100K easily. I'll keep it until it die.
    For the brake light, I know it's a faulty switch. I just can't figure out how to replace it. For now, I just use black tape and cover the light and just remember to release the parking brake.
    If you know how to replace the switch, let me know
  • silcossilcos Posts: 7
    My '92 LS400 has 110k. Suspension is getting pretty rough on bad roads. Does anyone have any advice, personal experience, costs relating to suspensions. I am thinking of getting new struts and springs front and back. Are Pepboys,Meineke an option?
  • If your LS400 has leaked power steering fluid ( if you can see the oil spot in your garage or have to refill the fluid often) , have the booster replace ASAP before the power steering fluid damages your alternator.
    I have replaced two alternators in mine and finally was informed by the mechanic that it was caused by the power steering fluid get into the alternator.
    The cost for replacing the booster is under 200 at the independent garage. I don't know how much Lexus will charge.
    Speaking about the charge, if your car out of warrantee, have it serviced at an independent mechanic especially for tune up, water pump, timing belt or alike, you'll save half of the cost.
    Good luck
  • I own a 1990 LS400. As you might have guessed, the readout is gone. Several of you have mentioned low cost fixes for this problem. I am a DIY'r and would be happy to replace the LCD if possible. Several questions come to mind:
    1) Can the LCD be replaced?
    2) Are there LCD bulbs that go bad and can be replaced. Or does the whole display have to be replaced.
    3) What does all your experience tell us that are new to this game. Should we use a dealer, should we buy the part, etc?

    I love the car but this is driving me crazy!
    Thanks.
  • 1990 LS400 with considerable wind noise coming from the sunroof. Sounds like and air leak. Any chance anyone has had a similar problem and found a nice solution?
  • gcleary,
    Just scroll back and read post from dugcar and silco. It's quite easy to replace. Cost around 400 bucks. Good luck.
  • I’ve got a perplexing display problem that started recently. When the car’s gear selector is in drive and I’m driving forward, sometimes stepping on the brake pedal would light up the orange reverse indicator in the display cluster. I’ve had to turn the display up to the highest setting. Lower settings would cause the display to blank out whenever I step on the brakes. The reverse indicator would then go off after I take my foot of the brake. Another thing I’ve noticed is that if I’m driving down the highway at a high rate of speed, stepping on the brakes would light up the reverse indicator and the transmission would immediately downshift into a lower gear. This problem happens intermittently, sometimes the car would drive great with no problems and sometimes I have the gauge problem with the downshifting problem. I’ve checked the transmission fluid and everything looks ok (good color and right level) Anybody have any ideas on this problem?
  • dwitydwity Posts: 3
    On my 1995 LS400 the radio display has 5 lcd's that go out and come on with a mind of thier own. Most of what I've read here has to do with the clock and a/c panel. My only issue is with the radio display. Any helpful advice on fixing this problem. Thanks, Dwity...(taz@ct1.nai.net)
  • pat455pat455 Posts: 603
    Seems to me there is some helpful information in this very topic - you can use the navigational tools at the top of the page (just under the title) to scroll back through the posts here.

    Good luck.

    Pat
    Community Leader/Maintenance & Repair Conference
  • your problem is in the trunk wiring. the wire for tail lights etc. is routed through the trunk hinge and has frayed causing a ground short. this happens over time (open and closing truck). the short effects the computer chip which in turn sends false signals through-out the electrical system. easy fix at lexus dealer. if dealer does not no problem, call lexus in westminster, california.

    good luck,
    Bill Barton bb25e@aol.com
  • thanks bill, i believe that is the cause of the problem. when the problem would crop up, I would open and close the trunk (sometimes it took several tries) and the problem would disappear. sometimes, everything would be fine until i open up the trunk for one reason or another; the problem would immediately crop up. thank you for the info, i'll probably tackle it myself since you pointed me in the right direction.
  • lecialecia Posts: 1
    To Dugcar -- I'm buying a 1991 LS400 with a burnt-out time/temp display, though I definitely want the entire car to work the way it was meant to. I really appreciate the info you all have presented; I think I'll try to do it myself, though I'm a bit mechanically challenged. I found the part for $375+$10 S/H at a parts dealer in CA (remanufactured). Do I need the whole thing or just lights? How can I tell?
  • It might be as simple as slighly low brake
    fluid. My 90 LS light has come on when the
    fluid is down just a fraction of an inch.
    If this is your problem you might notice
    that the light sometimes is not on after
    parking on a grade, rather than a flat
    spot.

    The radiator indicator works the same way.
    If you're just slightly below the low level
    indicator line, then you'll sometimes see
    the dash indicator.
  • Lecia,

    Two weeks ago, I took the face of the temp control unit to fix the LCD problem. I was hoping that the problem was the burnt out light bulbs but it wasn't. All I had to do to was to remove each bulb and measure its resistance with the Ohm meter. If I remember correctly, there were 4 bulbs for the front LCD lighting. It would be unlikely that all 4 bulbs to go out at the same time, so chances are you would need to replace the whole thing(the face) if your LCD blacked out.

    PS. At what part dealer did you a remanufactured LCD for $375? I am interested in buying one.
  • I bought a 92 w/ 97K three months ago .Everything is great, except when I stop, shift back to parking, sometime I can not remove the key, It happened more often lately.Is it a problem ,some one already went thru this matter?I need your advise.Thanks
  • tcsctcsc Posts: 5
    I have the LCD problem also on my 92 LS 400 and would appreciate any info. on a fix. I have also recently experienced the outer half of my speedometer needle going dark. Now the speedometer needle bounces up and down or sits on zero, bounces up and down with the blinker on or as the AC comes on and off. It sounds like an electrical grounding problem of some kind but I am not sure. I also have recently had the "overdrive off light" blink on and off when the OD button was engaged! These problems are getting worse it seems. Can't use the speedometer controlled cruise control when needle is bouncing up and down. Please email any suggestions.
  • lecia - is it burnt out or blacked out buy leaking LCD? - if the lights are just burnt out review some of the topics on bulb replacement, that should be very inexpensive but the removal of the unit is the same. If its blacked out from LCD leaking then the $375 unit is the correct replacement part. (its actually the front half of the module. You have to disassemble and replace.)
    dugcar
  • I just boguht a 93 Lexus Ls400 with 72,000miles rather low and i already seem to have a problem on my odometer it says trac/off how the hell can i get it to say on i pressed the tracoff button but it wont seem to work maybe it something else but i don;t know and don;t have a manule to help me so if anyone knows please help
    thanks
    Jim
  • That price for the panel is incorrect. That was 350.00 plus tax. The units are rebuilt and takes roughly 10-14 days.
  • For a price of 300.00 plus tax exchanged you all can have your lcd panels back with a 1 year warranty. Lexus of Riverside has taken care of many panels.
  • Hi!

    I need to get a leaking steering pump replaced on my '92 LS-400.
    Can anybody recommend a reliable, non-dealership service facility?
    So far the best price I have is $499 for pump and $132 for 2.2 hours labor.

    Also, looking in this forum, I also have the burnt bulbs on the temp control panel (the LCD is OK, I can see the numerals just fine in daylight). Can anybody point me to the message that details how to remove the temp panel (without damage :-)?

    Thanks in advance!
  • dwitydwity Posts: 3
    I have a 95 ls400 and the drivers side heated seat doesn't seem to get "hot" like the passenger side. I truly cannot even tell if it is working. Is there an adjustment to control how much heat is produced or is simply not working properly? Is there specfiic fuses for the seats? Does a Chiltons or other type manual exist for this car? If so where can I obtain one? Thanks everyone. Any ideas would be greatly appreciated.
  • I, have a 1992 LS400 and If I suddenly hit the brakes on this car the radio turns off. I have look for wires or what ever near the brake pedal and can't see anything. Any Suggestions.
  • Read post #40 and #43. Your problem may or may not be a related issue with the wiring in the trunk. Since it's easy to see if this is the cause of problem, I would give this area a shot first. I found a severed wire (black and white wire) in my trunk that was causing all sorts of havoc whenever I stepped on my brake pedal. BTW, does anybody have problems with the factory windshield being chipped easily? I've owned several cars in the past (maxima, bmw, acura) in which windshield chips were few and far in between. In fact, on some of my cars in which I drove for many years, I never received any windshield chips. On my LS400, I probably have at least 10 chips on the windshield and a friend of mine who has a 93 LS400 had counted at least 8 on his. We had discussed this in the past and he estimates that he probably received 1-2 chips in all of his previous cars combined whereas on his AS, he's got four times that number. Does any other LS400 owners noticed this problem? Just wondering.....
  • mike_542mike_542 Posts: 128
    my friends 1997 ES300, 1998 GS400, and my 1991 LS400
  • I've noticed my outer half of the speedometer needle in my 91 LS 400 flickered for awhile and is now just dead.

    Might anyonw know of a fix short of a new factory part, or of a source for rebuilt speedometers / needles?

    Thanks.

    Sandyfordiii
  • I own a 2000 ls400 with approx. 20000 miles-all services performed by a dealer. When the car has sat for a day or more-I feel a slip in the tranny when shifting from 2nd to 3rd gear. This happens under light or moderate acceleration and only the first few minutes-after the engine warms up the shift pattern is normal--any thoughts would be appreciated.
  • tcsctcsc Posts: 5
    I have a 92 LS 400. When I am driving between 40 and 60 mph and gently add gas the tranny shudders as it down shifts. Feels like I am running over a cattle guard or something. The downshift works fine if I hit the gas harder. Any thoughts on what may be causing this disturbing shudder anyone? Thanks, TC
  • Good morning tcsc On your transmission problem this can be fixed by having your fluid flushed and replaced at your Lexus dealer, or you can do it yourself, their is a new trans fluid spec out there called -IV, have it changed and your problem should be gone.
Sign In or Register to comment.