Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





GMC Envoy Losing Coolant

melmccunemelmccune Posts: 1
edited August 29 in GMC
Envoy Losing Coolant very slowly
I have a 2003 Xl. It has been losing about 1/2 gallon of coolant every month. I have looked every where for leaks with no luck. Any suggestions???

Comments

  • burdawgburdawg Posts: 1,524
    If your saying that you never see any sign of leaks underneath, then the only other possibility is an internal engine leak. 1/2 gallon is a good bit to lose, if it's an external leak you see signs of it especially when it sits with a hot engine. The best thing to do is have the cooling system tested under pressure to confirm.
  • paco42754paco42754 Posts: 2
    I have a F150 Sport 4.2L V6. I have a ticking noise that I can't find. It's driving me nuts. Sounds like it could be in the exhaust but not sure. Is this common in the 4.2? And how can it be fixed?
  • steverstever Viva Las CrucesPosts: 40,805
    Try posting in one of the F-Series discussions, like Ford F-Series Noises - Squeals - Rattles.

    Moderator
    Need help navigating? stever@edmunds.com - or send a private message by clicking on my name.

  • reg11reg11 Posts: 2
    Any success with finding the coolant leak? I am having the same issue with my 2002 Envoy 4.2 L engine. HAd it in the shop twice, cannot seem to locate where coolant is going. Loosing 2 litres or more between oil change?? I know there were cylinder sleeve crack issues with these engines when they first came out- hope it's not that! Anyone else having similar problem or had it fixed.
    Thanks,
    Reg
  • reg11reg11 Posts: 2
    I am having the same issue with my 2002 Envoy 4.2 L engine. Had it in the shop twice, cannot seem to locate where coolant is going. Loosing 2 litres or more between oil change?? I know there were cylinder sleeve crack issues with these engines when they first came out- hope it's not that! Anyone else having similar problem or had it fixed.
  • agageagage Posts: 2
    My baby sister is having the same problem with her 2007 Envoy 4.2.L engine. The radiater has been pressure tested and ok. Compresson tested ok. No sign of fluid on driveway and no discoloring of the tail pipe. Has anyone out there found a answer to this problem? If so what is the answer.
  • agageagage Posts: 2
    Have a 2007 Envoy that loses antifreeze at a abnormal rate. The radiater has been pressure tested and ok. Compression tested and ok. No sign of fluid in driveway and no discoloring of the tail pipe. No increase in oil level, which would indicate it leaked into the block . Has anyone out there found a answer to this problem? If so what is the answer?
  • mrashleymrashley Posts: 2
    I have a 2003 envoy that has been running almost flawlessly until this weekend. Suddenly it has started to drop coolant after driving around town. It does not pull temp, gauge stays below 210. I have checked fluid levels and coolant was low, filled and after driving a few blocks when I parked coolant is running out from behind front passenger wheel. I cannot see where its leaking from but it flows down the inner wheel well. I was assuming its coming from the overflow tank, but it was dry inside. Any suggestions? I'm off work the next two days and going to work on it.
  • Did you ever figure out what was wrong? I just had the same problem yesterday. If anyone else reads this and has this case solution please post in the reply. Thank you.
  • 03envoy103envoy1 Posts: 1
    2003 Envoy losing coolant. Have replaced cooling fan, thermostat, water pump, radiator and added a stop leak. No drippage, no water in the oil, no vapor in exhaust. Overheats everytime under a load and sometimes under normal operation. Our friend, a mechanic, is stumped and we are frustrated. HELP please! :(
Sign In or Register to comment.