Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





GMC Envoy Heating Ventilation and Air Conditioning

2456

Comments

  • siksasiksa Posts: 3
    All of the HVAC controls and temperatures function on the console of my 03 envoy, but the blower ignores the speed control. It usually is off, but sometimes comes on at arbitrary speed when the car is initially started. Where is the control module, Does it need reset? Please help.

    Thanks.
  • siksasiksa Posts: 3
    Hi,
    I also have the same problem. Did you get it fixed and if so what was the fix? Thanks very much. Bob
  • Hi yes i have a 2004 GMC Envoy and that also happened to mine my air works fine up until you turn the dial to 5 its actually your Resister (which controls the fan speeds) a Blower Resister and you usually can only get it at the dealer. Its kind of a pain so if you dont know anyone its best to have them put it in as well ,plus if anythings wrong your local GMC Dealer will have to cover it. Good Luck
  • alfa116alfa116 Posts: 1
    :cry: :sick: I'm having the same problem with the A/C. The ambient air temperature is stuck on 50 degrees. I tried the resting of the control module with no luck. I've spend the better part of the day looking of the Ambient air sensor behind the radiator. the sensor is not there, is there another location.
  • hsauberthsaubert Posts: 2
    What year is your Envoy?
  • cwickscwicks Posts: 1
    My 2003 envoy just started having the indentical problem. Did you ever find out what was causing this? Not a good thing since my truck is black, in Florida, in August. Please help!
  • siksasiksa Posts: 3
    Yes, it was the blower control module that mounts alongside the blower. You have to remove the sound panel (two screws) under the glove box and remove the glove box at the hinge (three screws). Then you can see the module. It has a pigtail wire that plugs into the blower. Release the plug latch with a screw driver and disconnect it. The module has two screws holding it into the duct by the blower. The module costs about $72 mail order or $115.65 at the GMC dealer. The dealer wanted $200 to fix it.

    Note: this fix is for the digital type control with the up/down bar graph on the console, not the rotating switch type blower speed control, which has a resistor module instesd of the electronic module.

    Good luck.

    Bob
  • I just purchased a used 04 Envoy with 24k miles. The radio had 2 lights out on it. As it was under warranty, they are replacing the whole radio, not fixing it. We also has a Chevy Venture 2003 van, it has the same problems, but is well out of warranty.
  • I checked the fuse sensor and resistor, they where ok.
    does anyone has had the same problem?
    Can anyone help me in solving the problem?
    thank you
    angelo
  • This is for anyone that may have the same problem.
    I checked the power at the end of the blower sensor and the power was ther..
    I also decided to bypass the blower sensor and connect the power directly to the blower, the blower started working so i went to buy a new blower sensor and about $160 later with the new sensor i restored the heat in the Envoy.
    Angelo
  • a/c is working on car , air comes out from leg vents,rear vents front dash side cold
    but is not coming out front vents ,checked fuse boxes any suggestions
  • hardhawkhardhawk Posts: 702
    The rear HVAC and radio controls on my 2002 Envoy SLT have quit working. It is as if there is no power to the controls as neither the rear HVAC or radio controls will come on when you push the respective power buttons on the back of the front console. When you turn on the lights the markings on the control panel light up so you can see the buttons, etc., but you can still not turn on either the HVAC or radio. I checked the rear HVAC fuse and it was fine. Local non-dealer mechanic looked at it and found all wiring and connectors to be good. He thinks it is caused by some control module, but does not have the GM repair book to look at and check it. Anyone have similar issues or ideas for me to cehck before I take it back to the dealer? Thanks.
  • shaapennshaapenn Posts: 1
    I have read some of the other people's tales about the problems with the 2003 Envoy SLT XL air conditioning blower motor control module. I have been without air for about a month and finally had a friend take a look and found out that mine was bad. My problem now is that looking online I keep finding the 7 pronged one instead of the 3 prong. I read someone's input about going to a Super Parts AC Delco but I don't have one of those out here in Hawaii and am desperately trying to find the right part online instead of having to pay the dealer 2 or 3 times the amount. Can anyone point me in the right direction about an online site for good parts?
  • paygepayge Posts: 1
    I have a 2003 GMC ENVOY. Last month the air would just stop working for 5 sec. and then turn back on. It would quit for 15 sec and then turn back on. Then it would work fine. Now I am lucky if the blower works at all. I would like to know if anyone else has had this problem. Sometimes the air works and sometimes it will not. It will work on 1,2,3,4 and will quit on 5. I can sometimes get the vent air to come on and then hit the air button and sometimes the air will kick on.
    I don't believe it is the compressor but maybe a switch. I called my local GMC dealership and they said they have never heard of this problem. I do not believe that. Not from reading this. Any help will be great. Thanks.
  • oncelostoncelost Posts: 1
    I have a 2002 Envoy and am having a problem. When I turn heat/air with the drivers or passenger control, extremly hot air is blowing out the passenger side. No matter what temp I set the passenger to it blows as hot air as possible, while the driver blows whatever I set it at. Does anyone have a clue? I would appreciate any help.
  • Is the module under the foam padding underneath the blower motor (towards the floor side)...I've only dropped the glove door down to look behind it...I can see the blower motor unit....also what color are the wires that plug into the blower from the module??..looks like a purple and brown wire..
  • I have an 02 Envoy XL. Automatic HVAC controls. The rear air blower quit working. I removed the rear panel to access the blower assy. Upon doing some tests, I found that the motor would blow fine if I manually grounded the ground wire that goes to the motor. Is there a bad control module somewhere that controls the motor with it's ground or is the front control switch bad? I'm not familiar with this vehicles wiring configuration and am at a loss as to where to check next. Any history on this problem? Thanks in advance.
  • I'm having tow problems:
    1) When a/c is on sometimes the blower blows, sometimes not. Turning the speed up or down does not adjust the air flow. It might blow a little bit but then when driving down the road it turns on full blast. Then on it's own when it wants to starts blowing nothing again.

    2) When I turn the car off the A/C Heater Blower does not turn off. Once in awhile if I keep messing with it or turn the car on and off it might stop. It has drained my battery twice now and I have to unhook the battery to get it to stop.
    When I hook the battery back up, start the car, I do not turn it on and it will turn on automatically even though you do not hear it and then I am back in the same boat again.......

    Somebody please help!!!
    Thanks Jess
  • I answered your other identical post with a solution to your problems shortly after you posted it. That was 2 days ago. Have you fixed your problem?

    C.B.
  • I brought it to me dealer....they fixed it....some of the wiring needed repairing...reason???...cost was $89.00...so I did care...works great now..now my posi traction is jerking only when I turn to the left...had them drain fluid...ran it...about 100 miles...still does it...not sure what to do next...mileage 128,000..
Sign In or Register to comment.