Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





1985 Mercedes 300SD Turbo Diesel cranks but won't start

I have a 1985 Mercedes 300SD Turbo Diesel with about 140,000 miles on it. Recently it's become increasingly difficult to start, until eventually it wouldn't start at all. It still turns over fine - I can hear the starter turning the engine (at least until I wear the battery down by trying to start it). For a while I could get it to start if I was persistent enough, but now it simply will not start.

I think the problem is my own fault. Here's the history.

This car had been modified slightly. The stock air filter had been replaced with a cone filter. I neglected to check the air filter for some time, and discovered that the top plastic part had cracked open. Since the filter was obviously useless, I tried to replace it, only to find no local store carried the right size cone filter. I found them on eBay, but while I was waiting for the auction to end and the filter to be shipped to me, I drove the car without a filter. I'm certain this led to the problem.

The filter connects to a very short rubber tube that connects to the air intake on the turbo. When I was having trouble starting the car, I tried spraying some starter fluid into that tube. The result was that the car actually had more trouble starting directly after I sprayed starter fluid. And it seemed the more I used, the worse it started.

Any suggestions?

-Dyllan

Comments

  • I own a diesel,but not a MB, however they are all the same. With diesels it always come down to three things, well maybe 99% of the time. Either a broken ground somewhere, bad fuel, not enough air. I would take a look at the generator and see if it is functioning properly.
  • manny16manny16 Posts: 1
    hi your problem can range from simple to comlicated solutions. the simplest have the heater plugs and heater relays checked. it should be working properly. check the inteke impeller of the turbo it maybe damaged since you used the car without aircleaner. have the mechanical injection pump checked out since it is an old car. lastly if your engine is consuming oil a very expensive engine rebuilding is needed. i used to own a 240d and i rebuilt the engine. now i own a 300sd turbo 85. liked the sd better coz its a lot faster and exeptional built quality. no major problems so far.
  • laci73laci73 Posts: 2
    Hi.....diesels....if your starter turns, but no fire, you may have an air into fuel line, after a years rubber pieces may cause a leeks, so you do not loose your fuel, but you can smell it. ones there is an air into a fuel house, engine does not start.

    Glow plugs.....always check your glow plugs before winter. Pull them out, conect them back as they were inside the engine, make sure they have good ground. Than turn ignition and look at the plugs.be very carefull...they get red hot!!!! they have to start turn red at the end, and then warming up whole body. If they turn hot at midle or somewhere else..they are faulty...replace the faulty ones.

    fuel filter drain or replace before winter.

    check your battery and starter....those 2 things very important for winter.

    ones your engine turns, and white smoke comes off your mufler, you have a lot of vater into a fuel....drain the filter, fill tank with fresh fuel

    blue smoke means worn engine....have to be rebuilt= expensive
    black smoke....your injectors or injector pump need set up
    ones your battery is dead, you still can start a diesel drivin down a hill, put it into a 3or 4 gear ang slightly release the clutch...it will start. Engines with rubber timing belts might damage, if the belt is worn.
  • joe3716joe3716 Posts: 15
    My 1983 300 Turbodiesel came to a stall this morning after a few jerking moves. The starter cranking was ok but the engine won't start. Checking fuel lines found the fuel plunger pump was totally loose - most likely from the engine vibration. Tightening the plunger pump didn't help till i plunge the pump a few times to get fuel into the engine. Retightened the plunger, flicked the starter and the engine comes back to life and runs ever so smoothly.
    Diesel engines have very strong vibrations and the fuel plunger pump (a plastic piece close to the fuel filter) are bound to come loose over time. Good to check it for tightness from time to time.
    Hope this helps. Good luck.
  • I pulled the line off of the lift (primer pump) and got fuel pulsing out when I turn the starter but don't know if the pressure is enough. Does anyone know what that pressure should be and if I have fuel coming out does it mean the injector pump is not working? What would my next test step be? Do I pull an injector line off and check for fuel? The glow plugs are working.

    Any suggestions would be appreciated. It seams to fire off a little but not enough to start.

    Thanks,
    Tech6
  • you have air in the system. Loosen the main fuel filter a little bit (the big round one). Manually prime the pump until fuel comes out from the top of the fuel filter near the bolt. To prime the pump just unscrew the plastic plunger and prime it a few times- you should see fuel coming out from the main filter. Then tighten the main filter again, prime a few more times, tighten the plastic plunger tight again, and it should start
  • I have a 1984 Mercedes 300SD Turbo Diesel with about 195,000 miles on it.
    when i start the car in the morning doesn't give me problems. but when i stop the car
    after driving it .. it gets really hard to start again. do you guys know what could be the problem..
  • I have a 2003 Silverado 2500 duramax with the same problem. Let me know if you get any ideas on what this could be.
  • benzsilverbenzsilver Posts: 21
    Vacuum? Compression? Filtrs dirty of leaking? Flooding on trying to start? Glow plugs weak or shorting out? Relays shorting out? Vibrations has caused loose wires? Engine heat causes old vacuum hoses to swell and leak? Once on my first benz I had a gas station service attendent check my oil and water. The sorry you know what bent and broke a wire inside the insulation near the starter junction block on the firewall. THIS AS YOU KNOW CREATED AN OPEN CIRCUIT IN THE STARTER/IGNITION CIRCUIT. I was able to drive away from the station because for the moment the circuit was not open, however the next day I was on a busy rush hour freeway, and the benz stalled in the middle lane. No one would stop and help as the cars and trucks were whizzing by on either side at 60 or 70 miles per hour. I thought that I was at my waterloo. Finally, a police officer pushed me to the side of the road. The wrecker towed me to my home; that did not come cheap. I new just about all the idiosincracies of the benz, so I was determined to solve this problem. I was very familiar with the vehicle. It took me a week to diagnose and correct the dastardly deed that that sorry so and so had done. It was a very simple fix but had I called a shop to diagnose the problem, they could have perhaps been both honest and smart, and determined the problem quickly with little expense to me or i could have cost a small fortune. So word to the wise: DO NOT LET ANYONE UNDER YOUR HOOD OR BENZ UNLESS YOU CAN HAVE COMPLETE CONFIDENCE AND TRUST IN THAT PERSON. Good Luck, benzsilver
  • swells2swells2 Posts: 1
    edited July 2010
    my 300sd turbo will not turn off . can someone please help me its costingh me a bundle letting it run 24/7
  • if any of the other messages you recieved never had worked out , my opinion is when starting the car hold the key, when holding the key while the starter is cranking press the throttle fully till engine rotates then starts and rev a couple times to makes sure it will run .
  • my 1985 300sd turbo diesel cranks but wont start. I have a new battery, replaced the primary and secondary fuel filters and replaced the primary air cleaner. In addition, after installing to two new fuel filters, I bled the fuel line of any air. The glow plug fuse is intact.

    Any suggestions would be appreciated.
  • So I have had my car in and out of the shop and no one can seem to figure out my problem. I am pretty familiar with the car and its just not making sense as to why it cant be figured out.

    So the problem is peculiar because it happens sometimes, but then after not using it for some time it will work fine. The problem has been that the car's brakes will get stiff and then I have to manually shut off the car by sucking on the tube leading to the fuel shutoff valve. I have to suck on that because the emergency stop button located above the engine will not shut it off. These problems all lead me to believe there would be a leak in the vacuum system, which still seems to be the problem, but it is still happening after the system has been checked, the idle is correct, the brake booster and fuel shut off valve have been recently replaced and the pump is producing correctly, . As I said before, the car will work fine for some time and then after about a week of normal to and from work/school, the car will start, then on the way home the brakes harden and the car will not shut off with the key. My father and I have been at a loss as to where to look or how to even go about looking. He has rebuilt the engine for the same car a year younger than mine, thus giving me the interest in these cars and knowing that they should be an easier fix knowing someone with a great knowledge of the car, but every time it "seems" ok, it only a matter of time that the same problem occurs over and over again. This has been for months and with me and my wife working, its hard to only have one car due to schedule differences.

    Has anyone had similar problems and know where to start looking. The major problem is diagnosis, the repair can be done, just dont know where to turn to.
    thanks
  • I have an 84 MB 300sd turbo,my first diesel,it was given to me & my wife by her dad when we got married last yr.it sat for a long while,till we got in it & atemped a drive from Va to Pa,a 10hr drive.it ran horrible till i stoped an hr later & put some diesel cleaner stuff in it.then i held it tothe floor & off we went down the hiway.It chuged & took all it had topush it to 70 & that was in second.after a few of those pedalsto the medal,it seemed to blow all the jun ot of it & it ran preety good till bout 4 monts ago.then i put some old diesel cleanr suff in it that smeld horrible,after that ran thru the tank it stared running real bad.i changed both fuel flters undr hood,does any1 know if there is anymor fuel filters anywhr else & or have any ideas on what maybe going on wth the car.i also replaced the air filter,batt.& alteraor so far & its got arround 450,000 miles on it.
Sign In or Register to comment.