Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Chevrolet Suburban Engine and Performance Issues

rvjayrvjay Posts: 1
edited March 14 in Chevrolet
i just gave my 94 suburban a tune up new plugs gaped at .35 plug wires distributar cap rotor.now when im driving at about 65to70 miles an hour it tends to hesitate never did this before any ideas would be greatly appreiated

Comments

  • kiawahkiawah Posts: 3,666
    A couple things to check:
    - Autoparts stores sell at the register a little package of electrical conducive paste, that you put on both the plug ends and the rotor cap, which ensures that the cap to wire connection is really good, as well as the wire to plug connection. I usually buy two packs.
    - Make sure you feel the plug wire make a definite click connection when put on the plug. You may have a connector that is either spread to wide, or too narrow and not able to firmly attach.
    - When you routed the wires, were you careful to route them the same as the old plug wires? You may be having cross sparking. One way to check is at night with all the lights out, see if you are getting any visible sparking across the wires. Hopefully you bought a good wire set, some cheap ones can cause problems.
    - You could have a bad plug. If your hesitation is a pretty solid problem, you may pull the plugs and look closely to see if you can see any difference in their appearance.

    Your symptom could also have nothing to do with your wires. At 65-70 and throttle, your engine needs quite a bit of gas and you could have fuel delivery problems (pump, filter, questionable gas?).
This discussion has been closed.