Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





2009 Toyota Corolla Problems and Repairs

1272829303133»

Comments

  • Mr_ShiftrightMr_Shiftright CaliforniaPosts: 44,872
    It's my opinion that water pumps are more or less expendable items, so any failure at about 80,000 miles or higher would be "normal" in my view. Prior to 80K, I'd be disappointed, and prior to 60K I'd probably not care because I'd be under warranty in most cars.

    MODERATOR

  • terceltomterceltom Posts: 1,017
    The pumps were bad in the 2009's. I had mine replaced under warranty in 2011 with 15,000 miles on then car. In fact, I didn't even ask, my Corolla was in for routine service when they replaced it, no questions asked. I don't believe it was a recall but there was a TSB issued for the 2009 water pumps. As I understand it, if an owner has a water pump problem the Toyota dealer has the preapproval (because of the TSB) from Toyota to go ahead and replace/repair the issue, in this case the water pumps on the 2009's. A recall would only pertain if there was a safety issue with the problematic componant or part on the particular model and year.
  • Mr_ShiftrightMr_Shiftright CaliforniaPosts: 44,872
    There is a TSB for certain specific VIN #s, and it only applies to the 60,000 mile warranty.

    See: T-SB-0362-09

    Rev1

    October 14, 2009

    MODERATOR

  • i have a 2009 corolla i am having a ton of issues with it and im not happy they anti theft key/ computer system thing is acting up and i have to trick my car into thinking that im not actually trying to steal it. I also have a issue with my stereo, it has a short in it somewhere and it makes the speaker pop, i took it to the dealership and they cant diagnose it because they cant get it to act up for them does anyone else have these issues? i also have a problem with the idle it is sticking my car only has 48,000 miles on it and i cant seem to get the problems to stop popping up, im not happy with the dealership or the car itself. does anyone have this many problems with their car or do i need to take this lemon back?
  • I bought a used 2008 Toyota Carolla and afer 18 months of ownuing it with an extended warranty my AC is out and is not covered. I paid almost $200 for an AC service and diagnostics and the only thing they found is the air conditioning works it is just not connecting somehwhere in the computer system. The compressor works, the fan, the switch ect. there is just no cold air coming out, just warmer air. Does anyone know what could be wrong?? I paid 13,000 for car and warranty and now I have NO air conditioning and summer is coming up fast and we have foster children! HELP!!
    KAT
  • terceltomterceltom Posts: 1,017
    Found my trouble ! The temperature sensor for the digital thermometer was bad. Picked a new one up at a dealer for $13.00 wholesale. If anyone else should experience this erratic thermometer behavior or even a malfunction, this $13.00 sensor is attached to the front bottom of the radiator directly behind the front grill.
  • moonpie3moonpie3 Posts: 3
    edited February 2013
    I wish I had read this earlier today. I just purchased a 2009 Corolla and did the usual 7 minute test drive. I got a good price on it and was happy with the deal. Twenty minutes into my drive home, my right foot started tingling, then my calf and shin, and after an hour, my foot was numb. I got out and took a break to allow the circulation to return. Next on a 15 minute trip, I started with the tingling and numbness again after 5 minutes. I have adjusted the seat length and height as far back as it will go. This car in my opinion is not meant for someone over 5'4". I am 5'7", and I too am all cramped up. I called the dealer just a few hours after driving off the lot and they refuse to take the car back. I hate I have to sell my new car and lose probably $1,000.00 or more over this. I am horribly disappointed in Toyota. Their quality has obviously gone down over the years.
  • mcdawggmcdawgg Posts: 1,668
    I am 5'10", no problems.
  • terceltomterceltom Posts: 1,017
    edited February 2013
    Wow, that's crazy ! I doubt if you could blame that on the car though. I'm 6' and have a 2009 Corolla and my seat comfort is wonderful. You know those seats can be adjusted several different ways. Please don't take this the wrong way, but you might want to get seen by a medical professional just to be safe (stroke).
  • "I have adjusted the seat length and height as far back as it will go"

    Maybe you need to go the other way,
  • I am just an odd bird! Hey, I am a medical professional! No circulatory problems and I run many days a week for exercise! I have narrowed it down to the angle of the accelerator. The service department told me it cannot be moved.

    Any other suggestions? :confuse:
  • I've tried everything, I even made a wedge to try and change the angle of the pedal but it didn't do any good. I actually gave the corolla to my son and bought a Hyundai elantra but what a mistake. This car has such a stiff pedal that i cant wait to get rid of it. It's actually 4 yrs now since the start of my leg problems and still don't know what to do.
  • sandman_6472sandman_6472 Coral Springs, FLPosts: 2,666
    5'7" here and have no problems with the 2013 Corolla...have driven a few at work and all the same. Shame you didn't rent this car before you bought. In the future, rent what you want to purchase for a week and see if it's doable on a day to day basis...you'll know soon enough and spending a few bucks upfront can make a big difference down the road. must suck to buy a new vehicle and find out that it just doesn't work for ya. Now what do ya do? Sell it and loose $, give it to a family member or just bite the bullet. Have you tried every solution you can think of like sitting on a cushion like I do or seeing if the track could be lengthened? There's gotta be some practical solution here for you to do as they are great cars. Or can you trade up to a Camry? Years ago my mother-in-law had us test drive her new car as she trusted us. thought that was crazy but we did and she bought it. had a similar problem like you so Oldsmobile let her pay the extra $ to upgrade to the next size model and all was good with the world. Just a suggestion here dude as the Camry might just be the ticket. Drove a new one last night and it was pretty nice except it was an SE and just too firm. Try a LE and that could solve your problem!

    The Sandman :) :sick: :shades:

    2014 Hyundai Tuscon SE/2005 Mazda 3s/2008 Hyundai Accent GLS/2009 Nissan Versa SL hatch

  • diana_ddiana_d Posts: 1
    I am having similar issues with my 2012 corolla. The computer system is not working correctly, the doors won't open/close, the seatbelt alarm won't go off when it's supposed to. I've taken the car back to the dealer about 4 times now and they can't find what is wrong with it. I looking to file a complaint against the dealer and/or toyota for failing to make these repairs.
    The car only has 14,000 miles so it is definitely covered under warranty.
  • Kirstie_HKirstie_H Posts: 10,876
    Please take a few minutes to answer our survey:
    https://www.surveymonkey.com/s/EdmundsForums

    It's really important for us to hear from our members and visitors to get direction going forward. Only good things are planned for the future, but we need to gather insights to get there! Whether it's your first time or you're a regular, we'd love to hear from you.

    MODERATOR
    Need help navigating? kirstie_h@edmunds.com - or send a private message by clicking on my name.
    Share your vehicle reviews

  • mcmcorollamcmcorolla Posts: 1
    Hi there,

    I just brought a 2010 Corolla LXE and it has abt 32,000 miles and it's making that whistling sound that you are describing. The Toyota dealerships swear it's a normal sound and they must think i'm stupid to accept that answer.

    I was reading one of your post stating that you have a pdf document to solve this problem. I was wondering if you still have it and if I can get it. My email address is masenmcm@yahoo.com. I'm sorry i couldn't find your email address to write you privately.

    Thank you Kindly:)
  • moonpie3moonpie3 Posts: 3
    I was the one that posted about the accelerator gunning and the seat not going back far enough to accommodate my leg length. We ended up returning the car to the dealership. I lost $1,000.00 on it, but I could not drive it the way it was. Good luck!
  • john673john673 Posts: 1
    I know your message was from a year ago, but I have the same problem and wondered if you have been able to fix yours. On cold starting I hear this rattling/grinding noise from the engine. It lasts for just 1-2 seconds as I am pressing the ignition. The noise is getting worse and I am concerned. Have had the car to the dealer a few times about it but they've only recently heard the noise because I left it overnight to cold start it for them in the morning. They said they think it is something with the timing.
  • BakkaBakka Posts: 12
    Interesting. I have the same issue and have been wondering what causes it. At times it's worse than others. Never heard anything like it in any of my previous vehicles.
  • sban226sban226 Posts: 2
    No problem, to be honest it just stopped happening. It might have to do with it being summer and it seems to only do it in very cold weather. I don't believe the problem is the timing I think it's the starter but it may also be the battery. Let me explain for some reason the battery developes blooming corrosion on the positive terminal. I kind of left it alone until I started having problems with the traction control. All I did was totally cleaned up the terminal and now there is no problem with anything, so you might want to take a look at that. Good luck.
  • terceltomterceltom Posts: 1,017
    I would have to adamantly disagree with you John. I don't believe there is anyway battery corrosion could affect traction control or engine or crankcase noise. I always felt that the common noise as described was due to the fact that the oil in the crankcase was not reaching the valves and rods as quickly as it should.
  • mcdawggmcdawgg Posts: 1,668
    This could be the VVTI actuator. There is a TSB for this. Just google and you will find.
  • Hi, my name is Sammy, my wife and I bought a 2013 Toyota corolla in August and it has a noise in the bottom half. It sounds like the oil is taking to long to reach the rods. We took it back with only 500 miles on it and the dealer says that it's normal for it to take 2/3 seconds for the oil to reach the rods. I find that very hard to believe. They said that they took 3 other corollas of the lot and they sound the same, again I find it hard to believe. I've been automotive tech. for 37 years and I can imagine the damage that can be done in those 2 to 3 seconds. Can u please help us and tell me which way should I go about this . Thank u
  • your mechanic must be a total fanny-pad, using grease? what a [non-permissible content removed]. You need to remove all 4 sensors while the car is on the hoist with all 4 wheels free. For each wheel, use sh!tloads of BrakeClean spray in the same hole you have removed the sensor from till you see the toothed ABS excitor ring gleam. (over time, brakedust settles in the ring due to proximity and toyota's failure to adequately sheild it from the breaks... enough carbon to make the sensor read 1,1,1,1,1,1/basically a skid; instead of 1,0,1,0,1,0/basically a turning wheel, the raised teeth sense as 1, the inverted teeth read as 0)
    Clean off the ABS sensor itself with a scotbrite pad or anything mildly abrasive like that. You may need to reset the computer but all will be fine now...... Grease, honestly.
  • Hi KATIE

    My mother recently came to me with a similar issue. The first place I would check is your evaporator drain tube. These cares are notorious for the drains getting plugged. Sometimes it will even spew water into the passenger side floor. Do you have a musty odor in your car? I fixed my mothers by sticking a piece of string trimmer line into the drain tube.
  • Hi mike,
    My mother came to me with this same issue. Is the smell kind of a musty wet smell? After doing some investigating I figured out water was coming from the passenger side floor vent and giving off the stinky smell. These cars are notorious for the evaporator tube drains getting clogged with spiders and road debris. I fixed my mothers by sticking a piece of string trimmer line into the drain hole. You would not believe how much water came pouring out!
Sign In or Register to comment.