Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





GMC Yukon Start Stall Idle Problems

qnessqness Posts: 2
I love my 2001 Yukon xl Denali with over 130,000 miles but having some starting problems. The initial problem was taking several tries to start, when after it seemed a clog was cleared and the engine banged loudly once it would clear and start and be ok for the rest of the day, but a little more difficult in colder weather. I brought it to a small gas station where they kept the vehicle over night, recognized the problem but couldn't diagnose. I went to the dealer and they couldn't even find the problem after keeping it over night.

The problem is now getting worse. I have to keep pumping the gas rigorously several times and restart several times to finally get it to turn over and actually start--it is not weather dependent and a little harder to start even after the vehicle has been in use during the day. It has never not started, but I really don't want to get stuck somewhere.

I don't know what to do or where to take it---any advice.
«1345

Comments

  • Here is a wierd one for you all. Once this truck gets below a 1\4 tank it will not start sometimes. The other day it did this with 3\8's of a tank. Basically you can run it all the way down to empty and as long as you put fuel in it, all is good. If you shut it off under a 1\4 tank, leave it over night it won't start. If you put a gallon of fuel in it, it will crank. This happend the other day and there were still 10 gallons of fuel in it when I filled it up, so I know it is not a guage issue. Maybe the pressure regulator?
  • listen to see if the pump is turning on. if you have a fuel pressure gauge, hook that up. should be around 50lbs +/-3
  • After my 93 yukon has warmed up and I shut it down. When I go to restart it, it will not start. It will turn over and act like it want's to start. I pull the number 1 plug and see if I am getting spark I get a real weak spark and then nothing. If I let the vehicle sit for a little it will fire right up. I have replaced (coil, icm, rotor, cap.) The wires and spark plugs are good. I thought it might be running a little hot, so I replaced water pump, therm, as well as the temp sending unit. When I do the code reader I get 54 and 32. Having a lot of trouble figuring this out. I have been working on this for about 3 week's any help would be appreciated
  • popo111popo111 Posts: 3
    I am now having idling problems when the vehicle approaches red lights or comes to any stop. It starts right up without problems. It has 102,500 miles on it and has been great until now. If anyone has any suggestions that might shorten my visit to the repair shop tomorrow, it would be greatly appreciated. Thanks in advance.
  • stormnnstormnn Posts: 1
    Did you change the spark module under the rotor? My 93 did the same thing.
  • popo111popo111 Posts: 3
    I have not. I will be bringing it in this morning and maybe that info will help. I appreciate it. I will post the problem and resolution when it is completed. Thank you.
  • popo111popo111 Posts: 3
    OK....I took the Denali to the shop and they fixed it. It actually stalled once on the way there and tried twice at stop signs. It turned out to be 'the throttle body was sticking'. They cleaned it and $150.00 later, It is working again. Thanks again fro your help and maybe this info will help someone else.
  • slywufslywuf Posts: 1
    I need some in depth technical help please - here's the long sad story in 3 part harmony: Recently this Yukon (5.7L Auto Trans) would start fine in the morning, drive fine to work, start up fine after work, but shutting it off 1/2 hour later and trying to restart again would get no action from the starter at all. Let it sit and hour and then it started up fine. Happened again the next day only this time it took 2-3 hours before it would restart. I thought the starter was the culprit, so spent big bucks on a new starter and put it in.
    It started up just fine but the next time it was driven for a while and shut
    off for about 30 minutes, it would not restart again... not even after waiting
    more than 12 hours. Here are the results of some testing that I have done:

    No check engine lite was ever present, and plugging in my OBD2 reader showed no error codes. Security light seems to function normally - stays on for about 5 seconds after turning on the key and then goes off.
    The fuel pump does run when the key is turned on.
    The fuses are good.
    The starter relay is good. Jumped across the output terminals of the starter relay socket and the starter cranks fine, motor starts but will run for just a couple of seconds.
    The ignition switch on this vehicle was just replaced about a year ago.
    According to the factory manual that I have, there is supposed to be a ground present on one side of the starter relay (coil side) this is pin 85 on the relay, and then when the ignition key is turned to start, there should be +12 volts on the other side of that relay coil which is pin 86. I dont see either when I put my meter on there. The diagnostics dont appear to take into account the theft deterrent system, which I suspect may be the reason. Should I be able to see theft deterrent trouble codes with the OBD2 reader as well? I tried adding a ground to pin 85 of the starter relay but it still wont start. What else can I do to figure out what is keeping the starter relay from working? Is there a way to bypass the theft deterrent system? HELP ! I'm stuck.
    Thanks in advance.
  • chenniganchennigan Posts: 1
    ive been driving my denali for about a year ,no probs,yesterday i went to go to work and the dash went crazy weird crazy and starter just clicks sometimes,sometimes nothing not even dash lights i think it might be the ignition switch because if i play with the key sometimes the dash works normal till i touch the key again to try to start it and it goess half dim and freakn out gauges...HELP
  • I have a 1999 GMC Yukon that will not start. The battery is not dead, but the engine will not crank over. I have voltage up to the fuel pump relay. I think it may be an electrical problem. Does anyone have any idea what is going on? It is now going on 3 days.......
  • Last summer my 02 yukon XL died while my wife was driving, she said it would lose power, and die, it restarted a couple of time, drive for a few miles, the same thing. we replaced the fuel filter, and got it home, test fuel pressure, all seemed okay. My daughter drove it for a week, on a trip, and it did it one time when she got back to town, stalled, restarted, got home, and no problem since, until yesterday, did the same thing, power lose, then dies, happened about 6 times, but she got home.
    Any ideas?
  • rshtrsht Posts: 277
    Possibly moisture in the system...
  • heazzzheazzz Posts: 2
    I have a 2003 and I found the crankshaft positioning sensor was bad it is behind the starter on the passenger side - drop the starter and you can get to it thru the wheel well -Good luck
  • I have a similar issue with my vechicle not starting. Through research i have found out that when i replaced the fuel pump my vechicle started right up with no issues. For some reason GM fuel pumps only last about 100,000 miles. This has fixed one of my many problems i hope this helps you.
  • 120k mi hard to start, rough idle, fouled plugs. Dealer says bad injectors. I replaced all injectors, no change. Cold start good. I just don't know what to do next. Plugs, wires, injectors, fuel filter, air filter all changed. Help?
  • rshtrsht Posts: 277
    Have you checked the vacuum lines for any possible leak?
  • emart1emart1 Posts: 1
    have you had any luck ...I'm having the same problem with 99 GMC yucon ( emart401@msn.com) I kind of think its in the security system...
  • Your idle problem could be a clog throttle body and /or IAC (Idle Air Control)valve. If you have a Vortex motor (V-8), this might likely be the problem especially if you have not had your IAC changed out or your throttle body cleaned. Let me know if this works for you.
  • I looked at the arm of the sensor on the body and where it touches the frame, and I'm looking at the shaft (plastic with no adjustment to it) but yet the manual saids that it is adjustable? What can I do without altering it like mounting a bracket on it to go higher? Anyone know or know of anyone doing this with their autoride?

    Help!
  • john8009john8009 Posts: 1
    My 1992 yukon wont start unless you add gas straight to the carbuertor. It will run fine after that but as soon as you turn it off you can't start it unless you readd gas to the carburetor.
  • rcortezrcortez Posts: 3
    Hi Yetirider,
    I just purchased a 2009 gmc yukon a few days ago. On the second day my wife was driving it and while attemping a slow left turn the vehicle died and she then pulled to the side of the road and it started right up. She was driving it today and it did the same thing. I drove and it did have some hesistation to it. I called the dealer and asked the service advisor if he had heard of this happening and he said know. I will take it in this week for a diagnostic. It sure doesn't look promising since I am already having problems. A vehicle that dies on you while driving is very dangerous. Will let you know what they find.
  • fongerellifongerelli Posts: 28
    I never had that problem and I had my yukon for 9 years now. If it continues, under the lemon law you qualify to receive another vehicle at no extra charge. My expertise would have to say there is something going on in the brians of the operation so have them hook up the computer to the Yukon and see what it says. It could be lots of things i.e. fuel injection, electrical , or computer telling everyone else to shut down because of something you know? I hope this helps and I know its frustrating especially when you just spend lots of money supporting an icon like GM and this happens.
  • coach17coach17 Posts: 10
    I have had the same experience with my 02 yukon xl (108,000 miles). Recently on two(400 mile) trips the truck stuttered and stalled while driving. After sitting for a few moments the truck started and ran fine. After the the first occurence, I replaced the wires, spark plugs, and fuel filter. A week later the same thing happened. Any ideas???
  • fongerellifongerelli Posts: 28
    I have an 2000 Yukon (with the new body style) and I have 102,000 miles on it. I have never experience that yet, But I had the similar situation with my Jag, It would stall at an idle, and it started up after I tried but you had to baby the gas pedal to get it going again. You might want to check out the mass air meter (expensive 300-500) or go to a junkyard, because once I replaced that in the Jag it was normal again. Back to the Yukon, I have never had to change the Mass Air Meter in it yet but i did put a chip in it to get better gas mileage or so they say. I have a feeling that GM installed a sensor device that once you reach a certain mileage it starts to stall and etc.. Once you know how to reset that portion you should be fine. If you hooked up a computer to the Yukon system it should indicate the issue that you have, I hope? Look at all of your filters too and make sure the system is running without any obstacles in it's path.
  • rcortezrcortez Posts: 3
    I have the yukon at the dealers right now. I will let you know what they fine. funny thata 2009 yukon is doing the same thing wtih only 40 miles on it at the time. It has done it twice so far.
  • coach17coach17 Posts: 10
    Di you ever find out what was wrong. My 2002 yukon xl does the same thing.
  • check your mass air sensor or your control valve sensor or have your throttle body cleaned. Let me know.
  • Yukon dies while driving, no sputtering, no stalling, just dies. Runs fine after restarting. Any suggestions to the problem???
  • I have had my Yukon going on 9 years now and I have not experience that yet. But I did experience it with my other car and it was the mass air sensor, It is that unit in front of the square air cleaner unit. You might want to be very careful when cleaning it with carbertor cleaner and re-install it and see what happens and if not that You need to take it in and have a meter connected to it so it can identify the problem. I hope helps you?
  • rcortezrcortez Posts: 3
    I have a 2009 yukon that has died 3 times while slowing to a stop. Took it to the dealer and they could not find any problems, after I drove off with it died 3 miles down the road. This has been 3 weeks ago and has not done it since. The milege is bad only getting 15 miles to the gallon in the city and the highway was supposed to get 15 city 20 highway. I do like the vehicle but worried about the longevity. Through this forum have heard of this similar problem through out the years before. I will try to have the dealer ship sign off on a promisary note to fix vehicle even after the warranty has ran out ifthis problem ever returns, if they don't agree will write a letter to gm.
«1345
Sign In or Register to comment.