Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Dodge Avenger Transmission Problems

I bought a 95 dodge avenger a couple of years ago. Got the car for 1,500. Low milage for it's age. I have had to do front end work on it since I have had it, and the brakes. But the problem is I will be driving down the road and I will lose third and overdrive. I can pull over it kicks hard when it down shifts. Wait about three to four seconds start it back up and it runs great. Could anyone have any idea why the transmisson does this? It does not do it all the time though. I love my little car it runs great except for this little problem

Comments

  • Hello, I have the same car doing to the same thing. VERY ANNOYING! now shutting it off doesn't help all the time. Did you ever find a fix? I saw something about having the Transmission control computer flashed on 96's. I'm going to call about that tomorrow.
  • ronc59ronc59 Posts: 6
    The problem is I will be driving down the road and I will lose third and overdrive. I can play with the throttle and it will kick back in for a moment. If I pull it into 2nd gear I can drive the car, just not very fast. The fluid isn't burnt smelling or dark.Also the check engine light came on, I haven't checked it yet but, I'm pretty sure it will be a trans code. Has anyone else had this same problem and cured it? Hope to hear from somebody.
  • Well I finally had to get me a new transmisson. I had the the transmisson computer replaced it didn't help. I finally got someone that could help me and told me it is the shift solenoid (sp?) in the transmisson that was causing the problem. So with all of you having the same problems I was with my avenger transmission have those checked out that could be your problem.
    Kitchenwitch
  • I had the speed input sensor replaced on my 95 & I haven't had any problems with it since.
  • ronc59ronc59 Posts: 6
    Thanks for the tips. I'll check those on mine.
  • mrcdcmrcdc Posts: 1
    I have the same car and it sounds like your torque converter and transmisssion are going out.AAMCO told me at 100,000 miles this will happen.....
  • I have a 2008 dodge avenger and it is stuck in first gear. It is an automatic, but for some reason the car is stuck in first gear. I was just driving the car one day and it just shifted down into first gear and would shift anymore. Is there anyone out there that has had this same problem before. I bought a shift solenoid and replace the old one but the vehicle still wouldn't shift. Any help would be greatly appreciated.
  • jpfjpf Posts: 496
    I suggest that you get the transmission scanned for codes by a reputable transmission shop. Good luck.
  • rage1rage1 Posts: 1
    i got a recall note and took it in and they have to put some clip in the shifter, with out this clip they may get stuck in gear.
  • well let me start here i got one for free the guy I got it from said he had the trany rebuilt and three months of having i had the same problem
    I replaced the speed control sensors and it shifted fine after that
    I got them both off of ebay input and output sensors cost me 20 for both
  • replace the speed control sensors they both casted me 20 dollars on ebay that fixed my shifting problems
    speed control sensors tell the computer when to shift and how fast the car is going
Sign In or Register to comment.