Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Suzuki SX4 ESP problem

hwong_44hwong_44 Posts: 1
edited April 22 in Suzuki
Recently, the ESP malfunction light turns on several times and my SX4 loses a bit of control. have to turn off the engine. When restart the engine, the malfunction light of ESP is off but the engine light is on. The engine light wll go off automatically after a day without starting the car. Went to the service dept. The computer shows nothing wrong with the car.

I find out that each time when I turn on the engine with the brake padel. The ESP light will on. but yesterday, I didn't so this, and the ESP goes wrong again. Therefore, would like to know is there anyone experiencing the same problem as me? Any advice.

Thanks.

Comments

  • At least with the "Engine" light on. That way the "error code" should still be stored and they should be able to read it with their test computers.
  • I've had the same problem. I have 40,000 m iles on it now but the ESP started at 1000 miles.. if ur gas lid isn't JUST Right it sets that off and it will eventually re-set it self.. also mine trips and all that if i use gomart gas (around here WV it gets water in gas) it goes away after re-fuling with another station. does exactlly what u are talkin about. Wait till u get more miles on it sensor screw up, my AC leaked in my floor, they had to re-install a complte unit, my doors are warped up heck my back door falls off (the interior) these cars are cheaply made
  • athungoathungo Posts: 1
    I have a 2007 Suzuki SX4 sedan. There has been a lot of noise coming out from the front left suspensions. I have changed the control arm, Ball bearings , Shock absorbers and the balance rod bushings. But the sound still persist whe i enter bad roads. It is so uncomfortable. Could anyone please tell me what the problem really is. Oh!! and the sound is like as if something is loose and not tightened properly giving it a clicking and dum dum sound... Please help me!!! :cry:
This discussion has been closed.