Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Nissan Armada Maintenance and Repair

191012141522

Comments

  • What did you do to get the problem fixed. My Armada is doing the same thing and I don't want the dealer to try and tell me it's a unique problem and charge me crazy money. Thanks.
  • Am I reading this correctly, you're saying that you got into an accident caused by the brake problem and your pregnant wife was killed???
  • tidestertidester Posts: 10,110
    arichards2,

    Fortunately, that was not the case. Robinj1 also posted this a few days back: robinj1, "Nissan Armada Problems/Solutions" #336, 12 Oct 2006 3:54 pm

    It's very disturbing and we wish her a speedy and full recovery.

    Robinj - you didn't mention the condition of your child. Is he/she okay?

    tidester, host
  • pmtrepmtre Posts: 55
    It's been awhile since my last post but I'd like to say I'm looking to purchase another Armada after the 1st of the year. Bought New 04 in Dec 2003, had the brakes fixed at 20k now have 45k with no problems. If there's something better out there to purchase, I'd like to see or hear about it. It's hard to beat the package Nissan gives you with the Armada for the money. What's better?
  • rshershe Posts: 236
    Pmtre,

    I have been looking (my 04 Armada got smashed)and must admit, not much even comes close. Test drove the Sequoia better quality fit and finish, but no where near the size on the interior. Trade off that I liked on the Sequoia is the 3rd row slides forward for more cargo space...Tahoe-quieter ride than my Armada, but 3rd row is a joke. I don't think my 4 y.o. would fit back there. I am not a Ford or Dodge person, so I can't speak for the new Exp. or Durango as I wouldn't even consider them. I currently have a GMC Yukon XL as a rental and must admit I am quite pleased with it, but must admit it is a bohemouth and still seems to have less 2nd and 3rd row legroom...The thing I do love is having a cargo area to load stuff, which is non-existent in the Armada with the 3rd row up...Just my 2 cents...I'm sure the flames for all I have mentioned will follow... ;)
  • i had no choice but to take it to the dealer after it left me stranded at disneyland any ways lucky for me they said the problem was the car main computer that was bad and was still covered under the 60 thousand mile powertrain warranty ,i have 58 thousand miles now. i will be picking up the car tommorow since they took 2 weeks to finish supposedly the part took a while to get.also they told me that there is a recall on some harness related to the car computer that maybe caused the problem but they were out of that for another week hopefully everything will be fine and ill keep you guys posted
  • I picked up my car Armada yesterday morning from service. They claimed it was a low battery and replaced it for a total bill of $250.00 Crazy!! Then while driving home from work that evening, guess what? Yep, stalled again just like before. Please let me know what ever harness or computer problem they fixed. I too am at about 50K miles and am outside of warranty. If I had something to show what the problem is maybe they'll actually take a look at it. Thanks
    Bobby
  • (See 304)It has been quite a while since I posted, but here goes. After the service dept. at my selling dealer priced me almost $1500 for a repair, I took my 2004 Armada to another dealer (#2). I told #2 about all the doubts I had about the bogus diagnoses I had been getting. I told #2 to take the time necessary to properly investigate my complaints...primarily the stalling of the engine while driving, and a popping noise when I turned the wheels sharply at low speed. After 9 days of careful inspection and considerable driving of my vehicle #2 found the problem with the stalling of the engine was the FUEL PUMP!!!.
  • Could you Please get in contact with me about your situation with your Armada Rollback problem. My Aramada did the same thing but went foward as well. If you still have the lemon please personally e-mail me at RJLurch@aol.com. Thank you and hope to here from you. I also have contact the DOT/NHTSA about the problem. Thanks, jason :)
  • I have a 2006 Armada. In the sand (I live in the middle east)I get a grinding noise from the front left when I turn to the left.

    Dealer says it's 'normal' ..never had it in my Patrol.

    He checked all the bearings (vehicle had 1500 miles on it when i first noticed it)...

    Any ideas? Is it normal? ..can't see why.

    Regards,

    Pete
  • paisanpaisan Posts: 21,181
    Doesn't sound normal to me. The grinding might be normal if you were driving it on dry pavement. I'll give it a shot with my Armada and report back to you on it.

    Where in the middle east are you?

    -mike
  • rshershe Posts: 236
    Try turning off the VDC and see if it goes away.. I go to a drive on beach with deep sand and the VDC which sounds a bit like grinding when it kicks in (usually when you are starting a turn in the sand) gets quite annoying. I just turn it off.
  • I have the same problem. What did the dealer say?
  • Afternoon.

    I'm in Doha. Been here about 1 year..quite enjoying it. Nice to go into a supermarket and leave the truck running 'cos it's too hot ..and still finding it there when I get back out!

    Regards,

    Pete
  • Thanks I'll certainly try that. What's your experience with the Armada in the sand? I had a Pajero in Dubai, and even though it was a bit underpowered I managed to get around in the desert quite well.

    I've been invited on quite a few desert drives here and am a bit nervous. The Armada seems so heavy and clumsy.... we bought it for my wife so she'd have lots of metal around here while driving here.

    Again, thanks for the feedback.

    Regards,

    Pete
  • He said it was 'normal' ...maybe he knows much more than me. There's also a bit of a language barrier here so him saying it's 'normal' maybe should have had a lot more explanation.

    One reply suggested I turn off the VDC ..I'll try that a report back.

    Regards,

    Pete
  • rshershe Posts: 236
    Pete,

    I have used it for the past 3 years to go on deep sand at Assateague Island in Maryland...Never a problem at all and not stuck even once.. I air down my tires to about 18 p.s.i., although I have gone on the beach with full pressure and it was fine. The lower pressure gives it a bit more grip. I go pretty weighted down as well, yakima mega warrior rack (pretty full), hitch rack, cooler, gear, tents, 3 kids, the wife and I. The VDC is annoying and I shut it off once I engage the 4WD. Good luck and have fun.
  • I get the same thing (popping sound when I shut it off hot)I also tow a 32'TT. Have you figured out the cause yet??

    Sorcisto
  • Hello All,

    Let me first state that I am attempting to remove all emotion out of this message to avoid bias. My goal is to simply supply personally discovered information to help others in their individual situations. That being said lets begin the story.

    I purchased an 04 SE Off Road in 12/06.

    48hrs after owning the vehicle, the smaller driver side sun visor fell off, which I haven't had fixed yet.

    72hrs afterwards, the braking system ceased to work while traveling on a heavily populated street, luckily there was a turning lane that gave me adequate room to stop before reaching the intersection. Symptoms: Brake peddle fell to the floorboard, grinding was felt and heard, dash brake light came on. It felt like the brake pads fell off the calipers and the calipers and rotors were rubbing against each other to stop the truck, which didn't happen. I had roughly 20% braking power, compared to normal, when this occurred. I came to a stop on a side road, read the owners manual concerning the dash brake light. The manual advised me to check the break fluid, and if full, take to a NISSAN dealership. Therefore, I brought it to a NISSAN dealership immediately. Within 10mins a mechanic noticed the upgraded braking system was already added to the truck before I purchased the vehicle. Therefore, their approach to fix the problem was reprogram the VDC control unit. (Please see specific info below). From the work order, this took them about 40mins.

    I have had the truck for a total of 2weeks now. The most recent issue is the driver side window. It won't roll up every time like it should. As of now, the window will roll down normally, but once every four times will struggle to roll up half an inch while residing inside the door frame. After playing with the window switch a few times, the window will roll back up normally.

    Important Info: As a second owner of the truck with 20K miles (16K left of 36K bumper to bumper Manufacturer Warranty) I was able to obtain a Five Year Claim Historyon the trucks repairs! This was substantial because I was able to view every repair that was applied to my truck before I owned it. The NISSAN Dealership printed this 5yr Claim History report, while repairing my brake problem. I noticed the 5yr Claim History report and asked for a copy. What do you know, they willingly gave me the report! (See below). Also note that, even if you are a second owner, NISSAN still honors their 3yr 36K & 60K Tran/Motor warranty.

    Problems with my 04SE Off Road:

    12/04 - Sun Visor Assy-LH (RPL Both Sun Visors)
    06/05 - Speaker Unit (RPL One Front Door/Kick Pane)
    04/06 - Rotor Disc Brake Front, Pad Kit Disc Brake F&R,
    Bolt
    (PRL Front Rotor & Grind Rear)
    04/06 - Harness-Jumper (Install BCM Sub Harness)
    12/06 - Reprogrammed VDC Control Unit (Reprogrammed
    VDC As Per Bulletin NTB06-040) Fail Code: 32
    Nissan Bulletin NTB06-040

    Please post your experiences so we all can learn from them.

    Sincerely,
    B ;)
  • paisanpaisan Posts: 21,181
    That is a known intermittent issue on the 04 models, there is a TSB out for it to replace both the front driver and passenger side switch units out. Bring it to a dealer and they'll fix it for you.

    -mike
  • paisanpaisan Posts: 21,181
    That was a very early production model and I'm suprised at how few problems you've had! That's great considering it's probably one of the first mass produced units.

    -mike
  • I had a 04 armada with serious brake problems... Complete brake failure 8 times. The Armada had 41,000 miles. I fought like hell. This truck sucks. I got my refund $35k and going to buy a new car... not a Nissan. Questions? [non-permissible content removed] it would be my pleasure. Fight like hell this truck is dangerous. One word of advise, Nissan will continue to tell you there is nothing wrong and you have too many miles ( over 30k)Keep fighting. 1-800 Nissan is a joke. Nissan arbitration is worthless. Keep calling and writing. Go above the dealer, the dealer will not do [non-permissible content removed]... Trust me.
    -Nissan sucks
    -Rob
  • paisanpaisan Posts: 21,181
    Perhaps YOUR nissan sucked, mine tows 9000lbs w/ease and 90% of my miles have been towing miles. Once they got the brake issues worked out, I haven't had any problems.

    Most likely you had an incompetant dealer who couldn't track your problem down. But don't lump all Nissans together my friend.

    Too bad it didn't work out for you, but show me another SUV with 9000lbs towing capacity, there are none except a 2500 series Suburban and if you think Nissan is a Joke, try a GM on for size.

    -mike
  • gbajagbaja Posts: 13
    hi guys,
    I know that there is an issue with the brakes, what I want to know is if they extend the warranty? I have an 2004 'mada that needs a new pair of rotors. thanks
  • paisanpaisan Posts: 21,181
    If you had the brake upgrades done, there is no extended warranty available.

    I had my brake upgrade done several of them (there are various different ones they came out with) and after the last one, my dealer was able to cut the rotors once, after that I'm on my own for rotor turning/replacement.

    -mike
  • Well I am aware that not all Nissans Armadas suck. The 2004 Nissan Armada has a serious brake problem....I was nearly killed because the damn thing had complete brake failure and I am by far not the only one with this life threating problem...The dealer was not able to fix the problem or the several nationwide Nissan Experts tech could not either.... Anyways are you reading the posts?... I guess you got a good one and the rest of us got a piece of Sh*t...Good luck with your Armada and ya a GMC looks great...Least it stops when you need it too!!
  • paisanpaisan Posts: 21,181
    Can you describe the post-mortum on it?

    Brake systems are fairly simple systems, and I'd be interested in what was the final result or cause of the "complete" failure.

    Simply coming on here and stating things like that are not useful in any way to a solution if someone is having a similar problem.

    I guess I should go play the lottery as mine stops w/o issue since having the last brake-update done on it, and I don't drive lightly, I've done several 100mph+ stops down to 40mph, stopped an un-braked 6000lb trailer, and routinely heat up my brakes in NYC traffic.

    So do please tell us the details of your problem and what the cause was.

    -mike
  • gbajagbaja Posts: 13
    they did fix my brakes at least 7 times since 2004, the main problem it vibrates at high speed. I think the rotors are 'kinda messed-up & needs a new one or needs to be cut.you think they extend the warranty on this issue?
  • Its very simple.... I would need to stop. I would press the brake, the brake would go to the floor and would not stop. Turn the Armada on and off again and problem fixed. Happened 8 times. The last time the wife was nearly killed, off the road into a ditch.
    Yes it is helpfull. I told people to email me if they are having the dreaded 2004 brake failure issue and perhaps I could help them.
    They could not find the cause and could not fix the issue. Nissan flew experts in and nobody could figure it out.
    Dont get me wrong your Armada sound like all is well. I wish I had one like yours, so do tons of other people. Good luck with it.
    I wish nobody have the same issues I did. Somebody will get hurt.
    God Bless
  • paisanpaisan Posts: 21,181
    I take it they replaced the ABS Unit, all the sensors, and possibly the VDC ECU, and the Car ECU.

    There isn't much else that could cause a problem like that, I also find it very hard to believe that there would be NO BRAKES, they aren't brake-by-wire.

    Seems odd to me, something isn't straight on this story, sorry I don't buy the brakes completely failed. That's not how brake systems are setup.

    -mike
Sign In or Register to comment.