Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Pontiac Torrent Stabilitrak and Traction Control Lights

ace331ace331 Posts: 1
I have a 07 Torrent bout 20k miles. The traction control light came on, and the panel says to service stabilitrak and traction control. It came on while I was stopped at a red light. Whenever I push on the gas the wheels wont spin til RPMs are about 3000, and barely at that. I was only a few blocks away so I was able to make it home fine. Has anyone else had this problem?
«13

Comments

  • ellengelleng Posts: 33
    Yes I had the same issue and made an appointment to have it looked at but the next day the light went out so I never took it into the dealership.
  • packer3packer3 Posts: 277
    Sounds like it might be the ABS wheel sensors.
  • I have an 07 that did the same thing but only after setting at idle for about 15 - 20 minutes at the bank. Took it to the dealer. Shut it off and it started right back up and the dealer said there were not error codes and if it did it again to drive it in and leave it running. It did it again and when I took it in left it running the dealer service rep shut it off. And same thing no error codes the next morning. 2nd time it had no power and barely made it to the dealer. Now it seems to have a miss at city speeds. Did yours do the same? Anyone else have this problem.
  • nemanema Posts: 1
    My 07 did the same thing - 20k miles. Wiring Harness had snapped in the front right tire. Service Traction Control, Service Stabilitrak and ABS lights all on.
    DIdn't take much too fix - wish I new why/how it snapped.
  • The battery died so I got the vehicle boosted. When it started the stabilitrack states that it needs service and the power steering seems to have gone out. Not sure what happened. It is a 2008, low miles. Can anyone explain what happened? :confuse:
  • johnny60johnny60 Posts: 1
    I had the same problem. 42,000 miles on an 07 Torrent. The dealer tells me he's never heard of a problem and they know nothing.
  • wbechardwbechard Posts: 2
    I had this problem on my '07 @ 35,000 kms just about a month ago. Torrent drove fine, just had the light on for a few days until it was cleared.

    Dealership cleared the error, then applied a firmware update to the stabilitack module. They then had to re-calibrate all of my wheel sensors.
  • I had the same happen to a 2007 Torrent, at about 52000 miles. The dealer replaced an electronic control module, which part costs $400. I just also changed out my front struts and had the same dealer re-align all four wheels. The service stabilitrak and traction control light just came on again, but the dealer was too busy to look at it the same day. Next day the service lights are off again. Will wait to see if they come on again and bring to the dealer or Autozone for analysis.

    Also, tip on replacing the struts. Struts and mounts are difficult to find for this year vehicle, but are available for the 2006 model. Make sure to replace the strut mounts as well... mine made lots of noise the first time I replaced one strut and not the strut mount. I found Monroe struts and mounts at Advance Auto Parts (again for 2006 model).
  • I found this TSB, which may be helpful:

    NHTSA Item Number: 10028186
    Service Bulletin #: PIT-4756
    Replacement #:
    Vehicle/Equipment Make: PONTIAC
    Vehicle/Eqipment Model: TORRENT
    Model Year: 2007
    Mfg Component Code: 036400 SERVICE BRAKES, HYDRAULIC:ANTILOCK:ABS WARNING LIGHT
    Date of Bulletin: 2008-11-01
    Date Added: 2009-03-13
    Summary: GENERAL MOTORS: ABS AND STABILITRAK LIGHTS ON DTC(S) U0121, C0550, C0186, C0196, C0710, C0252. THIS CONCERN CAN BE CAUSED BY WIRE HARNESS GOING TO EBCM, CHAFFING ON TRANSMISSION MOUNT OR METAL BRACKET. *PE

    Other similar TSBs include:
    NHTSA# 10021080, Service Bulletin# 4260
    and NHTSA# 10023914, Service Bulletin# 070232009
  • I had the exact same problem with my '07 Torrent. Can you tell me if the problem was fixed? Mine is currently at the dealer. This is the second time the power steering has gone out.
  • gmcustsvcgmcustsvc Posts: 4,055
    englishteach1,

    Have you contacted GM Customer Assistance regarding the problems you have been experiencing? Please keep me posted.

    Thank you,
    Caron, GM Customer Service
  • The problem isn't the stability trac I just had the same problem on a 2008 torrent and the problem ended up being a dead cell in my battery
  • I'm having the same issue with our 2008 Pontiac Torrent GXP (front wheel drive). The issue first started with only 30k miles on the odometer. As previously stated, once you turn the car off and start it back up the code would disappear. The code came back on within a few 100 miles, so we decided to take it to the dealer. Five separate trips to the same dealership spanning over a month and the issue is still there. Action items performed thus far, all by dealership are:

    - CODE 131
    - Steering Angle Sensor
    - Realigned Toe and Caster
    - BFP Sensor
    - Brake Pressure Modulator Valve Replacement
    - BPP Sensor Replaced and Retested
    - Found Internal Short In the EBCM - Reprogrammed the module
    - Re-calibrated Steering Angle Position

    Our next step was to contact GM Customer Service on getting this issue resolved. We've talked to them twice, now we have been waiting for 2 weeks for a "follow-up", hopefully resolution call. In the mean time, we gave up on that dealership and have taken our vehicle to another dealership to solve this issue.

    We are nearing the end of our warranty and would hate to be stuck with the bill of repairs for something that first occurred while under warranty. I will provide any updates as they come along. Maybe user bg3075 is onto something, I will mention this to the service rep.
  • It looks like you already have a case going, 08torrentgxp. If you wanted to forward the reference number (71-**********) or the last 8 digits of your VIN to us at socialmedia@gm.com, we can check into the progress of your case for you.

    Sarah, GM Customer Service
  • We'll be sending you an email shortly with the requested information. There is some additional information that I have left out this post concerning the repairs performed while trying to chase down this issue. We will include the details in the email we are sending you along with the case reference number.
  • Update....

    Yesterday we took our Torrent to the other dealership (let's call it Dealership B), hoping for better results. I mentioned the service bulletin noted by bg3075, but the service rep dismissed it, because the years did not match up (we have a 2008 vs a 2007). Dealership B is well aware of all previous work performed on our vehicle and decided to do the following:

    - Re-calibrated the brake pedal switch and the steering angle sensor

    The car was good for one day (approx. 40 miles), then the Service Traction Control Service Stabilitrak message appeared once more on the Driver Information Center (DIC). Dealership B would like for us to bring the car in again to take another look at the vehicle tomorrow. The saga continues....hopefully GM Customer Service will help us out.
  • I have had this continual problem with my 07 Torrent FWD since I bought the vehicle new in Dec of 2007. It has been in a couple different dealerships nearly a dozen times for this and several other problems.

    The power steering doesn't engage on startup and/or various warning lights for the Traction Control, Stabilitrak, Charging System, Reduced Engine Power, start coming on and then anywhere from 1 week - 3 months my battery will completely fail.

    Currently my vehicle has been diagnosed by a GM Tech as having an 'undiagnosable electrical issue' that results in intermittent battery drain and failure. I was told there was nothing more they could do without keeping the car for several weeks in order to monitor it. The dangerous part is that on two occasions I have been driving with my children in the vehicle and the electrical systems start dying. I have had the car 5 years and it currently on it's 5th battery. The Service Stabilitrak warning started showing yesterday (Oct 23, 2012) so I am anticipating having to replace the battery again soon. Luckily the batteries never even get close to being out of warranty.

    I had opened a case with GM in February 2012 after my 4th battery replacement. The only thing they would do is offer me a unspecified amount, but no more than $1000, off the purchase of a new vehicle. However, eventually I stopped getting updates on what was going on with my claim and the rep stopped returning my calls.

    If anyone finds a resolution to this issue please let me know. I would love to get this fixed.
  • silversub122,

    If you had wanted for us to check into what happened with your previous Service Request, we would be happy to check that out. Please email us the last 8 digits of your VIN, as well as your name and contact information, to socialmedia@gm.com

    Sarah, GM Customer Service
  • Hey silversub122. Just to let you know, we are still talking to GM Customer Service as well trying to see what they can do for us as the first shop, Dealership A, did some sketchy work on our vehicle. Now under startup our vehicle blows a puff of blue smoke, as if oil is making it's way pass the cylinder rings and onto the top of the piston.

    So after taking the car back to Dealership B again, they diagnosed our problem as the Brake Pressure Modulator Valve. Apparently this piece was defective from the beginning and Dealership A, for whatever reason, decided to work backwards on the service bulletin provided to fix this issue. The Tech from Dealership B, speculated that Dealership A probably worked backwards, because this part did not exist in GM's inventory anymore. The piece we now have in our vehicle was specially made just to fix our issue. We have driven our Torrent about 150 miles and one week without the Service Stabilitrak Service Traction Control from appearing on the Driver Information Center (DIC) screen. I'll update this post if it does come back on.

    I'm still very concern about the puff of blue smoke I see during startup that appeared after Dealership A had their hands on our Torrent. I'll be monitoring the oil levels and the amount of smoke for any unusual changes. We are still hoping that GM Customer Service will negotiate with us on something to help us keep this vehicle. If not, we may just have to leave the General. Standing behind your product, and making customers happy goes along way, especially with sources like the internet that can get your voice out there.
  • Thank you Sarah, I have sent the requested information to the email address indicated.

    A new development on my ongoing saga - I have now begun seeing the 'Service Airbag' warning indicator as well.

    These warning indicators appear and disappear each time I start the vehicle. Sometimes I get more than one, sometimes none at all. Sometimes they stay on until I turn off the vehicle, other times they will go off while I'm driving.

    At this point I want to get rid of this car. As much as I liked it in the beginning, all these constant warning lights, electrical and mechanical system failures, and the fact that I can't even take it through a car wash without getting water pouring through the A-pillars like a garden hose has completely soured me on the vehicle.

    Unfortunately, dealers will only offer about half of the Kelly Blue Book value for trade-in because 'the brand is no longer being produced' and anyone with the ability to get a Carfax report can see all the problems it has had, so I'm stuck.
«13
Sign In or Register to comment.