Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Jeep Grand Cherokee Electrical Problems

11819212324

Comments

  • this is rockyjr i don't have a problem with windows i have a 2011 jeep gc with a battery warning light that does not come on at start up
  • nomi91nomi91 Posts: 3
    I am having problems with my 2000 jeep grand cherokee laredo.
    It shakes horribly like the steering wheel wants to go off by itself but most importantly i have had an issue with it heating up for the past 2 years.
    Its leaked out the antifreeze ive had the radiator replaced and alot of the insides replaced as well.
    With summer coming its starting to act up again as soon as i turn it on it just kind of shakesfor a few minutes then stops
    also when i turn it off and ive had the ac on it sounds weird like a loud hurricane sound.
    so far ive taken it to 3 different mechanics just this month alone
    but now im worried because last yr i had it straight wired and now the electrical system is whats wrong but i told the mechanics i chose to get it straight wired because of the previous problems before.
    so now im not sure what to do and if its possible to get it back to the way it was before without straight wiring and what kind of mechanic am i looking for or if i need a new motor as one mechanic told me.
  • larchavelarchave Posts: 19
    This has happened to my Jeep since the day I purchased it in 12/06. I have a 2006 grand jeep and my lights flicker and when it does, if i hold the switch it stops. The radio just changes stations as if their is a ghost. they replace it when i bought the car. The engine light come on and off but I drives well.. Sometimes the transmission slips when the engine light is on but over all. dont waste your time and money because the deal will never figure it out. the reset the computer to my car and it was fine for 3 years now this has started again. i will live with it until my car is paid off in 9 months. then will trade in for a Honda to Toyota
  • thecez01thecez01 Posts: 4
    SO AN UPDATE ON MY 96 JGC 5.2L

    I HAVE REPLACE PRETTY MUCH EVERYTHING. THE PARTS ARE
    FUEL PUMP
    FUEL FILTER
    IDLER SENSOR
    THROTTLE SENSOR
    MAP SENSOR
    BATTERY
    ALTERNATOR
    DISTRIBUTOR CAP, ROTOR, AND CAM SENSOR
    CRANK SENSOR

    AND WELL NOTHING SEEMED HELP. IT FINALLY STARTS BUT A VERY HARD IDLE AND THEN DIES. PLEASE IF ANYBODY HAS ANY OTHER IDEAS IT WOULD REALLY BE APPRECIATED.

    THANK YOU
  • upacreekupacreek Posts: 1
    MY 98jgc kept draining the battery everytime it rained...I had a lot of people look and try to fix and couldn't. Nth said they would find eclectically issue for $99...so I took it to them and they said they would do stater system check for $15..they cleaned the posts on the battery and inside of the connectors going to the post and cut offextra loose wires. So far problem solved 3 weeks later...he said the wires were loose and the moister would connect the loose ends and drain it.....now no starting issues and my jgc doesn't need me to jump it and keep my foot on gas to keep engine going....
  • My hazard ligth or even the other buttons on the top bank do not work including the hazard lights. I checked all fuses underneath the dashboard and they are all OK. Is there another fuse for the hazard lights in the engine compartment?
  • tiredofitinaztiredofitinaz Posts: 8
    edited April 2012
    I am looking for owners of other Jeep Grand Cherokee Overland Diesels who are willing to help out together a comprehensive list of problems they have encountered with their vehicles. Let me know if you are interested.
  • tanyablytanyably Posts: 7
    I have a 04 jeep GCL 4.0/70,000 miles on it. The light started coming on and it was injector #5. I have checked the wires and replaced the injector more then a few times. I had to change the coil pack about 4 times, before I got one that stopped going out on me. The coil pack problem was about 10,000 miles before the light problem. I took the injector off and bumped the key over and there is way to much fuel coming out of that injector. The other ones don’t spray as much fuel as #5. I took the injector off and ran it without it, because I put a towel at the muffler and noticed a lot of fuel was coming out of the muffler, when I had the injector on.(it was dripping on the towel fast)(it didn‘t smoke at all). I am not sure if this is normal on a vehicle, but when I put the towel by the muffler I noticed it had a suction as well as it blew out.(..lol…don’t know how else to write that)..I have not been driving it, so I am not sure if it would die on me or what. It never did when I was driving it. I stopped driving it, because the light starting flashing fast. I wish I would have known about this sight, before I had to call my ex.. lol. I could go on and on with the things I have changed out and fixed on this jeep. I hope I put enough information, I don’t know to much about vehicles I can change a part that is about it. Thank you for your time and any help… Tanya Bly…FB
  • spo321spo321 Posts: 1
    i have a 1996 jeep grand cherokee, the vehicle fires up perfectly but then instantly dies not a sputter nothing it's like it just loses spark. my automatic lights do not work, but i can manually turn my lights on.my power windows dont work, and my door locks will not work. my interior lights work. after trying to start it multiple times i can here a sort of clicking from inside my vehicle like when the flashers are on. but only for a few moments. could this be a relay, or my ignition? any help would be wonderful.
  • tanyablytanyably Posts: 7
    Hi, Put your wallet away…. If it is what I think it is you will not spend a dime, just a little time…lol .. I have a 04 JGCL and I had the same problem with the windows and locks and not sure, there was something else that went out. It is the black wire in your driver side door jam. My son fixed mine, I think there is a boot on it slide it out of the way and you will see where that wire broke. A lot of people are having that problem. I have seen it about 20 or more times on this sight. You may want to read over some of them. They talk about it little more in detail. I have read about the other problem you are talking about also. The answer is on this sight not sure where sorry. Hope this helps. Tanya
  • pegoo57pegoo57 Posts: 1
    I have looked outside at night and my dome light is on. Jeep is off has been off for several hours. It is a 1997 Grand Cherokee Laredo. Lights are off doors are all securely shut. What is my problem? For a few weeks while driving the doors would lock and unlock and dome light would go off and on. vic didn't indicate doors ajar. HELP!!
  • mr_smithmr_smith Posts: 11
    I own a 06 Jeep Grand Cherokee laredo....does anybody else experience a short in the turn signal stem which causes the instrument lights and clock on the radio to flicker??
  • over211000over211000 Posts: 1
    My 99 Jeep Grand Cherokee has over 211,000 miles and most people think it's a 2004 because "IT LOOKS SO GOOD", but in the last couple of years it has been posessed. The back passenger window goes down by it's self, the sun roof opens slightly, hatch won't lock and if you open the hatch when the doors are locked the alarm goes off. Not to mention I have replaced the right tail light four times in the last year (and it's out again). I have maintained it well, I replaced the transfer case, axels, altinator and just had the transmission rebuilt. I had a mechanic look at the connection in the door and repaired a broken wire. Could this be a BCM problem or is it the PCM, and should I try replacing the screws with a 1/4"?
  • jauiboydjauiboyd Posts: 4
    I have an 04 Jeep Grand Cherokee Lareado....I had a similar issue where the wiring harness in the driver side door jam (one wire) broke and my instrument panel, radio lights all went out. My door locks & windows weren't working. The locks also would not respond to the remote either. I would have someone take a look at the wiring harness.
  • tanyablytanyably Posts: 7
    edited May 2012
    Anyone know where I can find a diagram of the harness that goes from the driver door to under the dash? Oh I am also trying to find the fuel modulater if anyone can help 2004 JGCL. I hate to bother you all about something as simple as this, but I have do spent a lot of time trying to look it up. I am a lady, so I think that may be why I don't know where some of the things are or what they look like...Thank for any help..Tanya bly
  • tanyablytanyably Posts: 7
    I have been having that problem also, and it was when I changed out the battery. First thing I am going to do is replace the battery. Then I am going to check the wiring to the battery, I did read somewhere that someone was having that problem and it was in a wire to the battery. It wasn’t the cables it was a wire leading to the battery. When they put my battery in it was not sitting level I fixed that problem, but it dies sometimes when I am making a slow turn. I am having a lot of problems with that jeep it is a 04 JGCL with 70,miles on it. If you ever figure out what is going on pleas let me know and I will do the same. Thanks
  • creimardcreimard Posts: 1
    Hey man,, I have the same problem. Mine you can run for days with nothing then bam,,,it die's. somtimes it starts rite away, somtimes it doesn't..if you ever figure it out, please let me know...thank you
  • lcatanlcatan Posts: 2
    My A/C and blower died suddenly. then yesterday, the auto windows would not go up!! I checked all fuses within the interior and under the hood- they are all fine!! Can someone please help!! It is going to be around 90 this weekend and I am freaking out!!!

    Thanks!!

    Laura
  • tanyablytanyably Posts: 7
    Hi Laura, I can tell you there is a black wire in the driver door jam. Just slide the boot back and you will see there may be a wire or two broken. When you fix the black wire it will fix the problem with your windows. I had a few wires broke that controlled a lot of electrical problems. I would start with that you never know one of them wires may control you’re a/c blower. I don’t think it will, but it may. You would be amazed what went wrong with my 04jgcl with the orange and white wire and black wire broke. I really think the wiring in the driver door jam is where you should start. There is a lot of stuff about this on the sight, I would type (windows) in the search and I am sure you will be able to find more information on what I am talking about. Hope this helps.
  • agallinoagallino Posts: 1
    edited May 2012
    I have a 2002 Jeep Grand Cherokee and Ive had nothing but problems. I got two trannys put in. Shifts fine and the check engine light came on said the sensor went so I got that changed.. The check engine light came back on so I needed spark plugs did that. check engine light again, new coils .. :again: fuel filter .. :again: fuel line which had a leak,, :again: and then I just got a crank shaft sensor (not exact on the correct name for it) and again the check engine light is back on .. when it not blinking its fine it runs great as soon as it starts to blink i cant accelerate and it starts to buck kinda bad.. sometimes i can let go of the gas slow down and it will stop blinking and I can continue to drive but a lot of the times I actually have to stop and start my car again to proceed. each time i got something replaced which all the parts i got replaced needed to be fixed you could see that, it still does the same thing this since the beginning when the light first turned on. Please help.. what could this be? I am at a loss.. Also my blinkers work when they want to and my headlights dont work .. the lights themselves are fine.. I seen one come on for a little while and it is back off but my high beams work.
  • wpatterswpatters Posts: 54
    My son has a car that acted like that. Check your battery connections and make sure the ground connection to the car is clean and put a star washer under it to bite into the metal. If the ground circuit to the battery is bad or marginal the computer will act weird. Also make sure any other ground connections from the engine to the chassis or any where else are also clean. Sometimes they look good but underneath the washer or bolt is corrosion and that is a no no for the little current draw of the computers....yes some models have more than one. I have a 2003 and the coil went out. In the process I found several connectors with bad connections. Sometimes you have to pull apart some of those connections you see in the engine compartment and reconnect them to clean the connection. It all sounds like electrical. And again make sure the battery connections look like new...ANY corrosion on the posts is a big killer.
  • jenijeajenijea Posts: 1
    I have a 1996 JGCL and the dash lights flicker bright and dim constantly when my headlights are on..my husband replaced the headlight switch control box and it stopped for a day or two and then started flickering again.. another problem I just started having is that the ac just stopped blowing ... I turned the ac off and waited a couple of minutes and turned it back on and it worked just fine .. the ac issue has happened twice now. I seen someone said that it might be the clutch in the ac compressor. Does anyone have any ideas on how to fix these 2 problems?
  • ev10ssev10ss Posts: 2
    Appears that my Jeep does not like to go thru a automatic car wash, one where the vehical is pulled thru. Four out of 6 times I will have the wipers come on automatically and make 1 or 2 swipes, the traction (or hill??) light will flash, and then the battery light comes on a stays on. The first time I took it to the dealer and as soon as they shut it off and restarted the light was cleared. They kept it for 4 hours and just said that the codes indicated a voltage spike but no issues. Now I'm just keeping a log between oil changes to document.
    Any ideas or similar experiences?
    Thanks,
  • tanyablytanyably Posts: 7
    I found the problem when I got another reading that the sensor was bad the one I just changed out. I started pulling all the wires from that sensor all the way to the pcm and found a burnt wire back behind the motor. The bracket was broke that held them from touching the motor and that is why it happened. I never could get a good reading on the injectors that is why I figured it had to be a wire. Hope this helps someone. Now I am getting 2 different codes on the fans. Back to the drawing board. But it runs so good..Tanya
  • snewpsnewp Posts: 1
    Hey Folks,
    Ever since I got my Jeep, there have been slight electrical issues, but over the past 5 years they've gotten worse, and more of them. Now that I'm seriously considering getting rid of it (which I don't wanna do) I looked you guys up. Quick, ain't I? Anyhow, the automatic lights will just randomly start flashing. As soon as I touch the panel where the control dial is for the lights, it stops. If I don't use the automatic setting, and just turn them on manually, no flashing of the headlights. I live in the city so I like the automatics - I can get in the house before they shut off. But living in the city could also get me shot if they start flashing when I'm behind someone. My radio never worked right, so I replaced the antenna several years ago, didn't help. Now the CD player doesn't work either. Just barely static. My sunroof won't open anymore. Heated seats don't heat. And now I get a message at night that says my taillights aren't working, but they are. Till I get home from work, the message is usually gone. All the gauges work, windows, work, AC blower works, dash lighting works, security alarm works, power seats work, cruise works, just the freaky things mentioned above.
    Does anyone know if there has been a recall for this problem? It seems like a grounding issue. I put a new battery in it last year and nothing got worse at that time. All these things were happening waaay before the new battery except the CD player, and I feel my son had something to do with that. Any words you can offer to direct me would be appreciated.
    Steve
  • I am having the famous Jeep electrical problems again. I have a 2004 Grand Cherokee 4.0L, 103K miles. 3 months ago I had the exact same issues, pulled the boot between the door and found the black wire was broken. I spliced it back together and everything worked perfect until 4 days ago. I checked the black wire again and found my splice had pulled apart. I re-spliced it but this time the problems did not go away. I ran a continuity check on that black wire (and every wire) that goes through the door and found everything to be connected. So I took it to a shop and they double checked all the wiring and even put in a new control unit and still nothing. I have tried the unplugging the battery trick and again nothing. I am starting to run out of ideas here. The black wire was broken once and my splice fixed it. The second time my splice (as well as the mechanics) won't fix it and my mult-imeter reads full continuity all the way to where it is grounded in the engine compartment. I am pretty sure this isn't the BCU gone bad. Any ideas? I listed my symptoms below

    Symptoms:
    -A/C compressor does not kick on
    -ALL the windows are stuck up
    -Airbag light is on
    -Seatbelt light is on
    -Dash lights are stuck on high with no dimming
    -Horn does not work
    -The info center does not read temp or anything else but the compass works
    -Dome light will not turn off

    That is about it. To me this all relates back to those wires running through the door but they were all triple checked and came out ok. Any ideas?
  • Thank you! My windows haven't worked for about a year now. I had previously tried looking at those wires, but I couldn't see anything. I settled on the PCM but let it be. Did a google search and found your post and checked again. It was the black wire on mine which broke completely in half. The orange wire was well on its way. I cut the orange stipped them both and crimped them with copper crimpers. Little electrical tape and everything works great. Thanks again!
  • two things first of hello mmy name ios steve i just got a 2002 jeep grand cherokee laredo v8
    three regulators were broke i replaced them one went fine but the right rear one that i replaced theres no power going to the door except the speaker [weird]
    i know the reg works cause we powered it with an external source and it went up and down
    Do you know what would cause this

    also i found water in my trunk on driver side and 2-3 inces of water in my spare tire comp what would cause this
  • misterg53misterg53 Posts: 1
    Check the other doors ,I've had three out of the four doors have broken wires in the boots.There should be a recall on all of the wiring in the doors
  • bsemigbsemig Posts: 1
    question where the heck is the bcm located on a 2005 GC
Sign In or Register to comment.