Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Jeep Grand Cherokee Electrical Problems

13468924

Comments

  • tidestertidester Posts: 10,110
    It sounds like the accessory switch for your ignition key is faulty.

    tidester, host
    SUVs and Smart Shopper
  • i have a 98 Grand Cherokee with 224,836 miles 2 weeks ago the AC blower would intermediately stop blowing now it blows but the ac stopped blowing cold. i know thats not what you had wrong but this is what is happening now. driving home my instrument panel went dead. all guages, radio, blower, power windows and locks quit working etc. vehicle stayed under power. then the gauges came back to life and went out again. drove 30 miles and it came back on. What the heck is going on. I have had little to no problems. the other wierd thing is that my rear passenger window hasnt worked in 2 yrs after this episode the window now works.
  • heydenoheydeno Posts: 6
    My jeep started doing the same thing but not only when i would turn but when i stopped at a light. It seemed if i kept it reved up to 1000 on the rpm it didn't die. Now I am having trouble with it starting. I can't trust it I have replaced about everything on the thing except for the PCM which seems to be where it is leading
  • barryzbarryz Posts: 43
    ok, today my 99 grand cherokee laredo 6cyl 4wd went to the mechanic with this identical problem, and as i thought it was the cps (crank position sensor) which fixed this problem. final cost $193, of which $61 was part, rest was labor and tax. i took to a NAPA auto repair center. Dealer wanted about $300 total. Do it yourselfers beware, this part is very hard to get to, in a extremely tight fit in an almost impossible to reach place behind engine on top of bell housing. And its not as simple as just unbolt old, bolt new, as the sensor has to be adjusted to have a certain gap between it and the marker for it inside housing, as it works by a magnetic field, which may explain why so many do it yourselfers on this site replaced cps and it didn't fix and then kept spending on other parts with no success. i got a 1 year 12k mile parts and labor warranty on this. Save the do it yourself items for simpler tasks, even the mechanics have trouble with this one with all the proper tools.
  • gaj2888gaj2888 Posts: 5
    This light has remained on for about two weeks now. There appears to be no problem with the emergency brake or my regular breaks? Is it possibly a bad sensor?
  • georgeg4georgeg4 Posts: 2
    I bought my 1996 Grand Cherokee Laredo second hand , It was running fine and now I am having problems with the alarm I disconnected the switches on all the doors and now when I start it the alarm sounds and the headlights flash for several minutes . But the vehicle runs . Is there any way to disable the alarm . I can operate with the flashing headlights but I had to disconnect the horn . Another related problem is the gauges and power windows will not operate while the ignition is in the run position they will however momentaril;y work if zI turn the key close to the start position . It is not in the switch or the column because I replaced both of them attempting to correct the problem
  • This happened to mine about the same time of year..Dec 2008. You've probably sold it by now? What I did was fit a relay into the circuit to the feed to blower motor, which only (really comes on when ignition is switched on....I even kept original spade connector in place, if someone later wants to fix the proper way, since then...cured..basic, but safe and works...
  • court1980court1980 Posts: 1
    I have a 2005 Jeep Grand Cherokee 3.7L truck has been running fine except the radio suddenly stopped working three weeks ago. I went to the store last night turned off my truck and when I returned 5 mins later it wouldn't start! All lights on the dash work, headlights are fine, windows work, sunroof etc. the truck just would'nt start it was silent. No clicking or problems trying to turn over, just silence almost like the key was only turned halfway. This happen once before a few weeks ago and 10 mins later it started fine. Last night I ended up having to leave my truck there after trying to start it for an hour. This morning started up fine!
    Any suggestions???
    Could this be electrical?
  • tuggajbtuggajb Posts: 646
    fiest thing i would change is ignion switch
  • Hi, I owned a 1994 Jeep Grand Cherokee for 11 yrs and am still sorry I sold it. Even worse that I replaced it with a 2005 which has big time electrical problems on the gauges,heat,blower and signals. Anyway back to your problem. My Jeep would start fine all week when I drove to work but come Monday morning if it sat all weekend the battery was dead and it would not start. Same thing happened while on vacation on Northern Mich after it sat all week. When I took it to the dealer it turned out that I had too many maps in the glove box which was causing a slow draw on the battery as the glove box light stayed on ( and I could obviously not see this with the glove box closed). I took all the maps out of the glove box and never had the problem again. Good Luck Carolyn996
  • OK first the dumb part of this topic. A few weeks ago I took my Grand Cherokee with a sunroof through the car wash. I noticed water coming through by the headliner and quickly found out you don't take vehicles with sunroofs through the car wash. Almost immediately after that my UConnect which is the mirror mounted type quit working. My question is is there a fuse or relay that could have possibly tripped in the system causing it not to work? I have looked around and can't find any wiring diagrams for this system. Help please!
  • 96jeep296jeep2 Posts: 11
    i have a 1996 jeep grand cherokee 200,000+, i bought a obd2 scanner for my car it give me a few error code one of the code is p0350 witch is no cam shaft poss sensor signal at the pcm. if this happens the pcm dose 2 things. 1st it shuts down the relay for your ignition/fuel pump 2nd it shuts down the relay for your ASD (atuo-shut-down replay) both shuts off your car while driveing or doing anything. this could be fix 1-2 different things pcm, needs to be reprogramed (not istalling a new one) must be reprogramed, cam sensor needs to be replaced. The best advised i could give any one that has a jeep and wants to keeps it, is..... go get your self a hanye's book on your car and do it your self, it's lest expencive, and your learn how to SOLVE issues. Did you know that a kit to repair a transmition is only 200.00$$$. and when you bring your car to get serviced they charge you oohh any were from 1200-2200 depends on the probolem. Ill help anybody that needs it just ask, i am not a mecahnic just a well informed jeep owner.
  • 96jeep296jeep2 Posts: 11
    If your not leaving any thing on in the car, thus causeing your battery to be drained, then its not getting a good recharge, i would take a look at the alternator.
  • well i get in it the morning or whenever and sometimes it ackes like it dead then i turn the key off and try again and nothing turn the key back off and the gauges go nuts back and fortht. but lately after that the car starts right up but before i would half to reset the battery to get going any one have any idea i was told it could be the computer of the body computer thanks you
  • can someone please help me
  • tuggajbtuggajb Posts: 646
    i would change the ignition switch as that is a lot cheaper to changr than the pcm could be bad contacts
  • eric_geric_g Posts: 1
    My 98 Cherokee starts normally, but sometimes, after driving for a few minutes, the 'Check Gauges' light comes on and the amp gauge drops to 9 volts. This continues until the engine is shut off. On restart it will be OK. It does not happen very time but it's happening often enough now to cause me to worry.

    Any suggestions as to what the cause/fix might be?

    Thanks
  • dknjdknj Posts: 1
    I have a 2004 Jeep Grand Cherokee with something similar.

    Sometimes it will start and run perfectly. Other times, it will not even attempt to start but I will hear the CD changer in the back of the SUV loading all the CD's. I can then wait 5 minutes and it will start perfectly. I notice when it won't start that the instrument dials do go crazy but only when attempting to start it. When it is running, it does seem to run fine.

    I have it at a mechanic right now. Initially they told me it was the battery however, I know that is not the entire problem.

    Stay tuned,
    Donna
  • sraesrae Posts: 1
    The guy who jumped the battery reversed polarity, melted a fusible link off the pos. terminal. What else can I expect? Please don't tell me my computer is trash, you hate to see a grown man cry. It turns over, no start. suggestions?
  • My wife has a 1999 Jeep Grand Cherokee Limited. The power windows don't work, the controls for the radio on the steering wheel don't work and the overhead console only shows what direction you are traveling and not what the temperature is. Also the lights on the inside of the Jeep stay on no matter what you are doing. The console for the windows and door locks, the power windows no longer work, but the power door locks still work and so do the controls for the mirrors. The memory seat controls also no longer work. Any suggestions?
  • I hate to be the bearer of bad news but we had very similar problems with our 2000 Jeep Grand Cherokee... all electrical in nature. We replaced sensors and other less expensive items...however in the end replaced the electrical control panel/unit...and all problems were resolved. This appears a very commen problem with JGC as they get older.
  • I am having the same problems with my 1999 Jeep Grand Cherokee. It first started when I set the factory security system off and the gauges started going nuts with a strange fast clicking sound coming from behind the instrument panel.Now this happens 1 out of 5 times when I shut down the car. Nothing electrical works when this is happening and the only way to fix it is to disconnect the battery and reset the system.Anyone have any ideas?
  • mmm I seem to have the same problem. Came to the car this morning , had difficulty getting in and eventually after pressing the button about fifty times the door opened and now i have exactly the same problem as you have described but also my air con shows it is working but doesn't and the heater only gives out hot.
    Over the last couple of months I have had to put my key fob almost at the window before it would open. don't know whether this is related.
  • i have a grand cherokee 3.1 2000 Turbo Diesel Automatic. right i was driving along the road the other day and everything just completely locked up, braked a couple of times and stopped. i could drive it in secound and first, as i had to get it to the side of the road. today i decided to have ago at driving it down the road in "drive" again and it was fine at a low speed (like 7-10mph) then when it went quicker it braked twice and went to a complete stop (didnt make a noise though). i put it in to 2nd and the same kinda happened again, so finally i put it in to 1st and it went quite a distance up the road but it did the same again(same again no noise). reverse works aswell btw. the reason i was tihnkin it was an electrical problem was because the transmission fluid is perfect, it doesnt smell burnt or look black and i thought that if it was something mechanical it just wouldnt drive at all or make a clunking noise.

    btw ive also had a problem with starting it, i can turn the key to turn the radio on but its takes a couple of goes to turn the engine on as it just make a clunking noise. also aircon hasnt worked and one of the electric seats doesnt work.
  • Could be a transmission sensor going out. Our JGC would all of a sudden stall for no apparent reason and any speed. Mechanic said this is typical of the transmission sensor...when got hot it would shut off the engine.
  • thanks for your speedy reply.
    ours doesnt stall it just seems to brakes shapely, engine still running.i think it does it when its trying to go in to 2nd gear.

    does anyone know if the gearbox had completely gone if the car would move forward, because i would have thought if it was the gearbox had gone it just wouldnt go into 1st or 2nd gear

    weve been driving round for about 12 months now without the prob shaft on the front of the car. could that have caused something to happen to it.

    its as if the car is tied to a piece of rope and once the rope runs out it just comes to an instant hault (if you get what i mean lol) if that helps.
  • My son has a 2005 Grand Cherokee and the headlights come on and off while driving. He sometimes has to turn the headlight switch to get them to work again. Anybody have this problem or any suggestions?
  • pole2pole2 Posts: 17
    I had same problem in my Dodge Dakota 2201. I had to replaced Central Timer Module. Located on the left side from driver sit. 5 minutes job but unit cost about $250
  • Thanks pole2.............turns out my problem is a multifuctional switch located in the steering column. About 1 hour job and part is around $ 70-80 bucks.
  • revellrevell Posts: 2
    Hi folks, I have a seriously strange problem. Two days ago my turn signals, and air controls on the dash went out (blown fuse 10amp). Replaced the fuse and all is good, so I thought. The moment I placed the gear selector into Reverse the fuse blows again. The fuse blows if I go from Park to Reverse, or Neutral to Reverse.
    It works fine in Drive,2nd,1st, and Park.
    So now I have no Reverse lights due to the fuse being blown. I have tried disconnecting the reverse light switch from the transmission, no luck... Also I have removed the reverse light bulbs, no luck... I have checked other bulbs for corrosion,etc. no luck....
    Why would my Reverse gear be taking out my turn signals and air controls?
    Can anyone tell me what might be the problem here??
    I have never had any electrical problems before,until now. And I have never heard of anything like this.
13468924
Sign In or Register to comment.