Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Dodge Stratus

11820222324

Comments

  • I am from russia.I have 2002 stratus with engine 2.7.I use engine oil mobil 1 5w50 and I have no what problems with the engine.Many people use this oil and too have no what problems with the engine.And that the bulb of pressure of oil did not blink, it is necessary to remove condensation from an end face of a socket on the gauge.Thanks for attention. I hope that my advice will help somebody. Forgive for bad English
  • 96es96es Posts: 3
    my 96 ES V6 is making a rattiling noise and i dont know where it's coming from.
    when it's trying to start i hear it under me like a loose floor pan or something but when it's running i hear it over by the passenger side i have no idea what it is please help
  • 96es96es Posts: 3
    i have herd a lot complaints about the airbags not going off in a crash i have a 96 ES V6 and i want to know if it's safe to drive because if the airbags aren't gonna go off i dont want any thing to do with it
  • 96es96es Posts: 3
    it's probleby just the transmsion shifting from second to first my grand parents intrepid did that i suggest taking it to a delarship and see what they say
  • I bought my college daughter a 2004 Dodge Stratus with the 2.7 engine. It now has 40,000 miles on it.

    I didn't really do the research on this engine before I bought it and now all I hear what a bad engine it is from car experts.

    I'm curious if there are any people who use this site that have put a least 100,000 miles on this engine without the sludge problem ruining the engine.

    Also, I'd like to know what maintenance schedule was used for those who got longevity with this engine.

    I currently have been changing the oil at 3,000 mile intervals with Mobile 1 synthetic. I hope this helps.

    I live in a small town. Today I heard at the auto parts store that there are a least five 2.7 engines in town that are shucked and the owners changed the oil regularly at 3,000 mile intervals. Supposedly these blown engines had less than 70,000 miles.
  • vvicevvice Posts: 2
    Mine has 175,900+ miles on it with no engine problems thus far besides a very small oil leak around the valve cover - (tightening the valve cover bolts has stopped or significantly slowed the leak, so no gasket change made yet), and a water pump failure a few days ago.

    I change oil every 5M miles & filter every 10m miles. The most important thing I've found with mine is that it does NOT perform well at high RPM's. Avoid exceeding 3M rpms - even when starting from a cold start - and mine gives no trouble and even gets 31 - 33 mpg.

    My only complaint with the engine and EVERYTHING else about this car is that you have to disassemble the entire vehicle to change or repair ANYTHING. The left front wheel & wheel well has to be removed to get to the battery!
  • egummegumm Posts: 1
    I have a 98 dodge stratus 2.4 cylinder. I have never had a problem with it ever. Until. My car was running hot. I put in a new water pump. Mind you, you have to mess with the timing. So I fixed the timing after that. It is correct now. Ever since them My car has not been running right. I changed the distributor ignition coil. It is only running on 2 cylinders. First it ran, it just seemed like it wanted to stall when you were stopped at a light. then all of a sudden it wouldnt start. Now for some reason. We have to jump the battery to start it . But, Im not driving it on only 2 cylinders.I took it to a mechanic he told me he couldnt fix it. They think it has something to do with the wiring hernis. Do you think that is possible? It would be a great help.

    I will be back on my computer tomorrow or sunday...

    Thank you in advance.
    Elise
  • jeeper87jeeper87 Posts: 1
    :) Hi guys, I have a 95 dodge stratus and when I turn on the defrost it squeals really loud. This only happens in defrost. If I turn it off and then back on again it is ok for 5-10 mins and then it does it again. What could be causing this? Any info is appreciated.

    Thanks
    Jeeper87
  • 99strat99strat Posts: 5
    My 99 is currently in an automotive electrical shop with similar problems. My mechanic said alternator, but the problem returned. The electrical guy thinks it's an electronic control module. I'll let ya know how it turns out.
  • I went to basic training and advanced individual training. When I came back my 01 dodge stratus wouldn't start. So jumped started it with my truck and it started fine except that the whole car was vibrating. After about 5 min the car was still vibrating but not as badly. When I put some gas in the car and drove it home. It wouldn't start anymore. I got the spark plugs changed and the battery checked which was still good. I'm getting a whirring sound so I'm almost certain it isn't the starter. Any ideas what it could be. I'm open for any ideas.
  • 99strat99strat Posts: 5
    Msg 399, cont'd...Auto electrician said "stopped looking after 1 hr. and $1,500 repairs...blah blah blah." Looked around, hated my options, went for second opinion. Pep Boys changed the battery and so far running great. CHECK ENGINE light is on so I looked under the hood to make sure it was still there. Yep...purring like a kitty. Ain't in a hurry to turn that light off...mileage jumped 10% ever since it came on. Will get back if battery turns out to be a bandage - not a solution.
  • i'm havin da same problem how did u fix it?
  • i'm havin the same problem how did u fix it
  • clbeverclbever Posts: 1
    I have a 2006 Stratus Sedan. Bought it used and dealer only had one key for it. Made spares. Several times car wouldn't turn over at all. Dealer had it twice to go through it and came up with nothing. Realized it must be the spare key. Each time it wouldn't start, we were using the spare key. Does this car require a special key for a spare? LIke the original fob? If so, what do they run in price? I hate having only one key. Thanks.
  • The engine feels like it's under a heavy load when driving at any speed and fuel mileage is really bad. It is worse later in the day(warmer) and it seems to be associated with the a/c cycling. Occasionally the a/c will just quit cooling. With the a/c switched off I feel a slight surging(I feel this is a different issue), but the loaded condition goes away. Any advice would be great.
  • richie29richie29 Posts: 2
    same thing just recently during our recent northeast heat wave. well gas milage has been a problem for awhile but didn't give it much thought until plus $3.50 a gallon.
  • phastphast Posts: 8
    You may want to check your speed sensors on your transmission. There are two and not very expensive. Symptoms would be as if the car is stuck in gear and won't shift (automatic trans) and you'll note that the tach or engine speed is high. don't drive the car any distance or speed in this condition as the trans may be damaged.

    I'm not a pro mechanic but I own and work on my cars one being a Stratus.

    If your A/C is cycling it may indicate it may need a charge. Possible leak.

    Hope this helps you, good luck.
  • phastphast Posts: 8
    Opinions to the cause? No fault codes, no check engine light, plugs (all) look good Suspect failing O2 sensor along with a old cat going south. 1998 Stratus with >100K on it.
  • phastphast Posts: 8
    Anyone have a problem with the door light switch acting like it's loose and have that annoying door alarm with the door locks opening and closing? Factory recall?
  • bethvbethv Posts: 1
    Went to work last night parked car smoke started coming out hood. Water fine oil fine runs fine not missing or anything, opened hood smoke was coming from a box that the spark plugs go into. Don't have money to just take to a shop can fix myself if possible, how do i figure out what that box is and how to fix whats wrong. Thanks
Sign In or Register to comment.