Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Jaguar S-Type

1272829303133»

Comments

  • rebjagrebjag Posts: 1
    After thirty years of driving Ford pickup trucks I sold my truck to buy a 2000 S-Type Jag. From the moment I first put the 3.0 in gear and started to drive...waves of my youth driving a '71 XKE came flooding over me. It seemed the Ford side of the S-Type was a merger of the best of two worlds. The 3.0 in the S Jag was certainly not the 3.0 I had in the Ford that was sold to buy the Jag.

    The S-Type Jag (2000 3.0) with 85,000 miles on it handles perfectly on steep curvy mountain roads. It has the same independent rear suspension as the old XKE making it take sharp curves flat and tight with the smoothness of a cat. The "J" shift automatic performs flawlessly when used as a stick shift on mountain roads.

    (For those who may have had troubles with the tranny.....it could be because it is important to know when to shift by keeping an eye on the RPMs and and having your ears and feet in tune with the sound of the engine and feel of the transmission of power from the engine to the wheels. More on that in the proper message thread later).

    The Jaguar S-Type 3.0, 2000 model, has had the fewest recalls of any year model of the S-Type. It had one.

    Like any Jag it needs to be pampered and serviced frequently. ... just like a good wife...to avoid breakdowns.

    I will stick with the S-Type in my stable and keep it tip top driving condition with special care to the cosmetics of the interior and exterior.....this make and model Jag will remain a 'classic' for all time as will all of the S-type Jags of the first decade of this century.

    While the purchase price is seemingly low now for what was an expensive car when new......as disgruntled owners toss them away to the folks who end up junking them from lack of funds or know how to keep them going, those of us who are passionate about the benefits of the S-Type will be the ones who reap the rewards of increasing values as their numbers on the streets diminish.

    Keep your S type Jags because they are already classic cars. :D
  • oldcemoldcem Posts: 309
    I share your sentiments - I currently have a 2006 S-Type VDP with the 4.2 V8. It's a hoot to drive - a muscle car in a tuxedo.

    Regards:
    OldCEM
  • With very low miles, 37,000. British racing green, all the bells and whistles, and so far I love it. Then again just got it this past sat :)

    Drove a BMW, Mercedes and a comparable Lexus and no comparison. Jaguar is way more luxurious and a better ride. It's a really beautiful car.

    As long as the transmission or engine doesn't fall out I'll be a happy camper!
  • gr8catgr8cat Posts: 21
    Penny, if you enjoy your STR 1/5 as much as I enjoy mine 2003 with 115 km's when I bought it (actually my husband bought it for me as a Mother's day present last year - no such good luck this year), you'll be in heaven ALL THE TIME you're driving it or just plain looking at it. I've put 25,000 km's on my Cat since last year and have had no major problems with it. Can still hardly tell the engine is running and the tranny, despite what my son, and sometimes myself, put that long suffering power train through, it just purrrrrs along, seemingly quite content. Have come close though to loosing the bonnet leaper a few times and that's the only problem we've had. So, good luck, and ENJOY.
  • jimsjagjimsjag Posts: 5
    Stick with the older model, it appears the later models have problems with the gearboxes. I have a 99 s-type, and apart from a little pinking she performs excellently.
  • jimsjagjimsjag Posts: 5
    Jag versus a Lincoln, come on you for real?
  • jimsjagjimsjag Posts: 5
    Sure there are horror stories, and it is very much pot luck if you get a "good one", do your homework first, check out common probs before trying them out, so thast you are knowing what to look for. After all we Brits are "qwerky" and a little eccentric. If you don't need rear leg room check out an XK?
  • jimsjagjimsjag Posts: 5
    Seems you are in the wrong forum, perhaps you should join the Ford or Merc forum?
  • I have a 2005 S Type Jaguar, and about a month ago, I was just driving along and every light on the instrument panel lit up . The car kept running, but, I could not get the lights to go off . At one point I stopped the car and the car locked up on me .
    Just about as I was going to get it towed, it started and no lights . This lasted a few days until it started all over again. My guess is the computer is sending random signals all over the place . As you would guess I brought it to the dealer whereupon, it was fine, no codes, and today runs fine . My question is , has anyone run into this, and I am just fooling myself that all is fine. I think the panel is about $ 1,000.00 or more so it would be nice if I did not have to replace it . In addition I have the Climate Control Problem blowing hot air all the time . A great purchase I guess Thanks for any advise Jack
  • My 05 Jaguar S Type has been at the dealer I bought it from for over two months. They can't figure out how to fix it. It's kind of similar to your example. One day I started it and drove about 100 yards and it died. Various messages started running across the screen. I took it to the dealer who duplicated the same instance. They've tried to put a new dashboard in and that didn't work Called in an advanced team from Jag with the newest diagnostic equipment and still haven't found out the culprit. The funny thing is, the car always ran. It would kill about once a day but then start and I could drive it normally. The dealership said it was the strangest issue they've ever had.
  • H E L P ! My 2001 s type 4.0 (120 k) has virtually every type of problem sensor imaginable from the "driver rear door open" to" the kid in the back seat has a runny nose" yet after having my oil changed only 1000 miles ago my car started making a sever engine noise. When I pulled over I found I was over 4 quarts low on oil. (no, it has never leaked) I added oil and barely made it to my driveway before it completely cratered. Where in the hell was my"low engine oil light" indicter or why wasn't I afforded the privilege of the "limp" mode to save me from blowing my engine. It's taken me 4 days just to face this situation. If it's blown are there less expensive Ford substitute motors or can anybody help me to get to day 5. So angry at self for low oil and so depressed not knowing what step to take next.
  • ewysockiewysocki Posts: 14
    I have a question that I have not seen addressed as of yet. My 07 S Type 3.0 I just purchased used with less than 19K miles on it has a vibration or hum at about 55-65 MPH. Seems this is a common issue with all S types with AWD. Is anyone having a similar experience. Otherwise I love the way the car handles and drives. Seems super fast with the 3.0 litre motor. Thanks for any help anyone can provide. My email is stryyder56@aol.com if anyone cares to reply online rather than through the forum
  • june14june14 Posts: 1
    Hi,
    I also want to swap the CD and burrow ribbons of the panel
    for a DVD with GPS navigation, LCD 7 ". My 2001 Jaguar S-TYPE -
    green, and is new and beautiful. Did you install the DVD ALPINE
    IVA is W5005 with GPS?
    Regards
  • ewysockiewysocki Posts: 14
    Hi this is my second post on this subject. After several trips to the local Jag dealer, after he road forced balanced all four tires/wheels, this is after his suggestion of tires out of round, shifted belts etc. The vibration was still there. Finally I found out through other sources that it could be the drive shaft. Well I took this news to him, the service writer, and he just looked at me like I did not know what I was talking about. The car had only 18 K miles and was still under the factory warranty. Reluctantly he chatted with the service manager who swore it was the left front wheel that was bad, or the CV joint. Well they brought in some sort of vibration computer to determine the cause of the vibration. Low and behold it was the DRIVE SHAFT...........there was no thank you from the service folks by the way. Did not cost anything because in was still under warranty.....so far so good, of course that is what the man said as he jumped off of the building and when he was half way down, said so far so good.
  • sunbird94sunbird94 Posts: 1
    my grandfather has a 1963 jaguar mk10,and a 1964 jaguar mk10 as his daily driver.the 63 is sitting on blocks in our garage for 5 yrs now,went out last night let the fuel pump filter twice,pushed the starter button and it fired right up filling my garage with smoke.good classic and rare car,where lucky to have two of this real british automobiles
  • tjg328tjg328 Posts: 5
    :cry: I have a 06 S Type and when I tried to uses my navigation system I have no audio. It will show me where I am going and all and the radio / cd have sound. I have removed the cd and cleaned it good and even reset it all. still no sound. Anyone have any clues to what would cause this problem?
  • 2OOO S TYPE 4 LITER DOHC W/VAR TIMING .1 OF THE PLASTIC CHAIN
    TENSIONERS BROKE AND SNAPPED THE SECONDARY TIMING CHAIN
    ,BENDING 2 EX VALVES. IN MY HASTE TO REPLACE VALVES I TOOK OFF
    TIMING CHAINS AND LOST MY TIMING.I KNOW ABOUT THE THE CAMS
    ,FLATS ON TOP AND CLAMPING BAR ACROSS THE 2 FLATS.WHERE DO I
    POS CRANK?.ONE MANUAL SAYS POS #1 CYL TDC ,ANOTHER SAYS POS #1
    CYL TDC AND ROTATE CRANK 45 DEGREES ,KEYWAY SHOULD BE AT 6
    OCLOCK POS.BOTH MANUALS SAY TO INSERT SPECIAL BOLT INTO CRANK
    SENSOR HOLE AND LOCK FLYWHEEL.I AM TOTALLY CONFUSED.I DONT
    WANT TO BEND ANY MORE VALVES AND HAVE TO TAKE HEADS OFF
    AGAIN.PLEASE HELP
  • vaboy3vaboy3 Posts: 2
    I have a 2008 Jaguar S type. Yesterday I lost the audio from my radio and CD and discovered that the mute function is now on. We cannot find a way to switch the mute off and the Jaguar dealer was of no help. How can we switch the mute off?
  • rayainswrayainsw Posts: 2,506
    edited August 2011
    Have you tried pressing the lower left button
    on the left side of the steering wheel? [ 2009 ]
    Edit:
    Or the top button - if there are 3 along the
    steering wheel edge [ 2007 ].
    I do not have a 2008 manual in .pdf ......
  • Thank you for getting back with me. I have sinced taken to dealer an they found the problem which there was a setting on the nav sys that some how gotten turned down causing the audio not to work when using the nav sys. You wouldn't know where I can get a cd for it other then the Jag dealer ? $ 199.00 is a bit high I think.

    TY
  • Cant get to that forum with your http
  • I have a dream car...the Jag...I have to get an older used model. Any suggestions on the best type and year to look for. What is a good price. Is repair high on the Jag. What should I look closely for when checking out the vehicle. Was looking at the Stype 2000 to 2004 online. Could use any suggestions that yall could give me. I am in KY and we do get snow not usually real bad. Will it handle good in the snow and ice? Help please contact ba32347@live.com
  • I just bought a 06 S Type 3.0 an love the car no problems in the2 1/2 yrs of having it. I paid 20,000 for it. Keep in mind have to run prim gas in it. I get about 22 - 23 miles per gal. An oil changes are about 70.00 way less then my BMW. Good Luck!!
  • - Was it resolved?
    - Was the vibration between 45 and 65mph?
    Seems that this problem is a widely spread one, and Jaguar maintenance doesn't have any communication concerning ways to fix it!
    Send an update please!
  • Hi, yes it was. They replaced the prop shaft. According to the dealer, this was in some maintenance bulletin. I had told them about this earlier in the process but they did not want to seem to go in that direction. They kept on insisting it was a wheel balance issue. They balanced the wheels 3 times with no improvement. They then placed a vibration monitor on the vehicle and took it for a test drive. It pointed them to the prop shaft. Hope this helps........... :) :) :)
  • I am torn between two automobile purchases 1) A Certified 2008 Honda Civic CR-V 2WD EX-L w/Navigation and has 50,232 miles for $19,500 and 2) A 2010 Mazda CX-7 FWD i SV and has 18,832 miles for $17,999 which of the two would be a better purchase option in terms of reliability and maintenance costs?
  • debi42kdebi42k Posts: 3
    I have seen a lot of posts where people are complaining about vibration with their S-Types, in almost every year model. I don't see a lot of answers to the posts, however. I have a 2006 3.0L S-Type, drive very aggressively & am just about to hit the 50,000 mile mark. I also was annoyed by constant road noise & vibration and was told it was just a "character flaw" of the vehicle. Well, I didn't want to settle for that answer. I started researching tires & it seems that the recommended tires for Jags is a Performance tire. Performance tires do not have as much "give" and provide a more rigid ride, hence the road noise & vibration.

    I recently needed 4 tires and opted for Touring tires. What a difference! There is very little vibration and I didn't know the car was so quite. Unless someone wants to know specificall, I am not going to indicate the brand of tires because this isn't an advertisement. As in everything, there are always mitigating facters - You must keep the wheels balanced & the car in proper alignment (duh). Different parts of the country have different weather extremes to struggle with so this may not hold true for everyone but it probably will for about 90%.

    I would be interested to hear if anyone has tried this change & if so, did it work for you as well as it did for me?
  • xjsguyxjsguy Posts: 8
    I have a perfect 1993 XJS convertible.
    I have Michelin Harmony tires on Dayton Jag mags.

    It is imperative that the balancing is performed correctly.
    When I purchased the tires, it had a vibration above 70 all the way to over 100mph.
    I purchased the tires and had them balanced at a shop I've been patronizing for many years.
    I learned that they do not have the proper equipment to balance my wheels/tires correctly so, I took it to the mechanic who does all the rest of the work on the car.
    It is a superior shop and, the owner loves my car which leads him to take good care of it.
    I had them re-balance the tires and, when I took it up to about 130mph, it was as smooth as if it was parked.

    Have you had the balance checked by a competent shop?
  • Thank you for your reply. I did not see it until NOW LOL I still have the car, but it has certainly been an adventure . I was so fed up with the lights going on and off I just parked the car for months . something with unhooking the battery cables and putting them back on and off seemed to reboot the computer or something . I took it to Jaguar and like you, they had no idea , even with specialists . I had had it and had it towed to the dealer and they said it was working fine ? From that day on it has never done it again , cross my fingers . However, It was blowing hot air as well . I had to have something replaced there , but , eventually it needed a new compressor, the radiator sprung some unexpected leake and had to be replaced, the coolant tank was replaced, and just this week I had to replace the transmission case as it was leaking oil and it shuddered when shifting gears . Now I have put so much money into it, I cant affort to get rid of it. Hope yours is running better now

    Jack
Sign In or Register to comment.